Can not drag and drop from network shares to most apps

Bug #1715883 reported by Colin Leroy-Mira on 2017-09-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Incomplete
Undecided
Unassigned
Thunar File Manager
Fix Released
Medium
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

Dropping a file from a network share into most applications (Claws Mail, Chromium, Thunderbird, ...) fails silently. This is because the URIs sent by Nautilus are GFVS URIs with various schemes (smb://, davs://, ...) and most applications doing POSIX I/O can't do anything with them.

This is easy to check by dropping a file from a network share into the Terminal.

Colin Leroy-Mira (colin-colino) wrote :

Nautilus migrated to gitlab.gnome.org.
The patch for this bug is at https://gitlab.gnome.org/GNOME/nautilus/merge_requests/2

Colin Leroy-Mira (colin-colino) wrote :

Thunar suffers from the same bug.

Changed in thunar:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in thunar:
status: Confirmed → Fix Released
gf (gf-interlinks) wrote :

Hello Colin,
Thank you for submitting this bug and reporting a problem with drag and drop from network shares IN Ubuntu. You made this bug report some time ago and Ubuntu has been updated since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you let us know and, run the following (only once):
apport-collect 1715883
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu better.
G

gf (gf-interlinks) on 2018-07-20
Changed in nautilus (Ubuntu):
status: New → Incomplete
Changed in nautilus:
status: New → Incomplete
Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.