don't start new shell when moving to new directory

Bug #731745 reported by Adam Dingle on 2011-03-09
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus Terminal
Wishlist
Fabien LOISON

Bug Description

When I move to a new directory, Nautilus Terminal starts a new shell in the terminal window, rooted at the new directory. The contents of the terminal window are cleared, which is unfortunate: I'd like to be able to scroll back to see the commands that I issued before. Instead of starting a new shell, I think Nautilus Terminal should simply issue a 'cd' command in the terminal window to change to the new directory.

Fabien LOISON (flozz) wrote :

The problem is that nautilus destroy the terminal when you change of directory... I have no solution for the moment... :(

Changed in nautilus-terminal:
status: New → Confirmed
Fabien LOISON (flozz) on 2011-03-09
Changed in nautilus-terminal:
importance: Undecided → Wishlist

For me this is close to a blocker bug.

In Dolphin, I would go into a folder, set off a long-running command (e.g. a gimp batch script on a 100 photos), then navigate into other folders while that runs. With nautilus terminal, this is impossible… (well, I can nohup, but it shouldn't be necessary)

Fabien LOISON (flozz) wrote :

@Kevin Brubeck Unhammer:

You are right, it is a very annoying bug, but I haven't any solution for the moment... :(

To fix this issue we could temporay stock an in two files the history and the old current folder.

Don't you think ?

Fabien LOISON (flozz) on 2011-08-21
Changed in nautilus-terminal:
assignee: nobody → Fabien LOISON (FLOZz) (flozz)
milestone: none → 1.0
Fabien LOISON (flozz) on 2011-08-21
Changed in nautilus-terminal:
status: Confirmed → Won't Fix
status: Won't Fix → Fix Committed
Fabien LOISON (flozz) on 2011-10-17
Changed in nautilus-terminal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers