Terminal on desktop

Reported by Jan on 2010-09-18
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Nautilus Terminal
Low
Fabien LOISON

Bug Description

On upgrading to Maverick, it got weird:
I had the nautilus-terminal on the desktop – it was placed behind gnome-panel. I wonder if this is a feature …

I can not confirm this with Lucid.

Fabien LOISON (flozz) wrote :

it is not a feature... Nautilus should not ask for a terminal here :/
I will blacklist the Desktop folder...

Changed in nautilus-terminal:
assignee: nobody → Fabien LOISON (FLOZz) (flozz)
importance: Undecided → Low
milestone: none → 0.6
status: New → Confirmed

I know, it was a bit of a joke. ;)

Fabien LOISON (flozz) wrote :

I committed a fix...
You should not see a terminal on your desktop anymore :)

Changed in nautilus-terminal:
status: Confirmed → Fix Committed
Fabien LOISON (flozz) on 2010-09-20
Changed in nautilus-terminal:
status: Fix Committed → Fix Released
Seria (andreas-boettger) wrote :

I have 0.6~ppa0 installed (Lucid). And I have a terminal on my desktop. Where is the fix placed?

Fabien LOISON (flozz) wrote :

The fixes does not seems to work for everyone :/
I'll check

Changed in nautilus-terminal:
status: Fix Released → Triaged
Fabien LOISON (flozz) on 2010-09-21
Changed in nautilus-terminal:
milestone: 0.6 → 0.7
Fabien LOISON (flozz) wrote :

I found why the fix does not work... on the desktop Nautilus gives the home path to the plugin instead of the desktop path -__-'

([fr] http://forum.ubuntu-fr.org/viewtopic.php?pid=3740736#p3740736)

Devon Jones (soulcatcher) wrote :

is there a way for us to manually do some configuration to eliminate the terminal on the desktop? Like can we edit the list of folders blacklisted?

Fabien LOISON (flozz) wrote :

@Devon Jones
There is no editable blacklist for the moment...

But the desktop folder is already blacklisted by defaut... The problem is that Nautilus return the home path instead of the desktop one when it creates the desktop :/

Simon (simonbcn) wrote :

@Fabien LOISON (FLOZz) See the screenshot about nautilus configuration. Perhaps that is the problem.

Nic Brough (grobbendonk) wrote :

I have the same problem - I get a nautilus terminal bar across the top of the desktop, with the gnome panel over it. It works fine, but I don't want it there ;-)

Can I add more info that might help?

nZain (patrick-stalph) wrote :

I'd be willing to help, too. Same problem on lucid. By the way, I do not have the "desktop_is_home_dir" property activated, but stil get the terminal on the desktop.

ValHue (valhue) wrote :

nZain, I have the same problem. Too on lucid.

Narsil (alterne) wrote :

Just for info : Works fine on my netbook (lucid NBR) bur not on my desktop (lucid)

Fabien LOISON (flozz) wrote :

@Simon:
the desktop_is_home_dir property is not the problem...

~~~~

I'm looking for a solution... :(

Devon Jones (soulcatcher) wrote :

So what changed in .6 that caused this? it didn't do it in .5 (at least not to me)

Devon Jones (soulcatcher) wrote :

I am a python dev, though I've never worked in the gnome type environment. I would be happy to dive in, but I have no idea how to debug in this kind of environment. Is there any place I can see the results coming out of stderr or stdout? How do I get my nautilus to use the version in my dev directory instead of the installed one?

If I can get those two answers, I may be able to pitch in and lend this another pair of eyes.

Fabien LOISON (flozz) wrote :

@Devon Jones#15:
the only change liked to the desktop is from line 667 to 683:
http://bazaar.launchpad.net/~flozz/nautilus-terminal/0.x/annotate/head%3A/code/nautilus-terminal.py#L667

@Devon Jones#16:
It is a bit boring to debug a nautilus-extension... :(

1. You are obligated to install the plugin (copy the .py file in the /usr/lib/nautilus/extensions-2.0/python directory).

2. For seeing the stdout/stderr you have to attach Nautilus to the terminal... on Ubuntu, the easiest way to do it is to type the following command:
  $ sudo nautilus --no-desktop

Devon Jones (soulcatcher) wrote :

ok, I've got a patch, and I also have an easier way to debug this app for you.

so first, debugging:
if you leave all the other files from the package the same, you can rm /usr/lib/nautilus/extensions-2.0/python/nautilus-terminal.py
instead create ~/.nautilus/python-extensions, and you can symlink nautilus-terminal.py into that (or develop it from there).

I added python logging then instrumented NautilusTerminal.get_widget and printed uri so I could see what that looks like for the desktop and for the path alike.

Turns out that the uri for the desktop looks like this:
x-nautilus-desktop:///

vs the uri for directories looks like this:
file:///home/devon

so basically added if
uri.startswith('x-nautilus-desktop'):
  return

to the beginning of get_widget and it solved the problem. You can probably remove the code later in that function that detects the desktop dir, because i think this will catch any reference to the actual desktop.

Devon Jones (soulcatcher) wrote :
Devon Jones (soulcatcher) wrote :

Damn uploader kept selecting my desktop file. Here's the real patch

Fabien LOISON (flozz) wrote :

x-nautilus-desktop:/// ... why I have not see that :(
I am maybe a bit tired...

~~~~~~~~

The bug is fixed (someone can confirm ?)

~~~~~~~~

@Devon Jones:
Thank you :)

Changed in nautilus-terminal:
status: Triaged → Fix Committed
nZain (patrick-stalph) wrote :

the patch works fine (lucid) and also fixes lp:644968

eMcE (emce) wrote :

I have the same problem on Lucid.
How should I apply this fix?

Fabien LOISON (flozz) wrote :

@eMcE:
You have to download the latest source revision, or apply the Devon Jones' patch to your installed version... But the simplest way is to wait.

I will out the 0.7 tomorrow :)

nZain (patrick-stalph) wrote :

If you can't wait, download the patch from devon, navigate to the location of the "nautilus-terminal.py" script:
 $ cd /usr/lib/nautilus/extensions-2.0/python/
and apply the patch to the python script by calling
 $ patch < path/to/the/downloaded/nautilus-terminal.py.patch

eMcE (emce) wrote :

@nZain.. thnx.

@Fabien.. Ok, I wait for new wersion.
:)

erythro (erythro) wrote :

With the Desktop folder being blacklisted, the terminal won't show up if you navigate to /home/[username]/Desktop in nautilus.
I would like it to still show up in the folder, but not on the desktop itself. Will this fix affect that as well?

Fabien LOISON (flozz) wrote :

@erythro:
It is already fixed for the version 0.7 ;)

Fabien LOISON (flozz) on 2010-09-23
Changed in nautilus-terminal:
status: Fix Committed → Fix Released
eMcE (emce) wrote :

Yes.. now v.0.7 works ok.
Thnx :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers