Menu not showing in Nautilus after installation

Bug #836601 reported by Laudeci Oliveira on 2011-08-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus Image Manipulator
Undecided
Unassigned
nautilus-image-manipulator (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

After install, log off, reboot, the menu never shows up in oneiric.

Laudeci Oliveira (laudeci) wrote :

The problem is the lib location on gnome3, it was changed from /usr/lib/nautilus/extensions-2.0/ to /usr/lib/nautilus/extensions-3.0/

Emilien Klein (emilien-klein) wrote :

Thanks Laudeci, this seems a good explanation. I will fix that in the Debian package (Ubuntu's upstream package source). However, I'm not sure I know how to get that fixed in Ubuntu before Oneiric ships (it's frozen right now). Any ideas?

Emilien Klein (emilien-klein) wrote :

Laudeci,

I don't have a copy yet of Oneiric, could you help me diagnostic this issue by running this command?

pkg-config --variable=pythondir nautilus-python

On natty it returns the following:
/usr/lib/nautilus/extensions-2.0/python

That's the directory where the nautilus extension gets installed (configured in ./setup.py). I would expect this to be "extensions-3.0" instead of 2.0 on Oneiric. So if that's the case, the package should put the extension in the right place, which it's apparently not doing right now.

Note: You would need this package installed: python-nautilus

laudeci@pandora:~$ pkg-config --variable=pythondir nautilus-python
/usr/lib/nautilus/extensions-3.0/python

---------------------------------------------------------------------------------------------------------------------------
Laudeci Oliveira
Official Ubuntu Member
Red Hat Certified Technician
Tecnólogo em Sistema de Informação

2011/9/4 Emilien Klein <email address hidden>

> Laudeci,
>
> I don't have a copy yet of Oneiric, could you help me diagnostic this
> issue by running this command?
>
> pkg-config --variable=pythondir nautilus-python
>
> On natty it returns the following:
> /usr/lib/nautilus/extensions-2.0/python
>
> That's the directory where the nautilus extension gets installed
> (configured in ./setup.py). I would expect this to be "extensions-3.0"
> instead of 2.0 on Oneiric. So if that's the case, the package should put
> the extension in the right place, which it's apparently not doing right
> now.
>
> Note: You would need this package installed: python-nautilus
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/836601
>
> Title:
> Menu not showing in Nautilus after installation
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/nautilus-image-manipulator/+bug/836601/+subscriptions
>

Emilien Klein (emilien-klein) wrote :

When i build the package in Oneiric Beta 1, the nautilus extension gets properly placed in `/usr/lib/nautilus/extensions-3.0/python`. So the debian source package has no problem, but the .deb has apparently not been rebuilt for Ubuntu (i.e. specifically in the context of Gnome 3). Laudeci, do you know if the packages are supposed to be rebuilt? If not, is it possible to get this one rebuilt? Would you know who I should contact to get this rebuilt?

Changed in nautilus-image-manipulator:
status: New → Confirmed
Emilien Klein (emilien-klein) wrote :

So the package got built on the Ubuntu autobuilders (see build log [0]) on 2011-05-20 08:52:55 UTC. I suspect that at that time the Gnome3 packages were not yet used, so it built the package for a Gnome2 environment, putting the extension in /usr/lib/nautilus/extensions-2.0/python. Now that the Gnome3 libraries are used, the package should be rebuilt.

I suspect that other packages will be affected by this kind of issues. I quickly checked the nautilus-open-terminal package, but since it got created later (on 2011-06-28 11:32:02 CEST), it already uses the Gnome3 extension directory.

[0] https://launchpadlibrarian.net/72073367/buildlog_ubuntu-oneiric-i386.nautilus-image-manipulator_0.3-1_BUILDING.txt.gz

Matthias Klose (doko) wrote :

no change re-upload needed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-image-manipulator - 0.3-1build1

---------------
nautilus-image-manipulator (0.3-1build1) oneiric; urgency=low

  * No-change rebuild for newer GNOME libs. (LP: #836601)
 -- Daniel T Chen <email address hidden> Mon, 12 Sep 2011 09:10:42 -0400

Changed in nautilus-image-manipulator (Ubuntu Oneiric):
status: New → Fix Released
Changed in nautilus-image-manipulator:
status: Confirmed → Fix Released
Emilien Klein (emilien-klein) wrote :

Even after rebuilding the package and putting the extension in the 3.0 folder, the menu still fails to show. I've opened bug#849361 to continue investigating. It seems that the extensions should go in another folder starting with nautilus-python 0.7.0 (according to that package's README file).

Melroy vd Berg (openlaptop) wrote :

Well the new path is: /usr/share/nautilus-python/extensions

gl ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers