myunity-3.1.5 won't build on quantal, wrong version Gambas

Bug #1109201 reported by Pander on 2013-01-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MyUnity
Undecided
Unassigned

Bug Description

myunity-3.1.5 won't build on quantal, wrong version Gambas. Quantal provides version 3 of Gambas but the source files are in format of version 2. Running make results in

gbc2 -a -t -p .
make: gbc2: Command not found
make: *** [build] Error 127

if gbc3 is used, it results in

gbc3 -a -t -p .
FMain.class: error: Bad form file version
make: *** [build] Error 1

when running verbose with debug information, it results in

gbc3 -vg -a -t -p .
Removing .info and .list files

------------------------------------------------------------------------
Compiling FMain.class...
FMain.class: error: Bad form file version

Please fix this because myunity 3.1.3-0ubuntu1 does not work with Quantal. It reports only in

Ubuntu 12.10
Sorry, Ubuntu release not supported.

Pander (pander) wrote :

Please see http://gambasdoc.org/help/doc/gb2togb3?v3 to upgrade the source code

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers