Ubuntu 12.10 not supported version

Reported by Paolo Sammicheli on 2012-06-06
112
This bug affects 23 people
Affects Status Importance Assigned to Milestone
MyUnity
Critical
Pixel
myunity (Ubuntu)
High
Santiago

Bug Description

Testing MyUnity on Quantal alpha1 Italiano. MyUnity doesn't starts because the 12.10 version is not in the support list yet.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: myunity 3.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic i686
ApportVersion: 2.1.1-0ubuntu2
Architecture: i386
CasperVersion: 1.317
Date: Wed Jun 6 16:27:38 2012
LiveMediaBuild: Ubuntu "Quantal" - Build i386 LIVE Binary 20120606-13:35
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: myunity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Paolo Sammicheli (xdatap1) wrote :
description: updated
summary: - Ubuntu 12.10 versione non supportata
+ Ubuntu 12.10 not supported version
affects: myunity (Ubuntu) → myunity

Yep, same here. Is there a force option?

Changed in myunity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in myunity:
status: New → Confirmed
importance: Undecided → Critical
philinux (philcb) wrote :

Same on 64 bit.

Running from a terminal gives this error "WARNING: gMainWindow::setToolBox not yet implemented".

C Schilder (cschilder) wrote :

Hi there,

Does anyone know if there is an update availlable for MyUnity on Quantal Quetzal?
If do a package availlability check using the webgui of rmadison ( http://people.canonical.com/~ubuntu-archive/madison.cgi ),
I can see that there is a package availlable for Quantal.
When I try to install this version, it still shows a message about not supported 12.10.
Does anyone know some sort magic how to trick MyUnity in a 12.10 supported mode?
Is there for instance a cli parameter to suppres this message?

The result is shown with this url: http://people.canonical.com/~ubuntu-archive/madison.cgi?package=myunity&a=&c=&s=

In 3.1.3 Main.module, one of the first actions is:
  IF Uversion <> "11.04" AND Uversion <> "11.10" AND Uversion <> "12.04" THEN
    FMessage.SimpleMessage("Ubuntu " & Uversion & "\n" & ("Sorry, Ubuntu release not supported."), "MyLogo_small.png", "dialog-error.png", "Close")
    QUIT
  ENDIF

So there doesn't appear to be any easy magic trick. There are many other places in the code where the version is checked and conditional code is executed depending on the version.

Instead I installed gconf-editor to do what I want, but it was a pain compared to having a simple tool like MyUnity.

I hope the developers won't slap me, but out of curiosity I tried fetching the source with
apt-get source myunity
cd /myunity-3.1.3
and replaced the code in #5 above with:
  IF Uversion <> "11.04" AND Uversion <> "11.10" AND Uversion <> "12.04" THEN
    IF Uversion = "12.10" THEN
      FMessage.SimpleMessage("Ubuntu " & Uversion & "\n" & ("Horrible kluge, faking as 12.04"), "MyLogo_small.png", "dialog-error.png", "Close")
      Uversion = "12.04"
    ELSE
      FMessage.SimpleMessage("Ubuntu " & Uversion & "\n" & ("Sorry, Ubuntu release not supported."), "MyLogo_small.png", "dialog-error.png", "Close")
      QUIT
    ENDIF
  ENDIF

I then followed the instructions in INSTALL.rst (use sudo for the long apt-get install line) up to and including 'make'.

./myunity

As far as I can tell, things still work ok at present, e.g. I changed the launcher width, its transparency, etc.

At such an early stage (Alpha1) I guess this isn't surprising, but I would expect later changes will break this hack, i.e. this cobbled MyUnity will no longer be compatible with changes in the desktop config files. Usual disclaimers, you get to keep both halves, I offer a full refund of what you paid me, yada yada.

Kudos to the MyUnity authors, I've never used Gambas, but that INSTALL.rst file told me all that's needed.

Pixel (fabio-colinelli) wrote :

Sorry but I have been very busy.
In the coming days will release MyU updated version with support for Quantal.

@ JohnWashington: best solution, but we can not use it :D
every version of Ubuntu (11.04, 11.10 etc.) has different characteristics of Unity and you must verify the individual keys.

Regards

Pixel (fabio-colinelli) on 2012-06-27
Changed in myunity:
assignee: nobody → Pixel (fabio-colinelli)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package myunity - 3.1.5-0ubuntu1

---------------
myunity (3.1.5-0ubuntu1) quantal; urgency=low

  * New upstream release. (LP: #1009590, #986544)
  * debian/patches/: drop, the only patch has been adopted upstream.
  * debian/control: drop Vcs-{Bzr,Browser}, unused.
 -- Andrea Colangelo <email address hidden> Tue, 12 Jun 2012 08:46:36 +0200

Changed in myunity (Ubuntu):
status: Confirmed → Fix Released
Pixel (fabio-colinelli) on 2012-07-12
Changed in myunity:
status: Confirmed → Fix Released
Lamberto Acyatan (obet1767) wrote :

Compiz cube affects MyUnity while in zooming in 12.10. Shadow still appear in transparency.

Viktor Suprun (popsul1993) wrote :

If remove file ~/.config/dconf/user then myunity hasn't been launched.

$ myunity
Main.?.0: #6: Type mismatch: wanted Integer, got String instead

The dconf settings has been removed because after update unity to version 6.6, the launcher and dash was ugly, and any changes in myunity did not give any effect.
P.S. Sorry for my english.

philinux (philcb) wrote :

I see Myunity has now been deleted with no change log.

http://www.ubuntuupdates.org/package/core/quantal/universe/base/myunity

Chris Chappell (ckchappell) wrote :

Having been playing with 12.10 today and very disappointed there is no myunity. I mean it should be a default program by golly.

Ephraim (thilo) wrote :

12.10 Beta2 - Myunity depends on gambas2, but Beta2 includes only gambas3 :( ....
what now?

Ephraim wrote: "12.10 Beta2 - Myunity depends on gambas2, but Beta2 includes only gambas3 :( .... what now?"

Perhaps it's time to convert MyUnity to Python? Gambas runs faster than Python, but speed doesn't matter for a config tool and it seems as though Gambas will always be a second class citizen.

The two languages are superficially quite similar, so much so that when I first opened up the source of MyUnity and glanced at it, for a few moments I thought it was Python!

Santiago (ogai7) on 2012-10-24
Changed in myunity (Ubuntu):
assignee: nobody → Santiago (ogai7)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers