Mytharchive calling ffmpeg with wrong resolution

Bug #138857 reported by Jovaro on 2007-09-11
2
Affects Status Importance Assigned to Milestone
MythTV
Invalid
Unknown
mythplugins (Ubuntu)
Undecided
laga

Bug Description

When I tried to create a DVD with some recordings I chose the Long Play format. Mytharchive will then call ffmpeg to re-code the mpeg files with resolution 352x576. This is obviously wrong and ffmpeg terminates.

laga (laga) wrote :

Why is this "obviously" wrong? According to Wikipedia, it's a valid DVD resolution.

Please provide more details, including the exact messages produced by ffmpeg.. You can find log files in the temporary directory you set in the mytharchive settings.

Changed in mythplugins:
status: New → Incomplete
Jovaro (bug-jovaro) wrote :

It is wrong because ffmpeg want a width x height resolution. 576x352 would be ok.

Snippet from progress.log
************************************************************
2007-09-11 18:09:09 ERROR: Failed while running ffmpeg to re-encode video.
Command was ffmpeg -threads 2 -v 1 -i "/media/filer/temp/work/1/newfile.mpg" -r pal -target dvd -b 2344k -s 352x576 -acodec ac3 -ab 192 -ac 2 -copyts -aspect 4:3 "/media/filer/temp/work/1/newfile2.mpg" -map 0:0 -map 0:1
2007-09-11 18:09:09 ************************************************************

Snippet from ffmpeg man page
 -s size
           Set frame size. The format is wxh (ffserver default = 160x128, ffm‐
           peg default = same as source).

laga (laga) wrote :

Hello,

thanks for clarifying the issue.

I'll report it upstream.

Changed in mythplugins:
assignee: nobody → laga
status: Incomplete → Confirmed
laga (laga) wrote :

I've just noticed that there's already a bug report filed in the MythTV bug tracker:

http://svn.mythtv.org/trac/ticket/3961

Jovaro (bug-jovaro) wrote :

That was me this morning. I forgot to write it here :)

Changed in mythtv:
status: Unknown → Invalid
laga (laga) wrote :

Looking at the upstream bug, it seems that this is not something we can resolve. I'll close this as "invalid" now. If you have any objections or a possible fix, please re-open.

I have to admit I really don't want to wrap my head around this issue right now, especially if it's only caused by people not capturing with a x576 resolution.

Changed in mythplugins:
status: Confirmed → Invalid
Jovaro (bug-jovaro) wrote :

Invalid is good. It turned out that the error wasn't caused by a wrong resolution but by a wrong audio-bitrate. This bug is resolved upstream. http://svn.mythtv.org/trac/ticket/3314
I'll try to do some better research next time...

Jovaro,

This hasn't yet been applied to -fixes has it? We can get that patch in
gutsy at least (provided it applies cleanly) if you'd like. I guess there
is a chance it might not since it's against ffmpeg isn't it?

Regards,

Mario

On 9/17/07, Jovaro <email address hidden> wrote:
>
> Invalid is good. It turned out that the error wasn't caused by a wrong
> resolution but by a wrong audio-bitrate. This bug is resolved upstream.
> http://svn.mythtv.org/trac/ticket/3314
> I'll try to do some better research next time...
>
> --
> Mytharchive calling ffmpeg with wrong resolution
> https://bugs.launchpad.net/bugs/138857
> You received this bug notification because you are a member of MythTV
> Ubuntu Maintainers, which is the bug contact for MythTV.
>

--
Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

I looked a wee bit closer, and these are all applied to the current -fixes checkout we've got. Things should be better.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.