Mythbuntu, Ubuntu derivative focused upon MythTV

Upgrading using the live cd wipes /var/lib/mythtv/*

Reported by Thomas Mashos on 2012-04-30
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Critical
Unassigned
Ubuntu CD Images
Undecided
Unassigned
partman-target (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson
ubiquity (Ubuntu)
Undecided
Unassigned
Precise
High
Stéphane Graber

Bug Description

[Impact] Serious data loss when using the live CD upgrade option.
[Test Case] Install 11.10. Create some files under /var/lib/mysql/ and /var/lib/mythtv/ (doesn't matter exactly what). Use the live CD upgrade option to upgrade to 12.04 using an in-place install. Check that the files you created still exist.
[Regression Potential] Limited to the upgrade option; this code is not used elsewhere. If that option still works otherwise then it should be fine.

Original report follows:

When using the live cd to upgrade, it wipes /var/lib/mythtv/* (presumably /var/*) meaning you lose the database and the default storage group locations

Thomas Mashos (tgm4883) on 2012-04-30
Changed in mythbuntu:
milestone: none → 12.04.1
Thomas Mashos (tgm4883) on 2012-04-30
no longer affects: mythbuntu/12.04
Changed in mythbuntu:
status: New → Confirmed
importance: Undecided → Critical
Mario Limonciello (superm1) wrote :

What's happening is that the "Upgrade" the live CD offers doesn't maintain the MySQL database or the recordings that are stored in the default /var/lib/mysql and /var/lib/mythtv.

I believe this is happening in partman-target (finish.d/clear_partitions). I'm not sure if there is any room to add special cases though.

Changed in partman-target (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
status: New → Confirmed
Changed in partman-target (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2012-05-11
Changed in partman-target (Ubuntu Precise):
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-target (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-target (Ubuntu Precise):
importance: Undecided → High
Changed in partman-target (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

The duplicate of this bug concerns other databases in /var/lib/mysql.

Colin Watson (cjwatson) on 2012-07-04
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-target - 78ubuntu1

---------------
partman-target (78ubuntu1) quantal; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Disable automatic mounting of USB removable devices.
    - Mount floppies with 'exec' and 'utf8'.
    - Use the path of the file associated with a loop device in /etc/fstab,
      rather than the filesystem's UUID or the loop device path.
    - Always set the loop option for loop devices.
    - Remove critical system files from the existing filesystem before
      installing.
    - Preserve the UID and GID of the initial user, if possible. Requires a
      patch to user-setup.
    - Check that all system partitions are formatted.
    - Stop adding removable devices to /etc/fstab, now that apt knows how to
      find CD-ROM devices using libudev.
    - Notify user-setup if there is an encrypted home partition present.
    - Stop creating /var/run and /var/lock on the root filesystem, now that
      these are symlinks into /run.
  * finish.d/clear_partitions: Don't remove /var/lib/mysql or
    /var/lib/mythtv, since they contain user data in the form of databases
    (LP: #992241).

partman-target (78) unstable; urgency=low

  * Team upload

  [ Joey Hess ]
  * Stop adding /proc to /etc/fstab on Linux (automatically mounted)
    Closes: #674481 Thanks, Roger Leigh

  [ Christian Perrier ]
  * Turn XC-Package-Type into Package-Type

  [ Joey Hess ]
  [ Updated translations ]
  * Tibetan (bo.po) by Tennom
  * Welsh (cy.po) by Dafydd Tomos
  * Basque (eu.po) by Piarres Beobide
  * Lao (lo.po) by Anousak Souphavanh
  * Lithuanian (lt.po) by Rimas Kudelis
  * Latvian (lv.po) by Rūdolfs Mazurs
  * Macedonian (mk.po) by Arangel Angov
  * Panjabi (pa.po) by A S Alam
  * Portuguese (Brazil) (pt_BR.po) by Felipe Augusto van de Wiel (faw)
  * Traditional Chinese (zh_TW.po) by Yao Wei (魏銘廷)
 -- Colin Watson <email address hidden> Wed, 04 Jul 2012 15:05:56 +0100

Changed in partman-target (Ubuntu):
status: Confirmed → Fix Released
Colin Watson (cjwatson) on 2012-07-04
Changed in partman-target (Ubuntu Precise):
status: Confirmed → In Progress

Hello Thomas, or anyone else affected,

Accepted partman-target into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-target/77ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-target (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Required some tricks to be able to test the partman-target fix, but yeah, the fix works.

I'm going to add an ubiquity task as this will need a rebuild of ubiquity to actually be rolled out to the precise images.

verification-done for the partman-target bits.

tags: added: verification-done
removed: verification-needed
Changed in ubiquity (Ubuntu):
status: New → Fix Released
Changed in ubiquity (Ubuntu Precise):
status: New → Triaged
assignee: nobody → Stéphane Graber (stgraber)
importance: Undecided → High
milestone: none → ubuntu-12.04.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-target - 77ubuntu2.1

---------------
partman-target (77ubuntu2.1) precise-proposed; urgency=low

  * finish.d/clear_partitions: Don't remove /var/lib/mysql or
    /var/lib/mythtv, since they contain user data in the form of databases
    (LP: #992241).
 -- Colin Watson <email address hidden> Wed, 04 Jul 2012 15:12:53 +0100

Changed in partman-target (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in ubiquity (Ubuntu Precise):
status: Triaged → In Progress
Brian Murray (brian-murray) wrote :

Hello Thomas, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Precise:
I verified that the version of ubiquity 2.10.18 in -proposed fixes the issue. After installation /var/lib/{mythtv|sql} are still there and content is untouched.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.19

---------------
ubiquity (2.10.19) precise-proposed; urgency=low

  * Automatic update of included source packages: base-installer
    1.122ubuntu7.1, debian-installer-utils 1.88ubuntu2.1, flash-kernel
    2.28ubuntu42.2. (one-time update from precise-proposed) (LP: #1021293)
 -- Stephane Graber <email address hidden> Mon, 30 Jul 2012 10:36:51 -0400

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in mythbuntu:
status: Confirmed → Fix Released
neutron68 (neutron68) wrote :

I downloaded the 32-bit 11.10 ISO file on Super Bowl evening (2-3-2013) from:
http://cdimage.ubuntu.com/mythbuntu/releases/11.10/release/

I used the Live-CD to try and update from Mythbuntu 11.04 to 11.10.
(Booted from the CD, chose Install Mythbuntu, Chose Upgrade from 11.04 to 11.10)

The SAME THING that was reported on 4-30-2012 happened to me last night:

"What's happening is that the "Upgrade" the live CD offers doesn't maintain the MySQL database or the recordings that are stored in the default /var/lib/mysql and /var/lib/mythtv."

That 11.10 32-bit ISO file was NEVER fixed.
That ISO needs to be DELETED from the download folders and remade without this bug.

How many other versions have this bug??

Eric

Adam Conrad (adconrad) wrote :

The mythbuntu/oneiric images have been removed from cdimage by request of the flavour admins. This should propagate to mirrors shortly.

Changed in ubuntu-cdimage:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers