Mythbuntu, Ubuntu derivative focused upon MythTV

Enable libcec support in mythtv

Reported by Bradley Baetz on 2012-04-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mythbuntu
Undecided
Unassigned
12.04
Undecided
Unassigned
libcec (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
mythtv (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Mythtv 0.25 supports using libcec (http://libcec.pulse-eight.com/) and a special USB adapter to let the TV remote (rather than an IR blaster) control mythtv.

Enabling this just involves adding 'libcec-dev' to Build-Depends in v0.25, except the libcec version in Precise is a straight import from Debian, and that version is too old, so requires updating too.

I'm using this on a new mythtv box I've set up, and apart from requiring me to use the source code to work out what keybindings to configure, it works quite well.

Mario Limonciello (superm1) wrote :

Does this *really* need a newer version of libcec? Or will the version in precise do the trick? If the version in precise will do the trick, then this can be closed as I just backported that to the 0.25 and 0.26 PPA's on all the builds they do.

If this requires a newer version than that in precise, we really need to get that fixed first before backporting.

Changed in mythbuntu:
status: New → Fix Committed
Bradley Baetz (bbaetz) wrote :

It needs 1.0.5, and precise has 1.0.3 (as does debian unstable)

The hardware manufacturer has a PPA with 1.0.5, but the packaging is slightly different to the upstream one and doens't cleanly install over it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcec - 1.6.1-1

---------------
libcec (1.6.1-1) unstable; urgency=low

  [ Mario Limonciello ]
  * New upstream version (LP: #982272)

  [ Andres Mejia ]
  * New release fixes build failure with GCC-4.7. (Closes: #667241)
  * Bump to Standards-Version 3.9.3.

 -- Andres Mejia <email address hidden> Sat, 21 Apr 2012 00:02:08 -0400

Changed in libcec (Ubuntu):
status: New → Fix Released
Mario Limonciello (superm1) wrote :

OK, gotten 1.6.1 in Debian, and Precise. I just did the backports to the Mythbuntu 0.25 PPA as well. So next autobuild on the PPA should have it.

Changed in mythtv (Ubuntu):
status: New → Fix Committed
milestone: none → later
Mario Limonciello (superm1) wrote :

I've confirmed tonight's autobuilds have it enabled. To be clear, this is not functional in precise, only in autobuilds ATM.

Changed in mythbuntu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.25.0+fixes.20120626.25dd4ce-0ubuntu1

---------------
mythtv (2:0.25.0+fixes.20120626.25dd4ce-0ubuntu1) quantal; urgency=low

  * fix get-orig-source rule's broken tarball fetch from archive.
  * Enable libcec support (LP: #982272)
  * Add missingok to additional mythtv-backend logs. (LP: #982162)
  * Pull an updated snapshot of Mythbuntu theme, to avoid theme
    downloader telling the user there is an updated theme on first
    boot.
  * Test for an empty key on public mysql. (LP: #989371)
  * Update amejia's email on uploaders field.
  * Drop recommends on adept-notifier.
  * Bump standards version.
  * Update apport hook for python3 (LP: #1013171)
  * New upstream checkout (25dd4ce)
 -- Mario Limonciello <email address hidden> Tue, 26 Jun 2012 11:22:57 -0500

Changed in mythtv (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2012-08-08
Changed in mythtv (Ubuntu):
milestone: later → none

Hello Bradley, or anyone else affected,

Accepted mythtv into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mythtv/2:0.25.2+fixes.20120802.46cab93-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mythtv (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Mario Limonciello (superm1) wrote :

I've validated that the build is happening with libcec support enabled now.

https://launchpadlibrarian.net/112345806/buildlog_ubuntu-precise-i386.mythtv_2%3A0.25.2%2Bfixes.20120802.46cab93-0ubuntu1_BUILDING.txt.gz
--------------------------------------------------------
# Basic Settings
Compile type profile
Compiler cache yes
DistCC no
qmake /usr/bin/qmake
install prefix /usr
runtime prefix /usr
CPU x86 x86_32 (i686)
yasm yes
MMX enabled yes
MMX2 enabled yes
3DNow! enabled yes
3DNow! extended enabled yes
SSE enabled yes
SSSE3 enabled yes
CMOV enabled yes

# Input Support
Joystick menu yes
lirc support yes
libCEC device support yes [/usr/include]
Video4Linux sup. yes (v1 no)
ivtv support yes
HD-PVR support yes
FireWire support yes
DVB support yes [/usr/include]
DVB-S2 support yes
HDHomeRun support yes
Ceton support yes
IPTV support yes
ASI support no

# Sound Output Support
PulseAudio support yes
OSS support yes
ALSA support yes
JACK support no
libfftw3 support no

# Video Output Support
x11 support yes
xrandr support yes
xv support yes
VDPAU support yes
VAAPI support yes
CrystalHD support yes
OpenGL video yes
MHEG support yes
libass subtitle support yes

# Misc Features
multi threaded libavcodec yes
libxml2 support yes [/usr/include/libxml2]
libdns_sd (Bonjour) yes
libcrypto yes
Frontend yes
Backend yes
OpenGL ES 2.0 no

# Bindings
bindings_perl yes
Perl config options INSTALLDIRS=vendor
bindings_python yes
bindings_php yes

# External Codec Options
mp3lame yes
faac yes
xvid yes
x264 yes
vpx yes
--------------------------------------------------------

CEC requires special hardware though, so I don't know we'll be able to validate any further (unless the reporter also tests the SRU).

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.25.2+fixes.20120802.46cab93-0ubuntu1

---------------
mythtv (2:0.25.2+fixes.20120802.46cab93-0ubuntu1) precise-proposed; urgency=low

  * New upstream fixes branch checkout (46cab93)
  * Updated to 0.25.2 point release. (LP: #1029522)
  * Major fixes:
    - Mythfilldatabase takes hours instead of minutes to run (LP: #997367)
    - A popular tuner card doesn't record in digital cable mode (trac 10712)
  * fix get-orig-source rule's broken tarball fetch from archive.
  * Enable libcec support (LP: #982272)
  * Add missingok to additional mythtv-backend logs. (LP: #982162)
  * Pull an updated snapshot of Mythbuntu theme, to avoid theme
    downloader telling the user there is an updated theme on first
    boot.
  * Update amejia's email on uploaders field.
  * Drop recommends on adept-notifier.
  * Bump standards version.
  * New upstream checkout (25dd4ce)
 -- Mario Limonciello <email address hidden> Wed, 08 Aug 2012 20:32:13 -0500

Changed in mythtv (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers