Mythbuntu, Ubuntu derivative focused upon MythTV

keyword missingok is missing in mythtv-backend logrotate config

Reported by Andreas Roth on 2012-04-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mythbuntu
High
Unassigned

Bug Description

I'm using the ​mythbuntu 0.25 repository for Ubuntu and every day i get a report about the daily logrotation of mythtv-backend:

/etc/cron.daily/logrotate:
error: stat of /var/log/mythtv/mythcommflag.log failed: No such file or directory
error: stat of /var/log/mythtv/mythjobqueue.log failed: No such file or directory
error: stat of /var/log/mythtv/mythpreviewgen.log failed: No such file or directory
error: stat of /var/log/mythtv/mythtv-setup.log failed: No such file or directory
error: stat of /var/log/mythtv/mythmediaserver.log failed: No such file or directory
error: stat of /var/log/mythtv/mythtranscode.log failed: No such file or directory
run-parts: /etc/cron.daily/logrotate exited with return code 1

i checked the config file and the keyword missingok is missing for all log files in mythtv-backend. the keyword is present in all other logrotate config files (e.g. mythtv-frontend).

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Mythbuntu, not only by opening this ticket, but suggesting a solution. With a proposed solution, I'm marking this as Triaged.

Changed in mythbuntu:
status: New → Triaged
importance: Undecided → High
Mario Limonciello (superm1) wrote :

I've committed a fix to the mythtv-fixes branch. It should be included with all autobuilds tomorrow and later (04/17/2012)

Changed in mythbuntu:
status: Triaged → Fix Committed
Andreas Roth (aroth) wrote :

The errors caused by the mythtv-backend logrotate config are gone. thanks!

But i still get two errors:
error: stat of /var/log/mythtv/mythmediaserver.log failed: No such file or directory
error: stat of /var/log/mythtv/mythtranscode.log failed: No such file or directory

I checked and the mythtranscode.log is inside /etc/logrotate.d/mythtv-transcode-utils and mythmediaserver.log is inside /etc/logrotate.d/mythtv-frontend. The solution should be the same as before, just add the missingok keyword.

Andreas Roth (aroth) wrote :

still got two errors
error: stat of /var/log/mythtv/mythmediaserver.log failed: No such file or directory
error: stat of /var/log/mythtv/mythtranscode.log failed: No such file or directory

Changed in mythbuntu:
status: Fix Committed → In Progress

Hello Andreas, or anyone else affected,

Accepted mythtv into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mythtv/2:0.25.2+fixes.20120802.46cab93-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andreas Roth (aroth) wrote :

Hi,

i just checked the packages from precise-proposed.
I'm sorry to inform you that /etc/logrotate.d/mythtv-frontend includes the definition of /var/log/mythtv/mythmediaserver.log and this logfile still lacks the missingok keyword. The same goes for /etc/logrotate.d/mythtv-transcode-utils (which defines /var/log/mythtv/mythtranscode.log).

Thanks for taking care of this litte issue.

Thomas Mashos (tgm4883) wrote :

Andreas Roth is correct, those two files don't have missingok set in logrotate. They do both have copytruncate set and on a fresh install of the 12.04.1 image (that includes the new mythtv packages) those log files exist, so this shouldn't be an issue.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Adam Conrad (adconrad) on 2012-08-16
Changed in mythbuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers