mythfrontend.real crashed with SIGSEGV in MythPlayer::calcSliderPos()

Bug #734131 reported by Josh Rosenberg on 2011-03-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MythTV
Unknown
Unknown
Mythbuntu
Fix Released
Undecided
Unassigned

Bug Description

Crashed.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: mythtv-frontend 2:0.24.0+fixes.20110312.40fc454-0ubuntu0mythbuntu1
ProcVersionSignature: Ubuntu 2.6.32-29.58-generic 2.6.32.28+drm33.13
Uname: Linux 2.6.32-29-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashCounter: 1
CrashDB: mythbuntu
Date: Sat Mar 12 21:52:58 2011
ExecutablePath: /usr/bin/mythfrontend.real
InstallationMedia: Mythbuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
Installed_mythtv_dbg: 2:0.24.0+fixes.20110312.40fc454-0ubuntu0mythbuntu1
ProcCmdline: /usr/bin/mythfrontend.real --logfile /var/log/mythtv/mythfrontend.log
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x87e022 <_ZN10MythPlayer13calcSliderPosER7osdInfob+1818>: mov (%eax),%eax
 PC (0x0087e022) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: mythtv
StacktraceTop:
 MythPlayer::calcSliderPos (this=0xaa71d078, info=...,
 PlayerContext::CalcPlayerSliderPosition (this=0xabbf34d0,
 TV::DoSkipCommercials (this=0xaa73aad8, ctx=0xabbf34d0,
 TV::ActiveHandleAction (this=0xaa73aad8, ctx=0xabbf34d0,
 TV::ProcessKeypress (this=0xaa73aad8, actx=0xabbf34d0,
Title: mythfrontend.real crashed with SIGSEGV in MythPlayer::calcSliderPos()
UserGroups: adm admin cdrom dialout lpadmin mythtv plugdev sambashare video
XsessionErrors: (polkit-gnome-authentication-agent-1:1670): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

visibility: private → public
Mario Limonciello (superm1) wrote :

Hi Josh,

Thanks for the crash report. I think everything we need is here. Could you just mention what you were doing when this happened?

Thanks,

Changed in mythbuntu:
status: New → Triaged

I was somewhere in the "Watch Videos" section, but I can't remember if it was loading the video list, trying to start a video, or trying to exit a video.

It may be worth noting that all of my videos load via samba from a Windows XP box connected wirelessly.

Changed in mythtv:
status: Unknown → New
Changed in mythtv:
status: New → Unknown
Mario Limonciello (superm1) wrote :

Upstream has committed a fix for this in both 0.25 (master) and 0.24-fixes branches. Any autobuilds containing the date 03/15 or later will include it.

master fixed in 96f2ed44755a31223be3

fixes/0.24 fixed in 785ea1b3604f44c05f0f

Changed in mythbuntu:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.