Mythbuntu, Ubuntu derivative focused upon MythTV

Hauppauge remote not working on upgrade to Maverick Meerkat

Reported by Kevin K on 2010-10-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Undecided
rhpot1991

Bug Description

After updating to 10.10, my Hauppauge TV card remote is no longer working. My TV card is a WinTV-PVR 150.

rhpot1991 (rhpot1991) wrote :

Why don't you try attaching some of the /etc/lirc files, as well as check your /var/log/syslog and dmesg for any lirc messages. You may also want to try changing the remote module to lirc_zilog.

Changed in mythbuntu:
status: New → Incomplete
rhpot1991 (rhpot1991) wrote :

Sorry, remote module in /etc/lirc/hardware.conf

Thomas Mashos (tgm4883) on 2010-10-11
Changed in mythbuntu:
assignee: nobody → rhpot1991 (rhpot1991)
Kevin K (stafio) wrote :
Kevin K (stafio) wrote :
Kevin K (stafio) wrote :
Kevin K (stafio) wrote :

I have attached config files from within /etc/lirc.

I tried changing:
REMOTE_MODULES="lirc_dev lirc_i2c"
in /etc/lirc/hardware.conf to:
REMOTE_MODULES="lirc_zilog"
Doing sudo /etc/init.d/lirc restart, seems to get stuck on "Loading LIRC Modules". I stopped it after 5 minutes of sitting there.

Changing the line back to the original and restarting lirc logs the following in /var/log/syslog:
Oct 13 21:36:04 mediabox lircd-0.8.7-pre3[9786]: lircd(default) ready, using /var/run/lirc/lircd
Oct 13 21:36:05 mediabox lircd-0.8.7-pre3[9786]: accepted new client on /var/run/lirc/lircd
Oct 13 21:36:05 mediabox lircd-0.8.7-pre3[9786]: could not get file information for /dev/lirc0
Oct 13 21:36:05 mediabox lircd-0.8.7-pre3[9786]: default_init(): No such file or directory
Oct 13 21:36:05 mediabox lircd-0.8.7-pre3[9786]: Failed to initialize hardware
Oct 13 21:36:05 mediabox lircd-0.8.7-pre3[9786]: accepted new client on /var/run/lirc/lircd

rhpot1991 (rhpot1991) wrote :

You want:
REMOTE_MODULES="lirc_dev lirc_zilog"

See if that helps.

Kevin K (stafio) wrote :

Same thing with:
REMOTE_MODULES="lirc_dev lirc_zilog"
Restarting lirc just hangs.

I seem to have bigger problems now. I booted up today and my mythfrontend is not displaying any of the menu items - only the background. I think I may be up for a full re-install.

Kevin K (stafio) wrote :

Fresh install - remote is not working

I tried changing to:
REMOTE_MODULES="lirc_dev lirc_zilog"

This time I get the response:
 * Stopping remote control daemon(s): LIRC [ OK ]
 * Loading LIRC modules [ OK ]
 * Unable to load LIRC kernel modules. Verify your
 * selected kernel modules in /etc/lirc/hardware.conf

Craig (craig-rouse) wrote :

I get the same thing. Fresh install of Mythbuntu Maverick and my Nova-T 500 remote no longer works. I've tried everything that's been suggested so far.

Kevin K (stafio) wrote :

It looks like somebody else has encountered this issue and was able to get things working on their system again: http://ubuntuforums.org/showthread.php?t=1598968. Hopefully the information there will help fix the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers