Shift Keys do not work in VNC

Bug #551147 reported by Greg Oliver on 2010-03-29
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Low
Unassigned
mythbuntu-default-settings (Ubuntu)
Undecided
Unassigned
x11vnc (Ubuntu)
Low
Unassigned

Bug Description

Package: libvncserver0
State: installed
Automatically installed: yes
Version: 0.9.7-2
Priority: optional
Section: libs
Maintainer: Ubuntu Developers <email address hidden>
Uncompressed Size: 455k
Depends: libc6 (>= 2.7), libjpeg62, zlib1g (>= 1:1.1.4)
Suggests: libvncserver0-dbg (= 0.9.7-2)
Description: API to write one's own vnc server
 LibVNCServer makes writing a VNC server (or more correctly, a program exporting a framebuffer via the Remote Frame Buffer protocol) easy. It hides the programmer from the tedious task of managing
 clients and compression schemata.
Homepage: http://libvncserver.sourceforge.net

Shift keys do not work when connected to VNC session. Same client connected to Karmic server works as expected. I could not find options for the keys...

-Greg

Mario Limonciello (superm1) wrote :

I've noticed this too with lucid.

Changed in x11vnc (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in mythbuntu:
status: New → Confirmed
importance: Undecided → Low
Michael Jumper (zhangmaike) wrote :

There seems to be a workaround: http://www.bramschoenmakers.nl/en/node/714

Adding the -xkb option as described in the above page solves the problem for me.

James Cuzella (trinitronx) wrote :

Can verify that adding the "-xkb" command line flag fixes the problem!

Running Mythbuntu 10.04 Beta 2 with updates from apt.

I've attached a very simple patch for the session script in /usr/share/mythbuntu/session.sh

Changed in mythbuntu:
status: Confirmed → Fix Committed
Changed in x11vnc (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → New
Changed in mythbuntu-default-settings (Ubuntu):
status: New → Fix Committed
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-default-settings - 0.96-0ubuntu1

---------------
mythbuntu-default-settings (0.96-0ubuntu1) lucid; urgency=low

  * Fix the shift key in VNC (LP: #551147)
  * Add some 16-color options for the bootsplash.
 -- Mario Limonciello <email address hidden> Fri, 23 Apr 2010 09:48:03 -0500

Changed in mythbuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released

also same problem for reverse VNC connections

adding "-xkb" on the x11vnc command line is a work-around.

Dilton McGowan II (diltonm) wrote :

Thanks for the tip on the workaround zhangmaike.

timothyjones (tim-timjones) wrote :

-xkb works for me too. Thanks!

Changed in mythbuntu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in x11vnc (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers