Mythbuntu, Ubuntu derivative focused upon MythTV

DVD ripping does not work until 'Directories that hold videos' is filled with a valid path

Reported by Peter Nauta on 2009-11-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mythbuntu
High
Thomas Mashos
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Mythbuntu 9.10, AMD64
As soon as this path is filled with a valid path like the default /var/lib/mythtv/videos, a DVD can be ripped.

Related branches

Thomas Mashos (tgm4883) wrote :

This was an oversight on my part in my enthusiasm for video storage groups. Unfortunatly, there isn't a whole lot that can be done to fix this until 10.04

Changed in mythbuntu:
assignee: nobody → Thomas Mashos (tgm4883)
status: New → Confirmed
importance: Undecided → High
Peter Nauta (pnauta) wrote :

I don't know where this is stored (mySQL, xml) but surely this can be dispatched as a patch? Otherwise, how about alerting the user during the installation procedure?

This info is stored in the DB. I can fix it for new installs on Ubuntu, but
any existing installs or anyone that installs using the ISO's are going to
run into this problem. The best I can do for 9.10 is make a note on the
release page.

On Mon, Nov 2, 2009 at 12:22 PM, Peter Nauta <email address hidden> wrote:

> I don't know where this is stored (mySQL, xml) but surely this can be
> dispatched as a patch? Otherwise, how about alerting the user during
> the installation procedure?
>
> --
> DVD ripping does not work until 'Directories that hold videos' is filled
> with a valid path
> https://bugs.launchpad.net/bugs/469583
> You received this bug notification because you are a bug assignee.
>

Peter Nauta (pnauta) wrote :

OK, that will be cool.

2009/11/2 Thomas Mashos <email address hidden>:
> This info is stored in the DB. I can fix it for new installs on Ubuntu, but
> any existing installs or anyone that installs using the ISO's are going to
> run into this problem. The best I can do for 9.10 is make a note on the
> release page.
>
>
> On Mon, Nov 2, 2009 at 12:22 PM, Peter Nauta <email address hidden> wrote:
>
>> I don't know where this is stored (mySQL, xml) but surely this can be
>> dispatched as a patch?  Otherwise, how about alerting the user during
>> the installation procedure?
>>
>> --
>> DVD ripping does not work until 'Directories that hold videos' is filled
>> with a valid path
>> https://bugs.launchpad.net/bugs/469583
>> You received this bug notification because you are a bug assignee.
>>
>
> --
> DVD ripping does not work until 'Directories that hold videos' is filled with a valid path
> https://bugs.launchpad.net/bugs/469583
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Met vriendelijke groeten,

Peter Nauta
PM4IT

MarcRandolph (mrand) wrote :

Unfortunately there is no easy way to fix this for existing installs, and this problem may fix itself if version 0.23 of MythTV is released in time for Mythbuntu 10.04. If 0.23 is not released by then, then the plan is to fix the 0.22 database in 10.04.

Changed in mythbuntu:
milestone: none → lucid-alpha1
status: Confirmed → In Progress
MarcRandolph (mrand) wrote :

I meant to say that there is no /automated/ way to fix this for existing installs. The user will have to do the configuration changes himself, as the original reporter suggests.

George Bredberg (joje47) wrote :

Im sorry, I dont understand what to fix with the rather scarse information supplied by the reporter.. Can someone please just make a short description on what has to be changed in db for it to work?
I only found the table "storage_group" but the settings there seem to be fine. Please just point out where its wrong so I can use it again.. I dont find 'Directories that hold videos'..

Thomas Mashos (tgm4883) wrote :

George, take a look at this page. It talks about something else, but should get you where you need to be.
http://baablogic.net/drupal/node/7

Hi,

Thanks a lot. You saved my world ;) Now I  only have to get the remote and lcd to work.. Im fairly new to this mythbuntu, but I like it a lot.

/George

--- Den mån 2009-11-16 skrev Thomas Mashos <email address hidden>:

Från: Thomas Mashos <email address hidden>
Ämne: [Bug 469583] Re: DVD ripping does not work until 'Directories that hold videos' is filled with a valid path
Till: <email address hidden>
Datum: måndag 16 november 2009 18.53

George, take a look at this page. It talks about something else, but should get you where you need to be.
http://baablogic.net/drupal/node/7

--
DVD ripping does not work until 'Directories that hold videos' is filled with a valid path
https://bugs.launchpad.net/bugs/469583
You received this bug notification because you are a direct subscriber
of the bug.

Status in Mythbuntu, Ubuntu derivative focused upon MythTV: In Progress

Bug description:
Mythbuntu 9.10, AMD64
As soon as this path is filled with a valid path like the default /var/lib/mythtv/videos, a DVD can be ripped.

      __________________________________________________________
Låna pengar utan säkerhet. Jämför vilkor online hos Kelkoo.
http://www.kelkoo.se/c-100390123-lan-utan-sakerhet.html?partnerId=96915014

Thomas Mashos (tgm4883) on 2010-02-02
Changed in mythbuntu:
status: In Progress → Fix Committed
Changed in mythbuntu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 0.22.0+fixes23527-0ubuntu1

---------------
mythtv (0.22.0+fixes23527-0ubuntu1) lucid; urgency=low

  [ Mario Limonciello ]
  * New snapshot (r23527)
  * debian/mythtv-database.postinst:
    - If the mythtv.cnf conffile is missing, don't freak out. (LP: #477926)
  * debian/control:
    - Build depends on libvdpau-dev for armel too. We don't know if
      tegra2's will be using VDPAU, but if they do, this will help.

  [ Thomas Mashos ]
  * Populate directories to hold videos in prefilled SQL file. (LP: #469583)
 -- Mario Limonciello <email address hidden> Sun, 14 Feb 2010 19:13:55 -0600

Changed in mythtv (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers