avi extension configured for default player (mplayer)

Bug #445984 reported by Blackpaw on 2009-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
Medium
Mario Limonciello
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Under file types the avi extension command is set to blank and "Use default player". Since videos are by default stored in storage groups now and the default player is "mplayer" which doesn't understand storage groups, playback will always fail, with "No stream found to handle url myth://Videos@127.0.0.1:6543/..." reported in the log.

the Internal player handles .avi files fine, so the avi file type entry should be set to "Internal" with "Use default player" unchecked.

Related branches

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Mythbuntu by taking the time to open this ticket. This has been confirmed to be an error in the default database and will be fixed in the next released build.

Thank you!

Changed in mythbuntu:
assignee: nobody → Mario Limonciello (superm1)
importance: Undecided → Medium
milestone: none → karmic-rc
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 0.22.0~trunk22304-0ubuntu1

---------------
mythtv (0.22.0~trunk22304-0ubuntu1) karmic; urgency=low

  * New upstream checkout (r22304)
    - Fixes crash during image loading of mythfrontend (LP: #445173)
    - Disables pulseaudio harder, fixing sound playback when it's installed.
      (LP: #436792)
  * debian/mythtv_0.22.0.sql:
    - Set Internal as the default player across the board. Looks like some
      areas were previously missed. This only affects new installs.
      (LP: #445984)
  * debian/patches/10_mythfilldatabase_log.dpatch:
    - Update to actually log to a file not a directory.
  * debian/patches:
    - Drop any patches that weren't actually being applied.
  * Set default theme to Mythbuntu rather than Mythbuntu-9.10 since upstream
    accepted it without a version number applied.
  * debian/mythtv-database.{postinst,config}:
    - Use the debian system maintainer account to set things up if possible.
    - Drop broken logic for trying to detect when slow writes are needed.

 -- Mario Limonciello <email address hidden> Wed, 07 Oct 2009 23:24:05 -0500

Changed in mythtv (Ubuntu):
status: New → Fix Released
Blackpaw (blackpaw) wrote :

Great, thanks!

MarcRandolph (mrand) wrote :

Fix was released in 9.10 RC.

Changed in mythbuntu:
status: In Progress → Fix Released

I'm running an updated 9.10 with 0.22.0+fixes22594-0ubuntu1 and still seeing this bug on a clean install.
Changed the AVI player to "Internal" in the frontend and can now play AVIs.

What does "fix released" mean when it is still broken? Released to the ubuntu repository?
Maybe there is some "reconfigure" command needed to rebuild the database?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers