transcode unencrypted DVD fails

Bug #429089 reported by rnestor on 2009-09-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
Mythbuntu
Fix Released
Medium
Unassigned
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Looks like the parameters passed by mtd to invoke transcode are incompatible with the current version of transcode (again!) This causes the import of unencrypted DVDs to fail. This is with the amd64 alpha-5 version of 9.10. The same problem occurs with MythTV installed in an amd64 alpha-5 version of Kubuntu. Obviously the import of encrypted DVDs will also fail in the same way regardless of the whether libdvdcss2 is installed or not.

Related branches

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Mythbuntu by opening this ticket. You mention "again". I did some quick searching and did not find where this had been reported (or even more importantly, resolved) previously. Could you point to any previous or current discussion or tickets on the matter? Also, have you already identified the correct parameters and/or a work-around?

Thank you!

Changed in mythbuntu:
importance: Undecided → Medium
status: New → Confirmed
Download full text (4.0 KiB)

Marc,

Thanks for picking this up! Let me give you same background on this.

I'm new to the Ubuntu family and relatively new to Linux, so bear with
me. Most of my Unix experience is with NetBSD (where I did some
development work) and more recently with FreeBSD. Last year I decided
to tackle Linux and try and build a PVR system based on MythTV. I
started with OpenSuse and actually had a working system on an old PC.
That lead me to buy new hardware to build a 64-bit, high performance
system. That's when the trouble began since OpenSuse didn't support
the new HW and I had to work with pre-release kernels and a distinct
lack of pre-built packages. I did get MytthTV with MythVideo working
and ran into the problem of parameters mismatches with mtd and
transcode there. I posted on their forums but never got much of a
response and finally tracked down the problem myself. I submitted a
bug report to the transcode team and they came up with their own fix
that didn't work (for me) with MythTV 0.21 but probably worked with
0.22. I finally gave up on OpenSuse and switched to Kubuntu a few
months ago. I have been playing with the Karmic bleeding edge stuff
so I expect problems. Over the last few days enough of the MythTV
modules were posted that I was finally able to get it up and running
again, and that's when I noticed the similar problems with transcode.
It exits when invoked by mtd. If I copy the command line mtd invoked
it with and run it from the command line, it reports that "-1" isn't a
recognized option. This is what's in the mtd.log:

  15:36:10: launching job: job dvd 1 1 6 1 -1 /video/mythtv/Videos/My
Name is Nobody
15:36:10: transcode command will be: 'transcode -i "/video/mythtv/temp/
My Name is Nobody/vob/" -g 720x480 -M 2 -1 -X2,0 -y xvid,null -A -N
0x2000 -o /dev/null --color 0 -R 1,twopass.log'
15:36:10: job thread beginning to rip dvd title
15:40:13: job thread finished ripping dvd title
15:40:15: Error: Exiting runTranscode(1) transcode exit code: 1

Here is the result of running the transcode line from the command line:

mythtv@bandit:~$ transcode -i "/video/mythtv/temp/My Name is Nobody/
vob/" -g 720x480 -M 2 -1 -X 2,0 -y xvid,null -A -N 0x2000 -o /dev/null
--color 0 -R 1,twopass.log
transcode: unrecognized option '-1'
'transcode -h | more' shows a list of available command line options.
mythtv@bandit:~$

BTW, this isn't the same option that gave me trouble on OpenSuse many
months ago so I assume intervening changes to MythTV have changed
things a bit.

Hope this helps, and thanks for bearing with me. If you'd like to to
do testing or provide additional logs and such, just let me know.
I'll do what I can but keep in mind I'm still on the learning curve
with Ubuntu.

-bob

On Sep 13, 2009, at 8:31 PM, MarcRandolph wrote:

> Howdy, and thank you for helping to improve Mythbuntu by opening this
> ticket. You mention "again". I did some quick searching and did
> not
> find where this had been reported (or even more importantly, resolved)
> previously. Could you point to any previous or current discussion or
> tickets on the matter? Also, have you already i...

Read more...

Deborah Armstrong (debee) wrote :

Same problem here with Mythbuntu, Karmic, Alpha 6, AMD-64 build. Dpkg -s reports the transcode version as:

Version: 3:1.1.4-0.0ubuntu3

I find no other binaries of transcode on my system.

My mdt.log reads:
11:49:37: a client socket has been opened
11:49:59: launching job: job dvd 1 1 7 0 -1 /var/lib/mythdvd/162-Rollings
11:49:59: transcode command will be: 'transcode -i /var/lib/mythdvd/temp/162-Rollings/vob/ -g 720x480 -M 2 -1 -j 0,8,0,8 -B 0,2 -y xvid -w 1618 -o /var/lib/mythdvd/162-Rollings.avi --color 0'
11:49:59: job thread beginning to rip dvd title
11:58:36: job thread finished ripping dvd title
11:58:36: Error: Exiting runTranscode(1) transcode exit code: 1
11:58:38: job failed: job dvd 1 1 7 0 -1 /var/lib/mythdvd/162-Rollings

If I try manually typing (well, with cut and paste!) this transcode command I get –

transcode: unrecognized option '-1'
'transcode -h | more' shows a list of available command line options.

and if I, just for fun, remove the "-1" option I get

transcode: unrecognized option '--color'

and if I remove both "-1" and "--color" then the transcode runs successfully.

The man page for transcode doesn't show either a --color or a -1 parameter either.

It's almost as if this is not the right version of transcode, but according to Synaptic it's the latest.

BTW, this only happens if you select a "good" or "excellent" DVD copy - if you select "perfect" then it doesn't run transcode and you don't have this problem. This is of course being tried only with unencrypted "home movie" dvds.

MarcRandolph (mrand) wrote :

> If I try manually typing (well, with cut and paste!) this transcode command I get –
>
> transcode: unrecognized option '-1'
> 'transcode -h | more' shows a list of available command line options.
>
> and if I, just for fun, remove the "-1" option I get
>
> transcode: unrecognized option '--color'
>
> and if I remove both "-1" and "--color" then the transcode runs successfully.
>
> The man page for transcode doesn't show either a --color or a -1 parameter either.

v1.1 indeed changed... from the main project page
(http://developer.berlios.de/projects/tcforge/), you can browse the
source directory and find:

http://hg.berlios.de/repos/tcforge/file/d6956f8dca76/docs/CHANGES-1.0-1.1

which shows
 --color [removed]
          is gone, replaced by --log_no_color.

The -1 argument is mentioned as well, although by a different name of
"--use_rgb". This has been replaced by "--video_format rgb24"

Of course, neither of these "new" command line options are available
on the older version. Until this gets straightened out, I would
suggest trying to fall back to the jaunty version of transcode if you
can't use the "perfect" option.

An alternative to falling back is to rename transcode as
transcode.real and then create an executable transcode wrapper script
which removes the --color option (isn't really needed) and replaces
the " -1 " parameter with " --video_format rgb24 ".

Changed in mythtv:
status: Unknown → New
MarcRandolph (mrand) wrote :

Looks like this might not take but a few lines to do with QT, so I am going to try to code up a patch which could be applied here or (ideally) upstream. In the mean time, please use one of the suggestions in comment #4

Changed in mythbuntu:
assignee: nobody → MarcRandolph (mrand)
milestone: none → karmic-rc
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 0.22.0~trunk22359-0ubuntu1

---------------
mythtv (0.22.0~trunk22359-0ubuntu1) karmic; urgency=low

  [ Mario Limonciello ]
  * New upstream checkout (r22359)
    - Themes have been shuffled around a bunch.
    - Fixes transcode arguments (LP: #429089)
  * debian/control:
    - Conflicts and replaces for themes that are now part of this package
  * debian/mythtv-setup.desktop:
    - Set to a real icon.
  * Set up some symlinks for the dejavu fonts so they aren't installed several
    times.
  * debian/rules:
    - Remove references to firewire_tester. We're not building it.
  * Simplify upstart script a bit.
  * Drop old logic for checking that ~mythtv/.mythtv/mysql.txt exists, and move
    it into the postinst.
  * Ship a mythbuntu crashdb for apport to catch crashes and submit against the
    mythbuntu project.
  * Add an apport hook for mythtv packages.
    - PPA builds will be directed at launchpad.net/mythbuntu
    - Normal builds will end up against launchpad.net/ubuntu/+source/mythtv

  [ Dave Walker ]
    * Incremeted to new upstream version to current trunk head.
    * Replaced sysv style init script with Upstart.
      - debian/control: Bump build-dependency on debhelper for Upstart-aware
        dh_installinit (debhelper >=7).
      - debian/mythtv-backend.upstart added.
    * Standards-Version bumped to 3.8.2.

 -- Mario Limonciello <email address hidden> Sun, 11 Oct 2009 13:43:15 -0500

Changed in mythtv (Ubuntu):
status: New → Fix Released
Changed in mythbuntu:
status: Confirmed → Fix Released
MarcRandolph (mrand) on 2009-10-11
Changed in mythbuntu:
assignee: MarcRandolph (mrand) → nobody
status: Fix Released → Fix Committed
Changed in mythtv:
status: New → Fix Released
MarcRandolph (mrand) on 2009-10-21
Changed in mythbuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.