Mythbuntu, Ubuntu derivative focused upon MythTV

Mythbuntu 9.04 amd64 - ivtv0: All encoder MPG stream buffers are full. Dropping data.

Reported by Sergey on 2009-05-12
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mythbuntu
High
Unassigned

Bug Description

After upgrading to Ubuntu Jaunty 9.04 (with Mythbuntu 9.04 installed) from 8.10, all subsequent video recordings are broken to the point of being totally unwatchable. The system has 8GB ram, dualcore AMD CPU and two Hauppauge PVR-150 TV tuners.

The same functionality worked flawlessly on 8.10.

Dmesg logs lots of dropped frames:
===================================
[549906.256316] ivtv0: Cause: the application is not reading fast enough.
[549906.352209] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549906.352214] ivtv0: Cause: the application is not reading fast enough.
[549906.952183] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549906.952187] ivtv0: Cause: the application is not reading fast enough.
[549907.453241] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549907.453248] ivtv0: Cause: the application is not reading fast enough.
[549907.557388] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549907.557393] ivtv0: Cause: the application is not reading fast enough.
[549907.656793] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549907.656797] ivtv0: Cause: the application is not reading fast enough.
[549908.453612] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549908.453618] ivtv0: Cause: the application is not reading fast enough.
[549908.642914] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549908.642918] ivtv0: Cause: the application is not reading fast enough.
[549908.797160] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549908.797164] ivtv0: Cause: the application is not reading fast enough.
[549908.955100] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549908.955104] ivtv0: Cause: the application is not reading fast enough.
[549909.259164] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549909.259171] ivtv0: Cause: the application is not reading fast enough.
[549909.358722] ivtv0: All encoder MPG stream buffers are full. Dropping data.
[549909.358726] ivtv0: Cause: the application is not reading fast enough.
===================================

Kernel:
===================================
Linux server 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

Module Size Used by
isofs 43688 0
udf 92584 0
crc_itu_t 10496 1 udf
usb_storage 94912 0
binfmt_misc 18572 1
nvidia 8123768 28
bnep 22912 2
vboxnetflt 110316 0
vboxdrv 1704748 1 vboxnetflt
ipt_MASQUERADE 11520 1
iptable_nat 14724 1
nf_nat 30100 2 ipt_MASQUERADE,iptable_nat
nf_conntrack_ipv4 24216 4 iptable_nat,nf_nat
nf_defrag_ipv4 10496 1 nf_conntrack_ipv4
xt_state 10624 1
nf_conntrack 84752 5 ipt_MASQUERADE,iptable_nat,nf_nat,nf_conntrack_ipv4,xt_state
ipt_REJECT 11776 2
xt_tcpudp 11776 4
iptable_filter 11392 1
ip_tables 28304 2 iptable_nat,iptable_filter
x_tables 31624 6 ipt_MASQUERADE,iptable_nat,xt_state,ipt_REJECT,xt_tcpudp,ip_tables
bridge 63904 0
stp 11140 1 bridge
kvm_amd 40972 0
kvm 176624 1 kvm_amd
kqemu 180648 0
lirc_mceusb2 21636 0
lirc_dev 22088 1 lirc_mceusb2
video 29204 0
output 11648 1 video
input_polldev 12688 0
nfsd 285344 17
auth_rpcgss 52512 1 nfsd
exportfs 13440 1 nfsd
nfs 304464 0
lockd 83796 2 nfsd,nfs
nfs_acl 11776 2 nfsd,nfs
sunrpc 227304 15 nfsd,auth_rpcgss,nfs,lockd,nfs_acl
jfs 197200 1
ib_iser 42752 0
rdma_cm 40692 1 ib_iser
ib_cm 51240 1 rdma_cm
iw_cm 18824 1 rdma_cm
ib_sa 32128 2 rdma_cm,ib_cm
ib_mad 50344 2 ib_cm,ib_sa
ib_core 76672 6 ib_iser,rdma_cm,ib_cm,iw_cm,ib_sa,ib_mad
ib_addr 15624 1 rdma_cm
iscsi_tcp 28048 0
libiscsi 44928 2 ib_iser,iscsi_tcp
scsi_transport_iscsi 45344 4 ib_iser,iscsi_tcp,libiscsi
it87 35352 0
hwmon_vid 12160 1 it87
sbp2 34700 0
lp 19588 0
tuner_simple 24084 2
tuner_types 26240 1 tuner_simple
tda9887 19844 2
tda8290 23428 0
wm8775 15020 0
cx25840 38320 0
snd_hda_intel 557364 0
snd_pcm_oss 52352 0
snd_mixer_oss 24960 1 snd_pcm_oss
tuner 36036 0
snd_pcm 99336 2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 11524 0
ivtv 168644 8
snd_seq_oss 41984 0
compat_ioctl32 18304 1 ivtv
snd_seq_midi 15744 0
snd_rawmidi 33920 1 snd_seq_midi
i2c_algo_bit 15364 1 ivtv
cx2341x 22148 1 ivtv
snd_seq_midi_event 16512 2 snd_seq_oss,snd_seq_midi
ppdev 16904 0
v4l2_common 23296 5 wm8775,cx25840,tuner,ivtv,cx2341x
videodev 45184 3 tuner,ivtv,compat_ioctl32
v4l1_compat 23940 1 videodev
tveeprom 23428 1 ivtv
snd_seq 66272 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
i2c_piix4 20112 0
k8temp 13440 0
parport_pc 45096 1
psmouse 64028 0
snd_timer 34064 2 snd_pcm,snd_seq
snd_seq_device 16276 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
parport 49584 3 lp,ppdev,parport_pc
serio_raw 14468 0
snd 78792 9 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 16800 1 snd
snd_page_alloc 18704 2 snd_hda_intel,snd_pcm
reiserfs 253952 11
ohci1394 42036 0
ieee1394 108288 2 sbp2,ohci1394
usbhid 47040 2
r8169 46596 0
mii 14464 1 r8169
raid10 31872 0
raid456 140064 1
async_xor 12160 1 raid456
async_memcpy 10752 1 raid456
async_tx 16636 3 raid456,async_xor,async_memcpy
xor 13968 2 raid456,async_xor
raid1 32512 3
raid0 15488 0
multipath 16512 0
linear 13440 0
fbcon 49792 0
tileblit 11264 1 fbcon
font 17024 1 fbcon
bitblit 14464 1 fbcon
softcursor 10368 1 bitblit
===================================

CPU info:
===================================
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) Dual Core Processor 4850e
stepping : 2
cpu MHz : 1000.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips : 2004.27
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) Dual Core Processor 4850e
stepping : 2
cpu MHz : 1000.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips : 2004.27
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
===================================

PCI Devices:
===================================
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
 Subsystem: Advanced Micro Devices [AMD] RS780 Host Bridge
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 32
 Region 3: Memory at <ignored> (64-bit, non-prefetchable)
 Capabilities: [c4] HyperTransport: Slave or Primary Interface
  Command: BaseUnitID=0 UnitCnt=12 MastHost- DefDir- DUL-
  Link Control 0: CFlE- CST- CFE- <LkFail- Init+ EOC- TXO- <CRCErr=0 IsocEn- LSEn- ExtCTL- 64b-
  Link Config 0: MLWI=16bit DwFcIn- MLWO=16bit DwFcOut- LWI=16bit DwFcInEn- LWO=16bit DwFcOutEn-
  Link Control 1: CFlE- CST- CFE- <LkFail+ Init- EOC+ TXO+ <CRCErr=0 IsocEn- LSEn- ExtCTL- 64b-
  Link Config 1: MLWI=8bit DwFcIn- MLWO=8bit DwFcOut- LWI=8bit DwFcInEn- LWO=8bit DwFcOutEn-
  Revision ID: 3.00
  Link Frequency 0: 1.0GHz
  Link Error 0: <Prot- <Ovfl- <EOC- CTLTm-
  Link Frequency Capability 0: 200MHz+ 300MHz- 400MHz+ 500MHz- 600MHz+ 800MHz+ 1.0GHz+ 1.2GHz- 1.4GHz- 1.6GHz- Vend-
  Feature Capability: IsocFC- LDTSTOP+ CRCTM- ECTLT- 64bA- UIDRD-
  Link Frequency 1: 200MHz
  Link Error 1: <Prot- <Ovfl- <EOC- CTLTm-
  Link Frequency Capability 1: 200MHz- 300MHz- 400MHz- 500MHz- 600MHz- 800MHz- 1.0GHz- 1.2GHz- 1.4GHz- 1.6GHz- Vend-
  Error Handling: PFlE- OFlE- PFE- OFE- EOCFE- RFE- CRCFE- SERRFE- CF- RE- PNFE- ONFE- EOCNFE- RNFE- CRCNFE- SERRNFE-
  Prefetchable memory behind bridge Upper: 00-00
  Bus Number: 00
 Capabilities: [54] HyperTransport: UnitID Clumping
 Capabilities: [40] HyperTransport: Retry Mode
 Capabilities: [9c] HyperTransport: #1a
 Capabilities: [f8] HyperTransport: #1c

00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 4 bytes
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
 I/O behind bridge: 0000e000-0000efff
 Memory behind bridge: f8000000-fbffffff
 Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
 Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
 BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
  PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
 Capabilities: [50] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [58] Express (v2) Root Port (Slot+), MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag+ RBE+ FLReset-
  DevCtl: Report errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep+ BwNot+
  LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive+ BWMgmt+ ABWMgmt-
  SltCap: AttnBtn- PwrCtrl- MRL- AttnInd- PwrInd- HotPlug- Surpise-
   Slot # 2, PowerLimit 75.000000; Interlock- NoCompl+
  SltCtl: Enable: AttnBtn- PwrFlt- MRL- PresDet- CmdCplt- HPIrq- LinkChg-
   Control: AttnInd Unknown, PwrInd Unknown, Power- Interlock-
  SltSta: Status: AttnBtn- PowerFlt- MRL- CmdCplt- PresDet+ Interlock-
   Changed: MRL- PresDet+ LinkState+
  RootCtl: ErrCorrectable- ErrNon-Fatal- ErrFatal- PMEIntEna- CRSVisible-
  RootCap: CRSVisible-
  RootSta: PME ReqID 0000, PMEStatus- PMEPending-
 Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
  Address: fee0300c Data: 4159
 Capabilities: [b0] Subsystem: Advanced Micro Devices [AMD] Device 9600
 Capabilities: [b8] HyperTransport: MSI Mapping Enable+ Fixed+
 Capabilities: [100] Vendor Specific Information <?>
 Capabilities: [110] Virtual Channel <?>
 Kernel driver in use: pcieport-driver
 Kernel modules: shpchp

00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 4 bytes
 Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
 I/O behind bridge: 0000d000-0000dfff
 Memory behind bridge: fdd00000-fddfffff
 Prefetchable memory behind bridge: 00000000fdf00000-00000000fdffffff
 Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
 BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
  PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
 Capabilities: [50] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [58] Express (v2) Root Port (Slot+), MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag+ RBE+ FLReset-
  DevCtl: Report errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep+ BwNot+
  LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive+ BWMgmt+ ABWMgmt-
  SltCap: AttnBtn- PwrCtrl- MRL- AttnInd- PwrInd- HotPlug- Surpise-
   Slot # a, PowerLimit 25.000000; Interlock- NoCompl+
  SltCtl: Enable: AttnBtn- PwrFlt- MRL- PresDet- CmdCplt- HPIrq- LinkChg-
   Control: AttnInd Unknown, PwrInd Unknown, Power- Interlock-
  SltSta: Status: AttnBtn- PowerFlt- MRL- CmdCplt- PresDet+ Interlock-
   Changed: MRL- PresDet+ LinkState+
  RootCtl: ErrCorrectable- ErrNon-Fatal- ErrFatal- PMEIntEna- CRSVisible-
  RootCap: CRSVisible-
  RootSta: PME ReqID 0000, PMEStatus- PMEPending-
 Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
  Address: fee0300c Data: 4161
 Capabilities: [b0] Subsystem: Advanced Micro Devices [AMD] Device 9600
 Capabilities: [b8] HyperTransport: MSI Mapping Enable+ Fixed+
 Capabilities: [100] Vendor Specific Information <?>
 Capabilities: [110] Virtual Channel <?>
 Kernel driver in use: pcieport-driver
 Kernel modules: shpchp

00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] (prog-if 01)
 Subsystem: Giga-byte Technology Device b002
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32
 Interrupt: pin A routed to IRQ 22
 Region 0: I/O ports at ff00 [size=8]
 Region 1: I/O ports at fe00 [size=4]
 Region 2: I/O ports at fd00 [size=8]
 Region 3: I/O ports at fc00 [size=4]
 Region 4: I/O ports at fb00 [size=16]
 Region 5: Memory at fe02f000 (32-bit, non-prefetchable) [size=1K]
 Capabilities: [60] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [70] SATA HBA <?>
 Kernel driver in use: ahci

00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at fe02e000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at fe02d000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller (prog-if 20)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 17
 Region 0: Memory at fe02c000 (32-bit, non-prefetchable) [size=256]
 Capabilities: [c0] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME+
  Bridge: PM- B3+
 Capabilities: [e4] Debug port: BAR=1 offset=00e0
 Kernel driver in use: ehci_hcd

00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at fe02b000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at fe02a000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller (prog-if 20)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 19
 Region 0: Memory at fe029000 (32-bit, non-prefetchable) [size=256]
 Capabilities: [c0] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+
 Capabilities: [e4] Debug port: BAR=1 offset=00e0
 Kernel driver in use: ehci_hcd

00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
 Subsystem: Giga-byte Technology Device 4385
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort+ <MAbort- >SERR+ <PERR+ INTx-
 Capabilities: [b0] HyperTransport: MSI Mapping Enable- Fixed+
 Kernel driver in use: piix4_smbus
 Kernel modules: i2c-piix4

00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller (prog-if 8a [Master SecP PriP])
 Subsystem: Giga-byte Technology Device 5002
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32
 Interrupt: pin A routed to IRQ 16
 Region 0: I/O ports at 01f0 [size=8]
 Region 1: I/O ports at 03f4 [size=1]
 Region 2: I/O ports at 0170 [size=8]
 Region 3: I/O ports at 0374 [size=1]
 Region 4: I/O ports at fa00 [size=16]
 Capabilities: [70] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Kernel driver in use: pata_atiixp

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
 Subsystem: Giga-byte Technology Device a102
 Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Region 0: Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel modules: snd-hda-intel

00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
 Subsystem: ATI Technologies Inc SB700/SB800 LPC host controller
 Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0

00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (prog-if 01)
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop+ ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Bus: primary=00, secondary=03, subordinate=03, sec-latency=64
 I/O behind bridge: 0000c000-0000cfff
 Memory behind bridge: fde00000-fdefffff
 Prefetchable memory behind bridge: d8000000-dfffffff
 Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
 BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
  PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-

00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 4 bytes
 Interrupt: pin C routed to IRQ 18
 Region 0: Memory at fe028000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Capabilities: [80] HyperTransport: Host or Secondary Interface
  !!! Possibly incomplete decoding
  Command: WarmRst+ DblEnd-
  Link Control: CFlE- CST- CFE- <LkFail- Init+ EOC- TXO- <CRCErr=0
  Link Config: MLWI=16bit MLWO=16bit LWI=16bit LWO=16bit
  Revision ID: 1.02

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Capabilities: [f0] Secure device <?>
 Kernel driver in use: k8temp
 Kernel modules: k8temp

01:00.0 VGA compatible controller: nVidia Corporation GeForce 9500 GT (rev a1)
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
 Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
 Region 3: Memory at f8000000 (64-bit, non-prefetchable) [size=32M]
 Region 5: I/O ports at ef00 [size=128]
 [virtual] Expansion ROM at fb000000 [disabled] [size=512K]
 Capabilities: [60] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [78] Express (v2) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <1us, L1 <4us
   ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <512ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [b4] Vendor Specific Information <?>
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [128] Power Budgeting <?>
 Capabilities: [600] Vendor Specific Information <?>
 Kernel driver in use: nvidia
 Kernel modules: nvidia, nvidiafb

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
 Subsystem: Giga-byte Technology Device e000
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 2300
 Region 0: I/O ports at de00 [size=256]
 Region 2: Memory at fdfff000 (64-bit, prefetchable) [size=4K]
 Region 4: Memory at fdfe0000 (64-bit, prefetchable) [size=64K]
 [virtual] Expansion ROM at fdf00000 [disabled] [size=64K]
 Capabilities: [40] Power Management version 3
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
  Address: 00000000fee0300c Data: 4189
 Capabilities: [70] Express (v1) Endpoint, MSI 01
  DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <512ns, L1 <8us
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 4096 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM+ Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [b0] MSI-X: Enable- Mask- TabSize=2
  Vector table: BAR=4 offset=00000000
  PBA: BAR=4 offset=00000800
 Capabilities: [d0] Vital Product Data <?>
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Virtual Channel <?>
 Capabilities: [160] Device Serial Number 78-56-34-12-78-56-34-12
 Kernel driver in use: r8169
 Kernel modules: r8169

03:06.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
 Subsystem: Hauppauge computer works Inc. Device 8801
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (32000ns min, 2000ns max), Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 20
 Region 0: Memory at dc000000 (32-bit, prefetchable) [size=64M]
 Capabilities: [44] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: ivtv
 Kernel modules: ivtv

03:07.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
 Subsystem: Hauppauge computer works Inc. Device 8801
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (32000ns min, 2000ns max), Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 21
 Region 0: Memory at d8000000 (32-bit, prefetchable) [size=64M]
 Capabilities: [44] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: ivtv
 Kernel modules: ivtv

03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link) (prog-if 10)
 Subsystem: Giga-byte Technology Device 1000
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32 (500ns min, 1000ns max), Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at fdeff000 (32-bit, non-prefetchable) [size=2K]
 Region 1: Memory at fdef8000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [44] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME+
 Kernel driver in use: ohci1394
 Kernel modules: firewire-ohci, ohci1394
===================================

MarcRandolph (mrand) wrote :

Howdy, and thank you for your report. You most certainly have enough RAM, so that can't be the problem. Does LiveTV work, or is all video through your myth system corrupted? Have you verified that the capture card itself is still working correctly, and is tuned to channel 3? (for those two items, please see: http://www.gossamer-threads.com/lists/ivtv/users/39797#39797)

If that doesn't pan out, could you please look over your /var/log/mythtv/mythbackend.log and see if it shows any other errors? around that same time?

If none of this helps, you might read up on checking your database(s).

Changed in mythbuntu:
status: New → Incomplete
Sergey (sliakh) wrote :

MarcRandolph,

the issue you are referring to is completely different from what I see. Sorry I was not clear in the initial post, but here is additional information:

1. I do not use a cable box. Both PVR-150 cards connected to the cable and used to tune to the first 70 analogue channels.
2. I do get both video and audio from the cards. However, the problem is that recorded MPEG file end up with lots of "broken" frames and skips quite a bit.
3. Live TV seems to be OK
4. All recordings made before upgrade are playing fine.
5. Following warnings are logged in /var/log/mythtv/mythbackend.log, however the same warnings have been logged prior to upgrade and everything worked fine.
=========================================
2009-05-11 21:00:01.373 Current Schema Version: 1214
2009-05-11 21:00:02.146 TVRec(4): Changing from None to RecordingOnly
2009-05-11 21:00:02.160 TVRec(4): HW Tuner: 4->4
2009-05-11 21:00:02.330 MPEGRec(/dev/video1) Warning: Audio sample rate 32000 Hz
   is not supported by ivtv driver, using 48000 Hz instead.
2009-05-11 21:00:02.333 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2009-05-11 21:00:02.352 Started recording: Family Guy "Jungle Love": channel 1034 on cardid 4, sourceid 1
2009-05-11 21:00:02.422 TVRec(3): Changing from None to RecordingOnly
2009-05-11 21:00:02.430 TVRec(3): HW Tuner: 3->3
 *********************** WARNING ***********************
 ivtv drivers prior to 0.10.0 can cause lockups when
 reading VBI. Drivers between 0.10.5 and 1.0.3+ do not
 properly capture VBI data on PVR-250 and PVR-350 cards.

2009-05-11 21:00:02.621 MPEGRec(/dev/video0) Warning: Audio sample rate 32000 Hz
   is not supported by ivtv driver, using 48000 Hz instead.
2009-05-11 21:00:02.635 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2009-05-11 21:00:02.649 Started recording: Weaponizers "Medieval Mayhem": channel 1030 on cardid 3, sourceid 1
 *********************** WARNING ***********************
 ivtv drivers prior to 0.10.0 can cause lockups when
 reading VBI. Drivers between 0.10.5 and 1.0.3+ do not
 properly capture VBI data on PVR-250 and PVR-350 cards.
=========================================

I do not understand how databases can be part of this, since it is the MPEG stream that ends up being corrupt, not recording metadata. Can you please clarify?

Thank you.

Sergey (sliakh) wrote :

One more finding:

mplayer -vo xv /dev/video0 -autosync 30

does result in playing a "broken" video (it is good enough to see what it is, but with dropped frames and something that looks almost like momentary loss of H/V sync in video signal at some random intervals between about 1 and 5 seconds).

MarcRandolph (mrand) wrote :

In the original report, it wasn't completely clear to me so I was originally wondering if there was a small chance that it could be a playback issue caused by the database because I found at least one reference exactly that in my web searches on your problem.

I'm have to admit that what you are seeing doesn't make sense to me:

1. Live TV seems to be OK
2. But recorded isn't
3. And if I understand your most recent comment, pointing mplayer to your encoder also results in broken video?

If # 3 is bad, I don't see how # 1 could be good. And if # 1 is good, then it would be a strange problem that # 2 would be bad, and even stranger that # 3 would be.

Can we assume that you've verified this behavior occurs with both PVR-150's? If you only had one device doing it, I'd suspect faulty hardware.

tduffy83 (ted4q) wrote :

I am having the exact same issue. I have tested this across 3 PVR-500 cards on each tuner, and all 6 tuners have the same problem. I even tried the cards in different machines and the issue was the same. I get the broken video in both livetv and recordings as well as using the command line to record and opening the card in VLC. 8.10 works perfectly as do all the old 8.10 recordings. I really think 9.04 has broken IVTV. I would really like to see this resolved as I need the newer open source intel video driver that only works with 9.04.

MarcRandolph (mrand) wrote :

@tduffy83: Are you seeing the same log messages?

Changed in mythbuntu:
importance: Undecided → High
status: Incomplete → Confirmed
Bart (bartthys) wrote :

Same problem here, I was thinking my tv-card or cable was busted when I realized this started after the upgrade.

Getting:
Jun 21 21:30:29 bart-tv kernel: [11719.734460] ivtv0: All encoder VBI stream buffers are full. Dropping data.
Jun 21 21:30:29 bart-tv kernel: [11719.734465] ivtv0: Cause: the application is not reading fast enough.

My card is a PVR 500

unixnewbie (darfsten) wrote :

just so you know I was getting the exact same errors alot when I ran Feisty Fawn with Mythtv .20.2-fixes. I made sure DMA was enabled for all drives and I even had the following options in my /etc/modprobe.conf
options ivtv enc_mpg_buffers=16 enc_yuv_buffers=20 enc_pcm_buffers=640 debug=3
BUT I still got the errors.

I just did a fresh install of Hardy Heron ( i wanted an LTS release this time) and with DMA enabled and having the above mentioned options in /etc/modprobe.d/ivtv I don't receive that error any more. I don't recall doing anything else with my setup out of the default install.

MarcRandolph (mrand) wrote :

Some of you might try the following (taken from http://www.gossamer-threads.com/lists/mythtv/mythtvnz/378788#378788):

Try putting the following in /etc/sysctl.conf

vm.min_free_kbytes=16384

Also [depending on] how many analogue cards do you have as you might want to double the value to 32768.

The ivtv driver tries to compensate for a lot of bugs in the dma chips on the 150/500 series cards but sometimes it isn't enough. When it gets really bad a reboot is generally recommended.

Other ideas:
http://ubuntuforums.org/showthread.php?t=899947
http://www.gossamer-threads.com/lists/ivtv/users/35808#35808

If this resolve the problem for you, please be sure to report back here!

yun14u (yun14u) wrote :

MarcRandolph
I experienced the same issue and fix it by implementing the solution you suggested (ie. increasing vm.min_free_kbytes). I noticed that if I don't do anything to the machine (ie. browsing MythWeb or running update), the errors does not show up. Could it related to sysctl.conf ?

squidvt (craig-codestorm) wrote :

I have had this issue as well, and I've checked with the MythTV devs, and V4L devs. This looks to be just over running the buffers of the PCI bus. I have this issue with My PVR-150 only. I don't have the issue with my PVR-250.

Also this seems to be happening when I am using both IVTV devices at the same time.

Alex EviL (alex--evil) wrote :

Have same problem on Ubuntu 9.04 amd64, 4 Gb Ram

Changing sysctl settings have no effect for me.

Alex EviL (alex--evil) wrote :

Sorry, forgot to mention, my card is Aver MCE 116 Plus, worked fine in Ubuntu 8.10.

Bart (bartthys) wrote :

Can you check your image size in the recording and livetv profiles? I had very similar problems on my PVR-500 after upgrading to a new Mythbuntu

Please check bug https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/550173 .

quequotion (quequotion) wrote :

This bug is back.

In Ubuntu 10.10 I'm getting this error when trying to stream video from an ivtv mpeg capture card to Totem ("totem /dev/video0").

This is not a problem with other players or methods of streaming ivtv video ("cat /dev/video0 > foo.mpeg" produces a good mpeg file and "vlc pvr://dev/video0" streams without any trouble).

I don't think it's a problem with the ivtv driver, although it could be a misconfiguration of the driver. I think it's more likely a problem with totem or, most likely gstreamer.

Thomas Mashos (tgm4883) wrote :

Marking incomplete as releases prior to 10.04 are no longer supported. Could someone confirm if this issue is still present in MythTV on a supported release?

Changed in mythbuntu:
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Mythbuntu because there has been no activity for 60 days.]

Changed in mythbuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers