Very unreliable DVD playback

Bug #288816 reported by jboehm on 2008-10-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
Mythbuntu
Fix Released
High
Unassigned
mythplugins (Ubuntu)
Undecided
Unassigned

Bug Description

Some disks play fine but here are two example of problems I'm having.

1) Pirates of the Caribbean 1 -- disk shows the FBI warning page then freezes. I have to kill the frontend to regain control. I've attached a cut from my mythfrontend.log for this attempt.

2) Dexter Season 1 Disk 1 -- FBI then Showtime promo then drop back to mythfrontend

I have confirmed that I have libdvdread3, libdvdcss2, and libdvdnav4 installed and that the region is set on my dvd drive. These disks play fine under .20 with ubuntu 7.10.

Here is my thread on the topic: http://ubuntuforums.org/showthread.php?t=957143

Related branches

jboehm (jbpub) wrote :
jboehm (jbpub) wrote :

This may be related to Mythdvd issue. See:
http://svn.mythtv.org/trac/ticket/5630

MarcRandolph (mrand) on 2008-10-24
Changed in mythbuntu:
status: New → Confirmed
Changed in mythtv:
status: Unknown → Confirmed
Changed in mythtv:
status: Confirmed → Unknown

I had this happen in .21 as well at one point, however it was related to the
Playback profile I was using switching to a less CPU intensive one resolved
it.

-Nick

On Fri, Oct 24, 2008 at 11:14 AM, jboehm <email address hidden> wrote:

> Public bug reported:
>
> Some disks play fine but here are two example of problems I'm having.
>
> 1) Pirates of the Caribbean 1 -- disk shows the FBI warning page then
> freezes. I have to kill the frontend to regain control. I've attached a
> cut from my mythfrontend.log for this attempt.
>
> 2) Dexter Season 1 Disk 1 -- FBI then Showtime promo then drop back to
> mythfrontend
>
> I have confirmed that I have libdvdread3, libdvdcss2, and libdvdnav4
> installed and that the region is set on my dvd drive. These disks play
> fine under .20 with ubuntu 7.10.
>
> Here is my thread on the topic:
> http://ubuntuforums.org/showthread.php?t=957143
>
> ** Affects: mythbuntu
> Importance: Undecided
> Status: New
>
> --
> Very unreliable DVD playback
> https://bugs.launchpad.net/bugs/288816
> You received this bug notification because you are a member of Mythbuntu
> Bug Team, which is subscribed to Mythbuntu.
>
> Status in Mythbuntu, Ubuntu derivative focused upon MythTV: New
>
> Bug description:
> Some disks play fine but here are two example of problems I'm having.
>
> 1) Pirates of the Caribbean 1 -- disk shows the FBI warning page then
> freezes. I have to kill the frontend to regain control. I've attached a cut
> from my mythfrontend.log for this attempt.
>
> 2) Dexter Season 1 Disk 1 -- FBI then Showtime promo then drop back to
> mythfrontend
>
> I have confirmed that I have libdvdread3, libdvdcss2, and libdvdnav4
> installed and that the region is set on my dvd drive. These disks play fine
> under .20 with ubuntu 7.10.
>
> Here is my thread on the topic:
> http://ubuntuforums.org/showthread.php?t=957143
>

Changed in mythtv:
status: Unknown → Confirmed
Jack Deslippe (jdeslip) wrote :

I also have this problem. And, the myth devs have locked down the bug report because it is magically fixed in 0.22, something to do with ffmpeg. I am still hoping to see a workaround for 0.21-fixes.

For me, it happens both with ffmpeg+xvideo and a vdpau+vdpau profile (using the backported patched mythbuntu packages). Since you say it is related to ffmpeg, can it be worked around by using a non ffmpeg profile?

Changed in mythtv:
status: Confirmed → Fix Released
Mario Limonciello (superm1) wrote :

Looks like upstream isn't going to backport it if it's fixed by the ffmpeg sync. We'll have to wait till 0.22 then it sounds.

Changed in mythbuntu:
status: Confirmed → Triaged
Changed in mythplugins (Ubuntu):
status: New → Triaged
tags: added: fixed-0.22
Dave Johansen (davejohansen) wrote :

This appears to have been fixed in the trunk of MythTV ( http://svn.mythtv.org/trac/ticket/5630 ), but for now could we just add an option like "-menu-startup" to bypass the problematic part of the playback?

I just tried playing back a DVD in Mythbuntu 9.04 beta and it froze up in MythTV and I had to kill the frontend, but the same DVD played just fine in mplayer, vlc, and xine when I loaded it up manually so I think that some sort of work around like this would be a good idea.

Dave Johansen (davejohansen) wrote :

Sorry, I thought that MythTV was using mplayer to playback DVDs (but I now realize that it uses MythDVD) and the "-menu-startup" command doesn't do what I expected anyway, but I think that the same principle applies and that something should be done to ensure that current systems don't freeze up since the fix is currently only in the 0.22 release.

Jack Deslippe (jdeslip) wrote :

I agree. I'd love to see this fixed in the current mythbuntu packages somehow. It seems 0.22 is a long ways away.

MarcRandolph (mrand) wrote :

The team understands how big an impact this is on some users and installs, but to provide some background and hopefully head off a bunch of "me-too" responses, upstream already investigated this issue and unfortunately was not able to discover the source of the problem. It appears to have been fixed on the trunk by a ffmpeg resync, which is quite massive (http://svn.mythtv.org/trac/changeset/18904 lists SOME, but not all, of the files impacted) and would be too disruptive to apply to the -fixes branch.

In summary, unless else someone volunteers to dig deeper into the bug and creates a patch, there aren't any resources to find and fix this on the -fixes branch. If someone could find a stand-alone player that works, a possible work-around might be to configure and use an external player (http://www.mythtv.org/wiki/MythVideo#External_Player_Configuration). If the player(s) installed by default don't work and you're a bit more adventuresome, you might try manually updating to the latest version of your favorite player(s).

Thank you for keeping any further replies to this bug to a technical nature (either code/patch discussions, or external player configurations that work)!

Changed in mythbuntu:
importance: Undecided → High
MarcRandolph (mrand) wrote :

Moving to committed so that the mythbuntu team doesn't think more work is needed on this. Upstream has fixes in place

Changed in mythbuntu:
status: Triaged → Fix Committed
Changed in mythplugins (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythplugins - 0.22.0~trunk21556-0ubuntu1

---------------
mythplugins (0.22.0~trunk21556-0ubuntu1) karmic; urgency=low

  * New upstream checkout (r21556)
    - Fixes unreliable DVD playback. (LP: #288816)
  * mythweb.postinst:
    - Make sure www-data can write to /usr/share/mythtv/mythweb/data
  * debian/control:
    - Replaces mythtv-common for mythmusic, mythnews, mythgallery.
      (LP: #415907, #419499, #419502)

 -- Mario Limonciello <email address hidden> Fri, 28 Aug 2009 01:35:15 -0500

Changed in mythplugins (Ubuntu):
status: Fix Committed → Fix Released
Nick Fox (nickj-fox) wrote :

I can confirm that this bug is actually a configuration issue with many GPUs and the newer drivers in Ubuntu 8.10+. This is not a code bug and with the upcoming release of MythTV .22 I have tested DVD playback with great results. Moving the Mythbuntu bug to Fix-Released

Changed in mythbuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.