Mytharchive does not work by default/lacking temp dir

Bug #251353 reported by ninti on 2008-07-24
4
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
Undecided
Unassigned
mythplugins (Ubuntu)
Undecided
laga

Bug Description

Archiving shows onto a DVD did not work by default. I had to, after some searching to figure out what the problem might be, manually create a temp directory and assign it permissions before archiving would work. The directory should be created on install.

Related branches

Actually populating the DB with the /tmp folder would be a cleaner option. A
Patch would be welcome.

-Nick

On Wed, Jul 23, 2008 at 9:05 PM, ninti <email address hidden> wrote:

> Public bug reported:
>
> Archiving shows onto a DVD did not work by default. I had to, after some
> searching to figure out what the problem might be, manually create a
> temp directory and assign it permissions before archiving would work.
> The directory should be created on install.
>
> ** Affects: mythbuntu
> Importance: Undecided
> Status: New
>
> --
> Mytharchive does not work by default/lacking temp dir
> https://bugs.launchpad.net/bugs/251353
> You received this bug notification because you are a member of
> Mythbuntu, which is subscribed to Mythbuntu.
>

laga (laga) wrote :

Nick Fox schrieb:
> Actually populating the DB with the /tmp folder would be a cleaner option. A
> Patch would be welcome.
>
> -Nick
>
>

We *should* already patch that. I'll take a look at our source package.
Using /tmp/ is not a good idea, because you will need lots of space there.

> On Wed, Jul 23, 2008 at 9:05 PM, ninti <email address hidden> wrote:
>
>
>> Public bug reported:
>>
>> Archiving shows onto a DVD did not work by default. I had to, after some
>> searching to figure out what the problem might be, manually create a
>> temp directory and assign it permissions before archiving would work.
>> The directory should be created on install.
>>
>> ** Affects: mythbuntu
>> Importance: Undecided
>> Status: New
>>
>> --
>> Mytharchive does not work by default/lacking temp dir
>> https://bugs.launchpad.net/bugs/251353
>> You received this bug notification because you are a member of
>> Mythbuntu, which is subscribed to Mythbuntu.
>>
>>
>
>

laga (laga) wrote :

Okay, the patch is there and it should be applied.

When did you install your MythTV box? Did you create a new databasE?

Chances are it was picking up old settings or you installed before Sun, 13 Apr 2008 18:59:26 +0200 which was when 0.21.0+fixes16838-0ubuntu2 was released.

ninti (nintigod) wrote :

I downloaded and installed Mythbuntu on July 15th. It was a fresh machine. There was a temp directory specified in in the settings (/var/lib/mytharchive/temp/), but the directory did not actually exist and I had to create it before MythArchive would work.

laga (laga) wrote :

Yes, you are right. I'll commit a fix to bzr soonish.

Changed in mythbuntu:
status: New → Confirmed
Changed in mythplugins:
status: New → Confirmed
laga (laga) wrote :

Fix committed. bzr rev 60.

Changed in mythplugins:
assignee: nobody → laga
status: Confirmed → Fix Committed
laga (laga) on 2008-09-21
Changed in mythbuntu:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythplugins - 0.21.0+fixes18379-0ubuntu1

---------------
mythplugins (0.21.0+fixes18379-0ubuntu1) intrepid; urgency=low

  * new upstream checkout
  * really add mytharchive temp dir (LP: #251353)
  * Add log file for MTD to MythVideo (/var/log/mythtv/mtd.log) (LP: #176236)

 -- Michael Haas <email address hidden> Wed, 24 Sep 2008 11:40:59 +0200

Changed in mythplugins:
status: Fix Committed → Fix Released
Changed in mythbuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers