Main Menu Jumppoint goes to wrong screen if any other jumppoint uses Ctrl-L

Bug #193503 reported by Zach on 2008-02-19
2
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
Mythbuntu
Expired
Low
Unassigned

Bug Description

If I define a keybinding for the Main Menu jumppoint, e.g., Alt+Home, and define a keybinding for the TV Recording Playback, e.g., Ctrl+L, the keybinding for Main Menu takes me to the TV Recording Playback screen. The TV Recording Playback jumppoint works fine (takes me where it should--TV Recording Playback).

If I define only the Main Menu jumppoint keybinding without defining the TV Recording Playback jumppoint, then the Main Menu keybinding works fine, taking me back to the Main Menu.

I do not recall what happens if I subsequently delete the TV Recording Playback jumppoint keybinding--whether or not the Main Menu keybiding works find again.

Thomas Mashos (tgm4883) wrote :

What version of Mythbuntu is this? Does this still exist in the release version of 8.04.1?

Changed in mythbuntu:
status: New → Incomplete
Zach (uid000) wrote :

I am on 8.04. I am staying up to date with Ubuntu as well as mythbuntu weekly fixes. This problem still happens.

Thomas Mashos (tgm4883) on 2008-09-25
Changed in mythbuntu:
status: Incomplete → New
MarcRandolph (mrand) wrote :

Confirming. After some experimentation with 8.04 weekly -fixes, it doesn't appear to depend on TV Recording Playback though... basically, if ANY jumppoint is set to Ctrl-L (and only Ctrl-L), then the main menu jump point doesn't work, and instead takes the user to whatever is defined as Ctrl-L.

Doesn't appear to be database, because setting the values via mythfrontend results in be correct values when jump points are viewed via Mythweb. Looks like a bug in mythfrontend.

Until this is fixed, the work-around is to pick something other than Ctrl-L

Changed in mythbuntu:
importance: Undecided → Low
status: New → Confirmed
Mario Limonciello (superm1) wrote :

Thank you for helping to improve Mythbuntu by opening this ticket.
This bug still exists in current 0.22 builds. I'll open a bug upstream.
I am marking this ticket as confirmed because it appears to have enough information to help the developers understand the problem. It is possible I am wrong and another more experienced triager or developer may adjust the status of the ticket to "incomplete" and request additional information.

Changed in mythbuntu:
status: Confirmed → Triaged
Changed in mythtv:
status: Unknown → New
Changed in mythtv:
status: New → Confirmed
Changed in mythtv:
status: Confirmed → Fix Released
Thomas Mashos (tgm4883) wrote :

Marking incomplete as this release isn't supported anymore. Can anyone confirm that this issue is still present on a supported Mythbuntu/MythTV release?

Changed in mythbuntu:
status: Triaged → Incomplete
Thomas Mashos (tgm4883) on 2015-01-11
Changed in mythbuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.