mythbuntu frontend installation stalls at 83% when hard disk of mysql server is full

Bug #178987 reported by Jakob Fix on 2007-12-28
2
Affects Status Importance Assigned to Milestone
Mythbuntu
Medium
Mario Limonciello
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

after talking to superm1 in this forum thread (http://ubuntuforums.org/showthread.php?p=4025678), he encouraged me report this bug:

when installing the frontend (using the advanced frontend-only mode, although this may also apply to other installation modes), the installation may hang indefinitely at 83% when trying to connect to the backend's mysql server, but the database server is unable to reply to a request because of hard disk that's full at 100%. (this happened in my case where mysql produced huge amounts of binary log files each 100MB big that clogged up the /var partition).

at the setup stage preceding the installation proper, it is suggested to not just do a SELECT statement using the user-supplied credentials and database details, but to also try to temporarily add and remove a value because this may give a more realistic view of the database's availability and may avoid the installation hanging at the stage where the installer says it's configuring mythtv.

according to superm1, the file in question is "ubiquity's mythbuntu_ui.py", and mor particularly, the "do_connection_test" method.

btw, thanks for mythbuntu, I hope this report is useful.

Related branches

Thomas Mashos (tgm4883) on 2008-08-08
Changed in mythbuntu:
importance: Undecided → Medium
status: New → Confirmed
laga (laga) on 2008-10-15
Changed in mythbuntu:
assignee: nobody → superm1
Mario Limonciello (superm1) wrote :

This behavior should be fixed in Ubiquity 1.11.4.

Changed in mythbuntu:
status: Confirmed → Fix Committed
Changed in ubiquity:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.11.4

---------------
ubiquity (1.11.4) jaunty; urgency=low

  [ Mario Limonciello ]
  * Mythbuntu specific changes:
    - Don't reinvent the square with autologin. It's provided
      by user-setup, so use it there.
    - Eliminate mythbuntu_summary.py, and instead merge it into
      mythbuntu_install.py
    - Change definition overrides in mythbuntu_install.py so run() can
      be used from install.py without code duplication in mythbuntu_install.py.
      (LP: #178987), (LP: #201397), (LP: #293268)
    - Change function overrides in mythbuntu_ui.py. There should be no
      full definition code duplication anymore.
  * GTK specific changes:
    - Move declaration of self.pages into __init__ instead so that it can
      more easily overridden outside of run().
  * Automatic update of included source packages: apt-setup
    1:0.37ubuntu9.

 -- Mario Limonciello <email address hidden> Mon, 19 Jan 2009 08:28:50 -0600

Changed in ubiquity:
status: Fix Committed → Fix Released
Changed in mythbuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers