MCC crashes with error on mysql plugin

Bug #1316905 reported by Thomas Mashos on 2014-05-07
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
High
Thomas Mashos
mythbuntu-common (Ubuntu)
Medium
Mario Limonciello
Trusty
High
Thomas Mashos
Utopic
Medium
Mario Limonciello

Bug Description

[Impact]
 * Mythbuntu control center crashes modifying MySQL settings
 * Mythbuntu does LTS only releases, so we should make sure this is fixed for LTS.

[Test Case]

 * Open MCC on a machine with a backend. Try to make a MySQL change.

[Regression Potential]

 * This code is only used for MCC.

Thomas Mashos (tgm4883) on 2014-05-07
Changed in mythbuntu:
assignee: nobody → Thomas Mashos (tgm4883)
importance: Undecided → High
status: New → Fix Committed
description: updated
Changed in mythbuntu-common (Ubuntu Utopic):
assignee: nobody → Mario Limonciello (superm1)
Changed in mythbuntu-common (Ubuntu Trusty):
assignee: nobody → Thomas Mashos (tgm4883)
Changed in mythbuntu-common (Ubuntu Utopic):
status: New → Fix Committed
Changed in mythbuntu-common (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
Changed in mythbuntu-common (Ubuntu Utopic):
importance: Undecided → Medium
Changed in mythbuntu-common (Ubuntu Trusty):
milestone: none → ubuntu-14.04.1

Hello Thomas, or anyone else affected,

Accepted mythbuntu-common into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mythbuntu-common/0.74 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mythbuntu-common (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-common - 0.74

---------------
mythbuntu-common (0.74) trusty-proposed; urgency=medium

  [ Mario Limonciello ]
  * Actually clean in the clean target.

  [ Thomas Mashos ]
  * Fix services plugin for VNC crashing (LP: #1309553)
  * Fix mysql plugin crashing (LP: #1316905)
 -- Thomas Mashos <email address hidden> Thu, 08 May 2014 14:06:34 -0700

Changed in mythbuntu-common (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-common - 0.74build1

---------------
mythbuntu-common (0.74build1) utopic; urgency=medium

  * No change rebuild for utopic (LP: #1309553, #1316905)
 -- Mario Limonciello <email address hidden> Thu, 22 May 2014 22:34:08 -0500

Changed in mythbuntu-common (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in mythbuntu:
status: Fix Committed → Fix Released

i'm running mythbuntu-common 0.74 and mcc keeps crashing when I try to setup a database backup. just a heads up. not sure if it's a related bug or different. I can provide any info you need.

Please run mythbuntu-control-centre from a terminal, reproduce the
error, and paste the terminal errors here.
Thanks,

Thomas Mashos

On Sat, May 31, 2014 at 10:41 PM, UbuntuAddicted
<email address hidden> wrote:
> i'm running mythbuntu-common 0.74 and mcc keeps crashing when I try to
> setup a database backup. just a heads up. not sure if it's a related bug
> or different. I can provide any info you need.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1316905
>
> Title:
> MCC crashes with error on mysql plugin
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mythbuntu/+bug/1316905/+subscriptions

linkku (aapo-anderson) wrote :

Hei,

Could this be related?

I am trying to get mythweb to work after update from Mythbuntu 12.04-> 14.04

On startup get an error:
Exception in applyStateToGUI of plugin Plugins
Disabling Plugin.

When I try to enable password for mythweb and press Apply and get:
No Changes found

and the text from the terminal:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Traceback (most recent call last):
  File "/usr/bin/mythbuntu-control-centre", line 383, in refreshState
    plugin.applyStateToGUI()
  File "/usr/share/mythbuntu/plugins/python/plugins.py", line 92, in applyStateToGUI
    self.mythweb_password_combobox.append_text("Reconfigure")
AttributeError: 'ComboBox' object has no attribute 'append_text'

Thomas Mashos (tgm4883) wrote :

While it looks related, it is not related to this bug. Please file a
new bug report.
Thanks,

Thomas Mashos

On Wed, Aug 13, 2014 at 11:37 AM, linkku <email address hidden> wrote:
> Hei,
>
> Could this be related?
>
> I am trying to get mythweb to work after update from Mythbuntu 12.04->
> 14.04
>
> On startup get an error:
> Exception in applyStateToGUI of plugin Plugins
> Disabling Plugin.
>
> When I try to enable password for mythweb and press Apply and get:
> No Changes found
>
> and the text from the terminal:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Traceback (most recent call last):
> File "/usr/bin/mythbuntu-control-centre", line 383, in refreshState
> plugin.applyStateToGUI()
> File "/usr/share/mythbuntu/plugins/python/plugins.py", line 92, in applyStateToGUI
> self.mythweb_password_combobox.append_text("Reconfigure")
> AttributeError: 'ComboBox' object has no attribute 'append_text'
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1316905
>
> Title:
> MCC crashes with error on mysql plugin
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mythbuntu/+bug/1316905/+subscriptions

tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers