mythlcdserver crashed with SIGSEGV in ref()

Bug #1105549 reported by wam on 2013-01-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mythbuntu
Expired
Undecided
Unassigned

Bug Description

garbage "RE" characters on display, so front-end closed, LCDd restarted, then front-end restarted

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: mythtv-frontend 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
ProcVersionSignature: Ubuntu 3.2.0-36.57-generic 3.2.35
Uname: Linux 3.2.0-36-generic x86_64
NonfreeKernelModules: nvidia
.var.log.mythtv.mythavtest.log:

.var.log.mythtv.mythccextractor.log:

.var.log.mythtv.mythjobqueue.log:

.var.log.mythtv.mythmediaserver.log:

.var.log.mythtv.mythshutdown.log:

.var.log.mythtv.mythtranscode.log:

.var.log.mythtv.mythutil.log:

.var.log.mythtv.mythwelcome.log:

ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
CrashCounter: 1
CrashDB: mythbuntu
Date: Sat Jan 26 00:40:03 2013
ExecutablePath: /usr/bin/mythlcdserver
Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
MarkForUpload: True
ProcCmdline: /usr/bin/mythlcdserver --verbose general --loglevel info --syslog local7
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x4050bf <QString::QString(QString const&)+15>: lock incl (%rax)
 PC (0x004050bf) ok
 source "(%rax)" (0x00000031) not located in a known VMA region (needed readable region)!
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: mythtv
StacktraceTop:
 ref (this=0x31) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
 QString::QString (this=<optimized out>, other=...) at /usr/include/qt4/QtCore/qstring.h:726
 TunerStatus (this=0x7fff7741d200) at ../../libs/libmythtv/tvremoteutil.h:18
 LCDProcClient::outputRecStatus (this=0x9676b0) at lcdprocclient.cpp:1998
 QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
Title: mythlcdserver crashed with SIGSEGV in ref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin mythtv plugdev sambashare sudo video

wam (flaurent) wrote :
Thomas Mashos (tgm4883) on 2013-01-26
information type: Private → Public
Thomas Mashos (tgm4883) wrote :

We really do appreciate you opening this ticket to help improve Mythbuntu, but it needs to be closed for a number of reasons. The biggest one is that upstream has moved on to a new version and believes this to be fixed. Could you please verify if this issue still exists in the latest version?

Please do not let the closing of this ticket dissuade you from opening a new ticket if this (or any other) problem occurs with the newer versions.

Changed in mythbuntu:
status: New → Expired
To post a comment you must log in.