Fix signal handling

Bug #528437 reported by krzysin on 2010-02-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-mmm
Medium
Pascal Hofmann

Bug Description

I use CentOS release 5.4 (Final)

This is perl, v5.8.8 built for x86_64-linux-thread-multi

http://search.cpan.org/~timb/DBI/DBI.pm#Signal_Handling_and_Canceling_Operations

When I use DBI does not work for me
local $SIG{ALRM} = sub { die "TIMEOUT\n" };

Working correctly POSIX::SigAction

Fix in file

krzysin (krzysin) wrote :
Pascal Hofmann (pascalhofmann) wrote :

Thx for your patch, I'll have a look at it any maybe include it in the next release.

Changed in mysql-mmm:
assignee: nobody → Pascal Hofmann (pascalhofmann)
importance: Undecided → Medium
milestone: none → 2.1.1
status: New → Confirmed
ufaria (ufaria-prisacom) wrote :

could be the cause of this bug?

https://bugs.launchpad.net/mysql-mmm/+bug/473962

krzysin (krzysin) wrote :

yes

Pascal Hofmann (pascalhofmann) wrote :

No :-)

Pascal Hofmann (pascalhofmann) wrote :

Applied to trunk. Thanks!

Changed in mysql-mmm:
status: Confirmed → Fix Committed
Changed in mysql-mmm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches