tabs or spaces in config file causes failures

Bug #494128 reported by Aaron Gee on 2009-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-mmm
Low
Pascal Hofmann

Bug Description

What: Lots of errors caused by the config file from the mysql-mmm-2.0.10.tar.gz

Explain: The issue is caused by spaces or tabs after usernames/passwords in the file. This causes the agent and various functions to fail with username/passwd issues OR a path issue. In the default tar ball there are several errors caused by space or tabs after mmm_agent user or tab after bin_path of mmm_mon.conf

Log Output Examples:

FATAL Couldn't sync with master: ERROR: Can't connect to MySQL (host = 10.208.67.2:3306, user = mmm_agent )! Access denied for user 'mmm_agent '@'master_db' (using password: YES)

mmmd_mon.warn:2009/12/08 11:38:35 WARN No binary found for killing hosts (/usr/bin/mysql-mmm//monitor/kill_host)

Suggested Fix: The code should ignore all white space after usernames/passwords and other config values in the config file.

tags: added: config files
Changed in mysql-mmm:
assignee: nobody → Pascal Hofmann (pascalhofmann)
importance: Undecided → Low
status: New → Fix Committed
Changed in mysql-mmm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers