Use portable uptime instead of Linux only

Bug #465107 reported by Martin on 2009-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-mmm
Medium
Pascal Hofmann

Bug Description

You are using MMM::Common::Uptime which supports Linux only, even the code has a note to add support for Solaris.

There is a CPAN lib which has portable uptime:

http://search.cpan.org/~pioto/Unix-Uptime-0.3201/lib/Unix/Uptime.pm

Changed in mysql-mmm:
assignee: nobody → Pascal Hofmann (pascalhofmann)
importance: Undecided → Medium
status: New → Confirmed
Changed in mysql-mmm:
status: Confirmed → In Progress
Pascal Hofmann (pascalhofmann) wrote :

Solution is not perfect, but i don't want Unix::Uptime as dependency (theres no .deb for it).

Changed in mysql-mmm:
status: In Progress → Fix Committed
Changed in mysql-mmm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers