Make init scripts return LSB-compliant exit status codes

Bug #383872 reported by Pascal Hofmann on 2009-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-mmm
Medium
Unassigned

Bug Description

Check whether the init scripts return LSB-compliant exit status codes and fix them if not.

See: http://refspecs.freestandards.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic/iniscrptact.html

When trying to stop mmmd_mon (version 1.x) via heartbeat this happens:

Jun 4 16:19:45 webserver1 ResourceManager[30311]: info: Running /etc/init.d/mmm_mon stop
Jun 4 16:19:45 webserver1 ResourceManager[30311]: ERROR: Return code 1 from /etc/init.d/mmm_mon
Jun 4 16:19:45 webserver1 ResourceManager[30311]: ERROR: Resource script for mmm_mon probably not LSB-compliant.
Jun 4 16:19:45 webserver1 ResourceManager[30311]: WARN: it (mmm_mon) MUST succeed on a stop when already stopped

Also affects MMM 2.0 I think

Related branches

Changed in mysql-mmm:
importance: Undecided → Medium
Changed in mysql-mmm:
assignee: nobody → Pascal Hofmann (pascalhofmann)
description: updated
summary: - Make init scripts LSB-compliant
+ Make init scripts return LSB-compliant exit status codes
Changed in mysql-mmm:
assignee: Pascal Hofmann (pascalhofmann) → nobody
status: New → Confirmed
Pascal Hofmann (pascalhofmann) wrote :

Fixed for MMM 2 since 2009-06-06. (removed link to MMM 1)

Changed in mysql-mmm:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers