Manipulating view slow after using rotate

Bug #581962 reported by desconocidohu on 2010-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MyPaint
Fix Committed
Undecided
Unassigned
mypaint (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mypaint

Hi, I have a Intel Core Quad 6000 with 8Gb of DDR2 RAM. mypaint is slow in my system only in Ubuntu 10.04 x86 with PAE, in windows 7 64bits is slow but less. I have two computer with mypaint, the another PC is a notebook with 1GB of ram, Ubuntu 10.04 x86 (wubi) and a slow Core Duo, in the notebook mypaint is more fast like in the quad core (windows o Ubuntu).

All the system are slow when I rotate, zoom and move the work.

I have new data for the bug. The problem begins when I rotated the image, the panning is normal before this. I prove the git version and has the problem

Jon Nordby (jonnor) wrote :

Please provide the following information:
1) Detailed steps to reproduce.
And; How big is the image you're painting? Are you using the interactive or stepped zoom/pan/rotate?
2) Exact description of what happens, and what you expected to happen.
And; What do you mean by "slow"? Just how slow?

Changed in mypaint (Ubuntu):
status: New → Incomplete

Steps:
- Open MyPaint
- draw something (for reference)
- rotate with Ctrl+Space hotkey (very slow)
- After rotating the zoom and move slows.
- If I reset the image position (rotate, move, zoom), the move is normal again.

The image is little (I don't Know... 600x400 +or-) but if I do this in fullscreen mode is slower than in windows view.

SLow: Very, very slow. For rotate my paint in a windows (600x400) the system need one or 2 seconds, in fulscreen mode this could be 4 o 6 seconds. In fullscreen the full system slows when I do this, normally i need reset xserver or kill the "python2.6" process because the windows don't response.

Sorry for my english.

Jon Nordby (jonnor) wrote :

Ok, that is helpful. Several seconds is definitely slower than expected.
Can you please upload an image that makes this happen?
Also, are you using Compiz? And what graphics card driver?

The bug happens with a blank image, without any line. The card is a ati 4850 with OS drivers and I use compiz. Now I can´t see that happens if I use metacity.

Jon Nordby (jonnor) wrote :

I cannot reproduce this issue on a live-cd when using Intel graphics and compiz. So this bug seems to be due to interactions between the radeon driver and compiz. Please report if you have any information that suggest otherwise.

Jon Nordby (jonnor) on 2010-05-27
summary: - rotate, move and zoom slow
+ Manipulating view slow after using rotate

I have the bug in compiz and metacity in GNOME... and in fluxbox. I have other PC with ATI X1950PRO in Ubuntu 9.10 with OS drivers and I don have the bug. If I can use the privative drivers I tell you the results.

Ok, the bug only success with OS drivers. Where can i report this?

Sorry for the lost time.

Jon Nordby (jonnor) wrote :

The issue was in MyPaint after all and has now been fixed upstream: http://gna.org/bugs/?16122

Jon Nordby (jonnor) on 2010-10-07
Changed in mypaint (Ubuntu):
status: Incomplete → Confirmed
Changed in mypaint:
importance: Unknown → Undecided
status: Unknown → New
Jon Nordby (jonnor) on 2010-10-07
Changed in mypaint:
status: New → Fix Committed
MarcRandolph (mrand) on 2010-10-07
Changed in mypaint:
importance: Undecided → Unknown
status: Fix Committed → Unknown
importance: Unknown → Undecided
status: Unknown → New
Jon Nordby (jonnor) on 2010-10-07
Changed in mypaint:
status: New → Fix Committed
Lenin (gagarin) wrote :

is 0.9.0 performing better?

In my laptop with Ubuntu 10.04 the final release i smore slow, in my q6600 with windows the beta is more slow.

When I can do best test I report this results.

Hi again.

I test mypaint 0.82 and 0.9 in Ubuntu 10.04 with the open drivers for the ATI 4850. The old version have the same problem but this problem in 0.9 don't appear. Work Perfect!!

But in Windows 7 64bits edition mypaint 0.9 don't work. The program don't show the window, close before show nothing. This secuence is only one or two seconds

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.