mylvmbackup exits with error on empty prefix

Bug #256352 reported by Lenz Grimmer on 2008-08-09
2
Affects Status Importance Assigned to Milestone
mylvmbackup
Low
Lenz Grimmer
Debian
New
Unknown

Bug Description

By default mylvmbackup uses the prefix "backup" for naming the
compressed backup file and as leading directory for the backed up files.

If you want to get backups without any prefix and try to set
prefix=
in /etc/mylvmbackup.conf, mylvmbackup exits with an error:
Error: Please make sure Temp dir (/snap//) is empty.

The Temp dir was empty before starting mylvmbackup, but the aborted
backup leaves a directory
<mountdir>/-pos
behind.

Other perhaps relevant parameters in mylvmbackup.conf:
xfs=1
mountdir=/snap/
relpath=/var/lib/mysql/
backuptype=tar
(omitting the trailing slashes doesn't change the error)

Seems like this happens because of mylvmbackup trying to store the two
internal files
*_mysql.pos
*_my.cnf
in a special subdirectory. (Why is that?)

Lenz Grimmer (lenzgr) wrote :

Sorry for the late reply! I can confirm this problem but wonder how you were actually able to enter a non-empty prefix - the code has a check that should abort in this case. Currently, a non-empty prefix is not supported - I will have to investigate if this can be fixed easily. The special subdirectory is created to store the Server's configuration file my.cnf as well as the binlog position information of this host and any replication slaves it might serve.

Changed in mylvmbackup:
status: New → Confirmed
Lenz Grimmer (lenzgr) on 2008-10-02
Changed in mylvmbackup:
assignee: nobody → lenzgr
Lenz Grimmer (lenzgr) on 2008-11-24
Changed in mylvmbackup:
importance: Undecided → Low
Lenz Grimmer (lenzgr) wrote :

Closing this one as "Won't fix" - the prefix is a requirement in order to be able to name the backups. The code contains a check that rejects empty prefixes, so a missing prefix should be caught properly.

Changed in mylvmbackup:
status: Confirmed → Won't Fix
Lenz Grimmer (lenzgr) wrote :

Reopening this one - I am working on an overhaul of the backup naming code. Soon, you will have more flexibility in how the backup files will be named.

Changed in mylvmbackup:
status: Won't Fix → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.