crash when specifying both --help and $mail_report_on eq 'always'

Bug #1351000 reported by pml@louisiana.edu
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mylvmbackup
Medium
Lenz Grimmer

Bug Description

If the --help option is specified and $mail_report_on eq 'always', the $mail_buffer variable is never assigned a value so perl issues an error message:

  Use of uninitialized value $mail_buffer in string at /usr/bin/mylvmbackup line 1179

Since it is doubtful that a mail report is desired if --help is specified my solution was to add

  $mail_report_on = 'never';

as the first line on the help() subroutine.

Related branches

Revision history for this message
Lenz Grimmer (lenzgr) wrote :

That makes sense - thanks for the report and sorry for the late reply. I'll look into fixing this for the next release.

Changed in mylvmbackup:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Lenz Grimmer (lenzgr)
milestone: none → 0.16
Revision history for this message
Lenz Grimmer (lenzgr) wrote :

Fixed as suggested and pushed into the trunk. Thanks!

Changed in mylvmbackup:
status: Confirmed → Fix Committed
Lenz Grimmer (lenzgr)
Changed in mylvmbackup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers