fails to build with zlib 1.2.6

Bug #948122 reported by redguy on 2012-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Data Dumper
Medium
Unassigned

Bug Description

When trying to build against zlib 1.2.6 (and possibly 1.2.5) mydumper fails to build with error:

/usr/lib/ccache/gcc -Wall -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -Werror -O3 -g -I/usr/include/mysql -DBIG_JOINS=1 -fno-strict-aliasing -DUNIV_LINUX -DUNIV_LINUX -I/usr/include/mysql -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -o CMakeFiles/mydumper.dir/binlog.c.o -c /tmp/buildd/mydumper-0.5.1/binlog.c
/tmp/buildd/mydumper-0.5.1/binlog.c: In function 'new_binlog_file':
/tmp/buildd/mydumper-0.5.1/binlog.c:244:10: error: assignment from incompatible pointer type [-Werror]
/tmp/buildd/mydumper-0.5.1/binlog.c: In function 'close_binlog_file':
/tmp/buildd/mydumper-0.5.1/binlog.c:255:3: error: passing argument 1 of 'gzclose' from incompatible pointer type [-Werror]
/usr/include/zlib.h:1488:12: note: expected 'gzFile' but argument is of type 'struct FILE *'
cc1: all warnings being treated as errors
make[3]: *** [CMakeFiles/mydumper.dir/binlog.c.o] Error 1
make[3]: Leaving directory `/tmp/buildd/mydumper-0.5.1/obj-x86_64-linux-gnu'
make[2]: *** [CMakeFiles/mydumper.dir/all] Error 2
make[2]: Leaving directory `/tmp/buildd/mydumper-0.5.1/obj-x86_64-linux-gnu'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/mydumper-0.5.1/obj-x86_64-linux-gnu'

it seems that the problem is similar to [1].

[1] http://postgresql.1045698.n5.nabble.com/incompatible-pointer-types-with-newer-zlib-td5507468.html

Related branches

redguy (mateusz-kijowski) wrote :

The attached patch seems to solve the issue

Changed in mydumper:
status: New → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers