Weather data became not available

Bug #852704 reported by Leo
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
my-weather-indicator
High
Lorenzo Carbonell

Bug Description

Weather became not available. Location St Petersburg, Russia not shows weather and other info. Another Russian place (Moskow for example) has the same result.

Revision history for this message
Aendy (andyxxi) wrote :

Same bug. Weather forecasts for Russian locations became not available some days ago.

Revision history for this message
Edgar Cherkasov (edgar2705) wrote :

Same bug. Forecast for Lobnya not works

Revision history for this message
corristo87 (corristo87-deactivatedaccount-deactivatedaccount-deactivatedaccount) wrote :

Same here for: Krakow, Poland

Revision history for this message
Ashley Payton (marash-payton) wrote :

No longer works for Toulouse, either.

Revision history for this message
Benoit à la Guillaume (abalg-no-log) wrote :

Same bug in France. Weather's information became unavailable whatever the french city used.

Revision history for this message
clapico (claude-picot) wrote :

Same thing in France : Weather's information became unavailable whereever the city used.

Revision history for this message
J.S Geffroy (js-geffroy) wrote :

Same for me , France. Tried Londres in uk which works fine. Which website is used to get the data?

Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

My-Weather-Indicator uses Google Weather API. Could you run My-Weather-Indicator from terminal?

Changed in my-weather-indicator:
assignee: nobody → Lorenzo Carbonell (lorenzo-carbonell)
importance: Undecided → High
Revision history for this message
maciek (bikemaciek) wrote :

garwol@garwol-MS-7267:~$ /usr/share/my-weather-indicator/my-weather-indicator.py
<urlopen error Root 0>
4.62509018068
16.8646700827
4.62509018068
16.8646700827
4.62509018068
16.8646700827
4.62509018068
16.8646700827
4.6513886681
16.8266374699
4.6513886681
16.8266374699
4.67772815608
16.7886315456
4.67772815608
16.7886315456
4.70411175203
16.7506605835
4.70411175203
16.7506605835
########################################################
Condiciones actuales
{'moon_phase': 'D\xc4\x85\xc5\xbcy do nowiu', 'moon_icon': 'mwi-moon24', 'temperature': 'B/D', 'dew_point': 'B/D', 'humidity': 'B/D', 'condition_text': 'Niedost\xc4\x99pny', 'wind_condition': 'B/D', 'condition_icon_dark': 'mwid-not-available', 'condition_icon_light': 'mwil-not-available', 'condition': 'Niedost\xc4\x99pny', 'sunset': '18:51', 'sunrise': '06:37', 'feels_like': 'B/D', 'condition_image': 'mwig-not-available'}
########################################################
Condiciones guardadas
None
5.77603922341
18.0292530729
5.77603922341
18.0292530729
5.77603922341
18.0292530729
5.77603922341
18.0292530729
5.80555611046
17.9880050656
5.80555611046
17.9880050656
5.83511389782
17.9467843958
5.83511389782
17.9467843958
5.86471596123
17.9055990696
5.86471596123
17.9055990696

location is Wroclaw, Poland

Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

What version of my-weather-indicator did you install?

OK! I got it.

Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

Please, try last version, and tell me if bug is fixed.

Thanks!!

Changed in my-weather-indicator:
status: New → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
Gilles Poudevigne (gillespdv) wrote :

I'm using 0.4.1.5.
No information available for any city in France, Poland and Russia.
I tried with a dozen of other countries, and it works fine.
No idea of the reason for this bug that is only for these 3 countries.

Revision history for this message
jack (jumpinjack) wrote :

Same here, using version 0.4.1.5 with Natty. I confirm no info for Paris, France for example.

Revision history for this message
Nicolas Wolff (npjwolff) wrote :

I run also the version 0.4.1.5 with Ubuntu 11.04. No weather data is showning for France sites but London or Berlin is working.
When I run Google weather API from a browser, it returns data.
Eg: http://www.google.com/ig/api?weather=%22Paris,france%22 returns
<xml_api_reply version="1"><weather module_id="0" tab_id="0" mobile_row="0" mobile_zipped="1" row="0" section="0"><forecast_information><city data="Paris, Île-de-France"/><postal_code data=""Paris,france""/><latitude_e6 data=""/><longitude_e6 data=""/><forecast_date data="2011-09-27"/><current_date_time data="2011-09-27 06:30:00 +0000"/><unit_system data="SI"/></forecast_information><current_conditions><condition data="Temps clair"/><temp_f data="59"/><temp_c data="15"/><humidity data="Humidité : 94 %"/><icon data="/ig/images/weather/sunny.gif"/><wind_condition data="Vent : N à 6 km/h"/></current_conditions><forecast_conditions><day_of_week data="mar."/><low data="13"/><high data="25"/><icon data="/ig/images/weather/mostly_sunny.gif"/><condition data="Ensoleillé dans l'ensemble"/></forecast_conditions><forecast_conditions><day_of_week data="mer."/><low data="13"/><high data="26"/><icon data="/ig/images/weather/mostly_sunny.gif"/><condition data="Ensoleillé dans l'ensemble"/></forecast_conditions><forecast_conditions><day_of_week data="jeu."/><low data="12"/><high data="27"/><icon data="/ig/images/weather/mostly_sunny.gif"/><condition data="Ensoleillé dans l'ensemble"/></forecast_conditions><forecast_conditions><day_of_week data="ven."/><low data="14"/><high data="27"/><icon data="/ig/images/weather/mostly_sunny.gif"/><condition data="Ensoleillé dans l'ensemble"/></forecast_conditions></weather></xml_api_reply>

Changed in my-weather-indicator:
status: Fix Committed → Fix Released
Changed in my-weather-indicator:
status: Fix Released → In Progress
Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

The new version fix the

Changed in my-weather-indicator:
status: In Progress → Fix Committed
Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

The new version fix the bug, please try it and confirm.

Thanks everybody

Revision history for this message
corristo87 (corristo87-deactivatedaccount-deactivatedaccount-deactivatedaccount) wrote :

I could check this, but I don't know how to install new version from source. Please provide new version of package or instructions how to create one.

Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

What is the version of your Ubuntu?

Revision history for this message
corristo87 (corristo87-deactivatedaccount-deactivatedaccount-deactivatedaccount) wrote :

Ubuntu 11.04 x64

Revision history for this message
Aendy (andyxxi) wrote :

Can you provide the package for 11.04 x86 too, please?

Revision history for this message
monkegoist (monkegoist) wrote :

So far, no download link for 0.4.2.11 version.

Revision history for this message
Aendy (andyxxi) wrote :

https://launchpad.net/~atareao/+archive/test/+packages
this bug is fixed in version 0.4.2.12, thank you

Revision history for this message
corristo87 (corristo87-deactivatedaccount-deactivatedaccount-deactivatedaccount) wrote :

It's working for Poland, thanks :)

Revision history for this message
monkegoist (monkegoist) wrote :

Confirmed, thank you.

Revision history for this message
Edgar Cherkasov (edgar2705) wrote :

Working for Russia. Thank you !

Revision history for this message
Leo (llenchikk) wrote :

Latest version from ppa working!

Changed in my-weather-indicator:
status: Fix Committed → Fix Released
Revision history for this message
Gilles Poudevigne (gillespdv) wrote :

Works for France also.
Thanks

Revision history for this message
Sflash (miksmar) wrote : Re: [Bug 852704] Re: Weather data became not available

Dear Lorenzo

Now everything works perfectly, thanks

Revision history for this message
Benoit à la Guillaume (abalg-no-log) wrote :

Esto funciona bien para Francia. Muchas gracias Lorenzo

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Bug attachments