gnome-shell crashed at xcb_io.c:260: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost'' failed

Bug #1877075 reported by errors.ubuntu.com bug bridge on 2020-05-06
52
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mutter
Unknown
Unknown
mutter (Ubuntu)
High
Daniel van Vugt
Focal
High
Daniel van Vugt
Groovy
High
Daniel van Vugt

Bug Description

[Impact]

This is the #1 crasher of gnome-shell in Ubuntu 20.04, though it's duplicated across multiple problem reports according to locale:

https://errors.ubuntu.com/problem/4de3d315d9df1c9699bda54beafeeeea8d52053c
https://errors.ubuntu.com/problem/2251b638f7a6167772f922dc5916740522c5c22b
https://errors.ubuntu.com/problem/943838b8a80c1da4f8df584b7d2ad3a13361fdd7
https://errors.ubuntu.com/problem/4b78bc9730e8681f0c42fc2ecea14d03544394f0

[Test Case]

None known. The plan is to just continue monitoring crash reports. Still, we are confident this is the fix because:

 * The offending source code in libx11 tells us it is :) and
 * The crash only started in Ubuntu with gnome-shell 3.34, which is the
   exact release in which XInitThreads was removed from mutter.

[Regression Potential]

Low. We add a single function call that tells libX11 to enable thread safety. This is the same as what we had in bionic, cosmic and disco, so it's well tested.

Daniel van Vugt (vanvugt) wrote :

This is actually the #1 (English locale) and #3 (Portuguese?) gnome-shell crash in focal this month.

https://errors.ubuntu.com/?release=Ubuntu%2020.04&package=gnome-shell&period=month

summary: - /usr/bin/gnome-shell:gnome-shell: ../../src/xcb_io.c:260:
- poll_for_event: Assertiva
- \342\200\234!xcb_xlib_threads_sequence_lost\342\200\235 falhou.
+ gnome-shell crashed with at xcb_io.c:260: poll_for_event: Assertion
+ `!xcb_xlib_threads_sequence_lost'' failed
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: - gnome-shell crashed with at xcb_io.c:260: poll_for_event: Assertion
+ gnome-shell crashed at xcb_io.c:260: poll_for_event: Assertion
`!xcb_xlib_threads_sequence_lost'' failed
tags: added: rls-ff-incoming
Daniel van Vugt (vanvugt) wrote :

If anyone experiencing this crash is reading, to work around it you should just be able to select 'Ubuntu on Wayland' on the login screen.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Leperous (scabin) wrote :

Had this after login, screen went black (cursor worked) for about 20 seconds, before the desktop recovered.

Daniel van Vugt (vanvugt) wrote :

Interesting thought. If this is the #1 crash then yes it would explain a lot of blank screen issues.

Sebastien Bacher (seb128) wrote :

Daniel, could you have a go to this one?

Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: removed: rls-ff-incoming
Changed in mutter (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Changed in mutter (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
no longer affects: gnome-shell (Ubuntu)
Changed in mutter (Ubuntu):
status: In Progress → Fix Committed
no longer affects: xorg-server (Ubuntu)
tags: added: fixed-in-3.36.3 fixed-upstream
tags: added: fixed-in-3.34.7
Daniel van Vugt (vanvugt) wrote :
tags: added: groovy
Changed in mutter (Ubuntu Groovy):
status: Fix Committed → In Progress
Changed in mutter (Ubuntu Focal):
status: New → Triaged
importance: Undecided → High
description: updated
Changed in mutter (Ubuntu Focal):
assignee: nobody → Daniel van Vugt (vanvugt)
description: updated
Changed in mutter (Ubuntu Focal):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.36.3-1ubuntu1

---------------
mutter (3.36.3-1ubuntu1) groovy; urgency=medium

  * Merge with debian, including new stable upstream release
  * debian/control: BD on adwaita-icon-theme 3.36.1-2ubuntu3.
    This version includes all the window decoration icons that mutter uses
  * Remaining changes with debian:
    - debian/control:
      + Update VCS flags to point to ubuntu salsa branch
    - debian/gbp.conf: update branch to point to ubuntu/master
    - debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      + X11: Add support for fractional scaling using Randr

mutter (3.36.3-1) unstable; urgency=medium

  * New upstream release (LP: #1881971)
   - Broadcast clipboard/primary offers
   - Fix monitor screen cast on X11
   - Implement touch-mode detecation for the X11 backend (LP: #1880596)
   - Drop external keyboard detection from touch-mode heuristics
   - Fix leaked DMA buffers in screencasts
   - Fixed crashes

mutter (3.36.2+12+gb425f1153-1) experimental; urgency=medium

  * Team upload
  * New upstream snapshot from the gnome-3-36 branch
  * d/p/backend-x11-Reintroduce-XInitThreads.patch:
    Drop patch, applied upstream

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 04 Jun 2020 21:46:56 +0200

Changed in mutter (Ubuntu Groovy):
status: In Progress → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted mutter into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.36.3-0ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Daniel van Vugt (vanvugt) wrote :

Verified the fix is present in mutter_3.36.3.orig.tar.xz but as mentioned above, no known test case.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
description: updated

The verification of the Stable Release Update for mutter has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.36.3-0ubuntu0.20.04.1

---------------
mutter (3.36.3-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream release (LP: #1881971)
    - Broadcast clipboard/primary offers
    - Fix monitor screen cast on X11
    - Implement touch-mode detecation for the X11 backend (LP: #1880596)
    - Drop external keyboard detection from touch-mode heuristics
    - Fix leaked DMA buffers in screencasts
    - Fixed crashes
  * Refreshed patches
  * d/p/backend-x11-Reintroduce-XInitThreads.patch:
    - Dropped (merged upstream)

mutter (3.36.2-1ubuntu1~20.04.2) focal; urgency=medium

  [ Daniel van Vugt ]
  * d/p/backend-x11-Reintroduce-XInitThreads.patch:
    Fix a very common crash when running in X11 (LP: #1877075)

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 05 Jun 2020 19:29:32 +0200

Changed in mutter (Ubuntu Focal):
status: Fix Committed → Fix Released
Dani (scrlk) wrote :

I'm running mutter version 3.36.3-0ubuntu0.20.04.1 but I still have the same problem.

Daniel van Vugt (vanvugt) wrote :

The issue is continued in bug 1886059.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.