tandem raise/lower for half-screen snapped windows breaks normal workflows

Bug #1753893 reported by cleary
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mutter
Confirmed
Wishlist
mutter (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

This has been reported upstream, and fixed/reverted:

> Mantas Mikulėnas (grawity) 2017-10-07 17:58:32 UTC
> A recent commit added this feature:
>
> window: Raise and lower tile match in tandem
>
> When a pair of tiled windows are grouped together, they
> are treated as parts of a whole and interacting with one
> affects the other.
>
> Following the idea that sibling tiled windows are treated
> as part of the same group, they should also be raised and
> lowered together.

> I'd like to ask for this to be optional, as in practice it ends up more
> annoying than useful. (For example, the way it selects a match is prone
> to accidentally grouping unrelated windows just because they're next to
> each other in the z-order...)

https://bugzilla.gnome.org/show_bug.cgi?id=788644

The revert commit:
https://gitlab.gnome.org/GNOME/mutter/commit/415584344a5d4b5

This is not currently in 18.04, I think it's important to include - can I make a wishlist request? :D

Changed in mutter:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Revision history for this message
Jeremy Bicha (jbicha) wrote :

I'm marking this Fix Released because I already finalized the debian/changelog entry for mutter 3.28.0-1. The update will be synced from Debian tomorrow.

Changed in mutter (Ubuntu):
status: New → Fix Released
Revision history for this message
cleary (bernard-gray) wrote :

Fantastic, thankyou!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.