Desktop icons slip under the top bar and dock

Bug #1696621 reported by Daniel van Vugt on 2017-06-08
84
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
mutter (Ubuntu)
Medium
Andrea Azzarone

Bug Description

Desktop icons slip under the top bar after logging in again.

If I place icons on the desktop in Gnome Shell they look fine, until I log out and log in again. On the second login they have moved half under the top bar.

The same problem is visible in the Ubuntu live session starting with 20170607.

tags: added: artful
Jeremy Bicha (jbicha) wrote :

I think this should be considered a nautilus bug first since gnome-shell itself does not draw desktop icons.

By the way, I don't believe the Ubuntu Desktop team has discussed yet whether to show desktop icons by default in 17.10.

Daniel van Vugt (vanvugt) wrote :

Yes and no. Nautilus draws the desktop (including icons) but it remains to be seen where the root cause of this bug is. It might be gnome-shell failing to communicate the work area correctly to nautilus...

As for whether to show desktop icons at all, it should be noted this is a different decision to when we were looking at Unity8. In Unity8/Mir the desktop icons didn't exist simply because supporting desktop windows like nautilus wasn't anywhere near implemented yet. But users did complain even in the limited testing of Unity8, about not being able to use the desktop as a desktop for icons.

Daniel van Vugt (vanvugt) wrote :

Also note...

Starting in http://cdimage.ubuntu.com/daily-live/20170607/
the live session relies on putting icons on the desktop and this bug is immediately visible on boot.

So I guess we do need to fix this.

summary: - Desktop icons slip under the top bar after logging in again
+ Desktop icons slip under the top bar
description: updated
tags: added: visual-quality
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Changed in nautilus (Ubuntu):
importance: Undecided → Medium

Yes, I am aware that the live session has an Install Ubuntu icon on the desktop. Ubuntu GNOME does not. Fedora worked around this with a simple Welcome app that starts the installer or tells you where to find the installer if you want to close the Welcome app.

I will be proposing that Ubuntu 17.10 install gnome-tweak-tool by default.

Just because many people want desktop icons does not mean that they have to be enabled by default if we provide an easy way for them to be enabled. Because of course there are many people who don't use desktop icons. (It sounds like the Unity8 complaining may have been because it was impossible, not necessarily because of the defaults.)

summary: - Desktop icons slip under the top bar
+ Desktop icons slip under the top bar after logging in
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: New → Confirmed

I experience exactly the same problem. I have been messing around with Arch Linux for the past few weeks (w/ GNOME 3.24), and despite my best efforts I haven't been able to solve this bug/glitch. Repeated (latest) installs, but no luck. Have you made any progress?

One thing that may be related is a strange Nautilus error message when one attempts to rename one of the desktop icons for the first time. Try the wastebasket, for example, and let me know what happens for you. Regards.

Daniel van Vugt (vanvugt) wrote :

Two interesting observations:

1. nautilus-desktop is an X11 app! It requires Xwayland when run in a Wayland session.

2. Gnome developers don't like it: https://wiki.gnome.org/Apps/Nautilus/Desktop

tags: added: gnome-17.10
fcole90 (fcole90) wrote :

If I open nautilus the icons suddenly move in an appropriate position. Look duplicate bug #1705285 for screenshots of before and after opening nautilus.

tags: added: julyshakedown
Daniel van Vugt (vanvugt) wrote :

I think the correct fix is for all docks and shells to implement _NET_WORKAREA:
https://specifications.freedesktop.org/wm-spec/wm-spec-1.3.html#idm140130317674416

Unfortunately that's an X11-only thing. nautilus-desktop certainly relies on it being an X11 app, but if your dock is native Wayland then we might have trouble fixing this because a native Wayland app would have to make X11 calls to tell nautilus-desktop about the _NET_WORKAREA.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
summary: - Desktop icons slip under the top bar after logging in
+ Desktop icons slip under the top bar and dock after logging in
summary: - Desktop icons slip under the top bar and dock after logging in
+ Desktop icons slip under the top bar and dock
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) wrote :

@Daniel: please stop adding a bunch of components to one bug if you are unsure about it. STRUT here isn't the right answer for intellihide, as it will prevent all windows to go at the dock place. This is the reason why my duplicated bug report only targetted nautilus and should remain that way. Cleaning again the component list…

no longer affects: gnome-shell-extension-ubuntu-dock (Ubuntu)
Didier Roche (didrocks) wrote :

I'm letting though gnome-shell (should be maybe better), because initial window placement should take the launcher into account.

Daniel van Vugt (vanvugt) wrote :

I should have mentioned I was only suggesting STRUT for when intellihide is off. Thus for the default configuration this bug would be fixed. Only people who change the configuration (e.g. change intellihide) would need to move their icons. But yes a fix could come in nautilus too, that would work for all values of intellihide.

Didier Roche (didrocks) wrote :

STRUT (or wayland equivalent) is already applied). The bug is different and was better conveyed in the one you duplicated then:
- nautilus doesn't refresh at start, and so icons aren't moved, after STRUT is applied
- and there is the issue with intellihide, which was part of my duplicate (so I assumed this bug was covering the one you duplicated from as well)

Andrea Azzarone (azzar1) on 2017-09-06
no longer affects: gnome-shell (Ubuntu)
no longer affects: nautilus (Ubuntu)
no longer affects: mutter
Changed in mutter (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
sibe39 (sibe39) wrote :

The problem is still here.

Please, can you solve it before the release of the 17.10 because it is very annoying visually and this is the first thing you notice.

https://img11.hostingpics.net/pics/996168Capturedcrande20170920203951.png

Changed in gnome-shell:
status: Confirmed → Fix Released
affects: gnome-shell → mutter
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.0-2

---------------
mutter (3.26.0-2) experimental; urgency=medium

  * debian/patches/src-core-screen.c-Set-_NET_NUMBER_OF_DESKTOPS-in-met.patch:
    Cherry-pick from upstream. Fix positioning of desktop icons at startup.
    (LP: #1696621)

 -- Iain Lane <email address hidden> Fri, 22 Sep 2017 19:13:26 +0100

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
sibe39 (sibe39) wrote :

Yes, it is resolved

Changed in mutter:
status: Fix Released → Confirmed
Changed in mutter:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.