Music App freezes on opening

Bug #1632728 reported by GTriderXC on 2016-10-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Music App
Undecided
Unassigned

Bug Description

My music app opens, starts to load the track list and freezes as You can see in the picture.
It doesn't work any more no matter what I do. I can reboot as many times as I like and nothing changes.
It doesn't react as if I was touching a .jpg image. Sometimes the loading process goes goes a little bit further so that some icons are visible next to the titles. It started one day as I downloaded some big mp3 files that I moved later from device memory to the sd card. Since it happened to me my file manager doesn't function properly any more either. I reported a bug for it here:

https://bugs.launchpad.net/ubuntu-filemanager-app/+bug/1628223

On a mailing list there was only one person with a similar case.

Bq E4.5 on OTA13

------
system-image-cli -i

current built number:35
krillin
channel: ubuntu-touch/stable/bq-aquaris.en
last update: 20.09.2016
version version 35
version ubuntu 20160913
tag:OTA-13
version device: 20160606-ab415b2
version custom: 20160831-991-38-18

GTriderXC (gtriderxc) wrote :

This is how the app freezes and there is nothing I can do except to close it.

GTriderXC (gtriderxc) wrote :
GTriderXC (gtriderxc) wrote :
GTriderXC (gtriderxc) wrote :
GTriderXC (gtriderxc) wrote :

$ sqlite3 b01631344d4b1a36d6dec3179aff8784.sqlite "DELETE FROM queue;"

Helped a bit. The player react on one, very first command (for example PLAY) or crashes. I managed to open the app and to click something. However after one click the app freezes again (even if the music plays) or crashes:

http://paste.ubuntu.com/23364315/

GTriderXC (gtriderxc) wrote :

paste.ubuntu.com/23392860

I thought the problem may be with reading the tracklist so I moved all the songs to sd card and removed it from the phone. Now the Music app showed me on launch that I have no music. As I copied a file, It showed it, played it, menu worked for one click and the app froze again.

In next step I'll try to reinstall it.

hochl (bach-1) wrote :

I habe the same Problem on krillin too

GTriderXC (gtriderxc) wrote :

It seems like many people have it (read the reviews in Ubuntu shop) but they do not report it.
@ hochl do You also have the problem I reported for a file manager? Just open it and try to copy/cut and paste a file (https://bugs.launchpad.net/ubuntu-filemanager-app/+bug/1628223). Both file manager and music app ceased to function in the same moment and since then they do not work.

hochl (bach-1) wrote :

Deleting the file /home/phablet/.config/com.ubuntu.music/music.conf and the folder /home/phablet/.local/share/com.ubuntu.music/Databases/ solved the problem for me. Maybe deleting /home/phablet/.config/com.ubuntu.music/music.conf is sufficient.

GTriderXC (gtriderxc) wrote :

I can confirm. rm -r /Databases let the app start and freeze again.

Then deleting /Databases

and

 /home/phablet/.config/com.ubuntu.music/com.ubuntu.music.conf

and

 /home/phablet/.config/com.ubuntu.music/com.ubuntu.music.conf.lock

solved the problem at the moment.
I'll try to crash it now the way I did it before. Thanks for help!

Andrew Hayzen (ahayzen) wrote :

For reference, if the .lock file exists that will stop the app launching and is bug 1576989. Not sure if this was the issue for both of you? As you mentioned deleting the Databases folder as well.

Are you both able to confirm the existence of a /home/phablet/.config/com.ubuntu.music/com.ubuntu.music.conf.lock file before you deleted the files? As I could then mark this bug as duplicate of bug 1576989.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions