Potential music app updates needed due to a change in theming/UI toolkit in OTA10

Bug #1550096 reported by Victor Thompson on 2016-02-26
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Music App
High
Victor Thompson

Bug Description

This is meant to function as a list of issues needing to be fixed once landing silo 50 lands in OTA10 [1]. There are changes in theming that resulted. This will be a running list as some of these things might change before OTA10 and/or this silo lands. Some of these issues might actually be UIToolkit issues and need more research.

1. Text typed into the now dark search bar is black and hard to read.
2. The progress bar's current position icon is dark gray.
3. Related to #2, the theming done for the slider could possibly be removed since the default is now blue.
4. Disabled header actions are not greyed out.
5. The app's startup is even more "violent" than it was before. With the silo installed the app starts up as completely white and then the Cards/ListItems fill in. Previously, IIRC, just the top would be white and the UI would shift upwards.
6. The leadingActions for Remove are no longer red with a white icon.
7. In the darker Dialog components, the cancel action is the same color as the background.

1 - https://requests.ci-train.ubuntu.com/#/ticket/905

Related branches

Changed in music-app:
status: New → Triaged
importance: Undecided → High
milestone: none → ota10
description: updated
summary: - Potential updates needed due to a change in theming/UI toolkit in OTA10
+ Potential music app updates needed due to a change in theming/UI toolkit
+ in OTA10
tags: added: ota10-sdk
description: updated
description: updated
Changed in music-app:
status: Triaged → In Progress
assignee: nobody → Music App Developers (music-app-dev)
Changed in music-app:
assignee: Music App Developers (music-app-dev) → Victor Thompson (vthompson)
description: updated

Fix committed into lp:music-app at revision 996, scheduled for release in music-app, milestone ota10

Changed in music-app:
status: In Progress → Fix Committed
Andrew Hayzen (ahayzen) wrote :

Found an additional issue where text boxes that have text but unfocussed have white text on a white background.

Steps to reproduce:
1) Go to the tracks
2) Enter a search term that returns results
3) Drag the flickable so that the keyboard disappears and focus from the search textfield is lost
4) Notice that the textfield now has white text on a white background

What I expected to happen:
At step 4) for the text to still be readable.

Changed in music-app:
status: Fix Committed → Triaged

Fix committed into lp:music-app at revision None, scheduled for release in music-app, milestone ota10

Changed in music-app:
status: Triaged → Fix Committed
Changed in music-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers