Music Player won't advance to next song if screen is blank and device is unplugged

Bug #1342351 reported by Rick Spencer on 2014-07-15
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Media Hub
Fix Released
Critical
Jim Hodapp
Ubuntu Music App
Critical
Jim Hodapp
powerd
Critical
Jim Hodapp
media-hub (Ubuntu)
Undecided
Jim Hodapp

Bug Description

1. put some music on your phone
2. go to the music scope and find the
3. go to the album view
4. open an album
5. click play in music player
6. wait until the phone screen blanks
7. wait for the song to end

Result
The next song does not play immediately, instead it plays perhaps 30-60 seconds later.

Related branches

I just rebooted my devel device and went through this and couldn't reproduce. I even uninstalled and reinstalled the music app and rebooted before testing again. It plays the next track just fine.

Rick, is this devel? Which image? Also which version of music app?

So:-

# system-image-cli --info

# click list | grep music

Is this an mp3 or flac?

If you leave it a really long time, does the next track start?
Does it do it when the phone is plugged in?

Changed in music-app:
status: New → Incomplete
Victor Thompson (vthompson) wrote :

I was unable to reproduce on my devel-proposed Nexus 4 with an mp3 album:

system-image-cli --info
current build number: 131
device name: mako
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/utopic-proposed
last update: 2014-07-15 00:43:03
version version: 131
version ubuntu: 20140715
version device: 20140712

I'll try few more permutations with the app already running, etc.

Victor Thompson (vthompson) wrote :

I might take a guess at what's occurring. In my experience if I put my phone down at a certain spot on a table the volume is *heavily* muted. Perhaps the first song that was played was sufficiently loud enough that you could tell it was playing with the phone still on the table and perhaps the second song was quiet enough that you didn't notice that it was playing until you simultaneously picked up the phone and hit the power button?

tl;dr: it was colonel mustard in the library with the candlestick

Jean-Baptiste Lallement (jibel) wrote :

Confirmed on mako with build #157

Changed in music-app:
importance: Undecided → Critical
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

actually next song starts playing after a moment (more than 30 seconds)

Victor Thompson (vthompson) wrote :

Ok, this must have to do with having the device unplugged vs plugged in. I can easily reproduce with the device unplugged.

summary: - Music Player won't advance to next song if screen is blank and music app
- is not in front
+ Music Player won't advance to next song if screen is blank, device is
+ unplugged
summary: - Music Player won't advance to next song if screen is blank, device is
+ Music Player won't advance to next song if screen is blank and device is
unplugged
description: updated

I'm seeing a 10s or so delay between one song ending and the next song start.

I've ssh'ed into my phone over wifi to tail the logs to see what happens. It's hard to decipher because there's no timestamps in the application log (grr!), but interestingly the syslog gets a bunch of messages between one song and the next which only happen between songs, as I presume there's things waking up to advance tracks.

Attached music_syslog which shows the 10s between the song ending and the next starting.
Looks like a lot of suspend shenanigans going on, which makes this unlikely to be a music-app bug.

tags: added: qa-daily-testing rtm14
Selene ToyKeeper (toykeeper) wrote :

Still happens on Utopic 161, but the delay is about 10 seconds, not 30+.

Victor Thompson (vthompson) wrote :

This doesn't appear to be in progress, but I'll echo that it still happens in Utopic 162 as well. Delay of about 10 seconds is probably accurate. Did something happen from #157 to #161 to minimize this delay?

Jim Hodapp (jhodapp) wrote :

Although I don't believe this is truly a media-hub bug, it's still possible that it might be so I've marked it as triaged.

Changed in media-hub:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Jim Hodapp (jhodapp)
no longer affects: ubuntu
Jim Hodapp (jhodapp) on 2014-08-05
Changed in media-hub:
status: Triaged → In Progress
Changed in music-app:
status: Confirmed → In Progress
assignee: nobody → Jim Hodapp (jhodapp)
Jim Hodapp (jhodapp) on 2014-08-06
Changed in powerd:
status: New → In Progress
assignee: nobody → Jim Hodapp (jhodapp)
importance: Undecided → Critical
Changed in media-hub:
status: In Progress → Invalid
Changed in music-app:
status: In Progress → Invalid
Changed in powerd:
status: In Progress → Fix Committed
Jim Hodapp (jhodapp) on 2014-08-06
Changed in powerd:
status: Fix Committed → Invalid
Changed in media-hub:
status: Invalid → In Progress
importance: High → Critical
Jim Hodapp (jhodapp) on 2014-08-08
Changed in media-hub:
status: In Progress → Fix Committed

I tried the following packages from silo 15:
  - libmedia-hub-client1:armhf 1.0.0+14.10.20140811-0ubuntu1
  - libmedia-hub-common1:armhf 1.0.0+14.10.20140811-0ubuntu1
  - media-hub 1.0.0+14.10.20140811-0ubuntu1

and there is no improvement, music player does not advance to next song when screen is blanked

Jim Hodapp (jhodapp) on 2014-08-12
Changed in media-hub (Ubuntu):
status: New → Fix Committed
assignee: nobody → Jim Hodapp (jhodapp)
Andrew Hayzen (ahayzen) wrote :

I have been testing with silo 15, with both flac and mp3 files and both of these are advancing onto the next track as expected with the power cable unplugged.

$ apt-cache policy media-hub
media-hub:
  Installed: 1.0.0+14.10.20140812-0ubuntu1
  Candidate: 1.0.0+14.10.20140812-0ubuntu1
  Version table:
 *** 1.0.0+14.10.20140812-0ubuntu1 0
        500 http://ppa.launchpad.net/ci-train-ppa-service/landing-015/ubuntu/ utopic/main armhf Packages
        100 /var/lib/dpkg/status
     1.0.0+14.10.20140808.1-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ utopic/universe armhf Packages

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package media-hub - 1.0.0+14.10.20140813-0ubuntu1

---------------
media-hub (1.0.0+14.10.20140813-0ubuntu1) utopic; urgency=low

  [ Jim Hodapp ]
  * Allow music to advance to the next song when the device is not
    charging (LP: #1342351)

  [ Jim Hodapp<email address hidden> ]
  * Allow music to advance to the next song when the device is not
    charging (LP: #1342351)
 -- Ubuntu daily release <email address hidden> Wed, 13 Aug 2014 01:42:00 +0000

Changed in media-hub (Ubuntu):
status: Fix Committed → Fix Released
Jim Hodapp (jhodapp) on 2014-08-13
Changed in media-hub:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments