Click App Preview of the core-apps are of low quality

Bug #1297357 reported by Nekhelesh Ramananthan on 2014-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dropping Letters
Low
Alan Pope 🍺🐧🐱 🦄
Sudoku App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu Calculator App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu Calendar App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu Clock App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu File Manager App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu Music App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu Shorts App
Low
Alan Pope 🍺🐧🐱 🦄
Ubuntu Weather App
Low
Alan Pope 🍺🐧🐱 🦄
notes-app
Undecided
David Planella
friends-app (Ubuntu)
Undecided
Robert Bruce Park
gallery-app (Ubuntu)
Undecided
David Planella

Bug Description

On a Ubuntu Touch phone, navigate to the app lens and long-press any core app to see its application preview. Considering that the core apps come preinstalled on the phone, they need to provide better app previews. You will notice that the following mistakes,

- Many times the short and long description are exactly the same leading to duplicate sentences being shown
- App Descriptions are too small
- Screenshots need to be updated with the latest designs or completely missing (in case of gallery-app, friends, system settings)

Clock App
- Application tagline and description are duplicated. The description can be a bit more elaborate.

Friends App
- Missing Screenshots and an app description. Only the tagline is shown
- No developer team name/author mentioned

Shorts App
- Tagline and app description start with same phrase. This could be improved better. The app description could perhaps elaborate on the features that shorts app provides like the ability to add remote feeds etc.

Calculator App
- Tagline and app description are duplicated
- Screenshot #2 doesn't look good. For instance, it could show the names of the calculation instead of showing an empty label

Music App
- Application tagline and description are duplicated
- Screenshots needs to be updated with the current design

Gallery App
- No screenshots provided

Camera App
- No screenshots. What I mean here is that perhaps a screenshots of the interface with buttons can be shown.

Media Player App
- No screenshots, description or tagline
- Developer name/author also missing

System Settings
- Tagline and app description missing
- Developer name/author missing

Dialer App, Messaging App, Contacts App, Browser App
- App description missing
- Developer team name/author missing

Changed in music-app:
importance: Undecided → Low
status: New → Confirmed
Victor Thompson (vthompson) wrote :

I think the order of importance is:
1) Improve the descriptions. This is something that those who have access to the core app click store account can do without pushing an app update. Most need some love.
2) Add previews for the apps that have none or need updates. Again, only those who have access to the core app click store account can do this and it doesn't require an app update.

For the music app, #1 should be fixed at some point. The screenshots do not deviate much from the current app, so I do not think that is needed at this time.

Robert Bruce Park (robru) wrote :

Is there any documentation available explaining how the app preview chooses to display this data?

For example, with friends-app, I see "What are your friends up to?" repeated both above and below the uninstall/open buttons, but as far as I can tell, that is only defined here:

http://bazaar.launchpad.net/+branch/friends-app/view/head:/friends-app.desktop

Which you can see only defines that information in one place (I mean, we're not defining the same string to two different keys).

So it seems to me that this is actually a bug in the app scope itself (since it's the one choosing to repeat the same .desktop comment twice), although perhaps there is a workaround in which I might add a new key to my .desktop file to make it say something else, but I'm not sure what it is.

Robert Bruce Park (robru) wrote :

Also I'm not sure how to add screenshots for friends-app, because it's not available in the app store, it comes preinstalled instead.

Changed in friends-app (Ubuntu):
assignee: nobody → Robert Bruce Park (robru)
status: New → Confirmed
Changed in ubuntu-clock-app:
milestone: 1.8 → backlog

Added unity-scope-click because it seems like a click scope issue rather than an individual app metadata issue.

dobey (dobey) wrote :

@Alan, which part of this do you think is a click scope issue exactly?

The duplicate description issue was fixed in build #9 (iirc), as we now show Publisher in the header, rather than the description. There was a bug about that in the click scope already, and it's now fixed.

Having checked my up to date phone, this does indeed look fixed. Thanks Rodney.

description: updated
description: updated
dobey (dobey) on 2014-05-07
no longer affects: unity-scope-click (Ubuntu)
dobey (dobey) wrote :

I've marked unity-scope-click as no longer affected as it's not feasible to mark this bug as a duplicate of bug #1313843 which was for the Publisher not being shown.

If there are other issues that do need fixed in the click scope, please open more specific bugs for those issues, rather than lumping them in with this (bugs that affect multiple packages/projects are really annoying to track and manage when they do not affect all those packages/projects in the same way).

dobey (dobey) wrote :

Should we include the need for merging translations into the .desktop files in this bug, or should I open another bug for this issue?

dobey (dobey) wrote :

As discussed with David on IRC, I've filed a separate bug for merging translations into the .desktop files of core apps, as bug #1318008 .

Changed in dropping-letters:
assignee: nobody → David Planella (dpm)
Changed in sudoku-app:
assignee: nobody → David Planella (dpm)
Changed in ubuntu-calculator-app:
assignee: nobody → David Planella (dpm)
Changed in ubuntu-calendar-app:
assignee: nobody → David Planella (dpm)
Changed in ubuntu-clock-app:
assignee: nobody → David Planella (dpm)
Changed in ubuntu-filemanager-app:
assignee: nobody → David Planella (dpm)
Changed in music-app:
assignee: nobody → David Planella (dpm)
Changed in ubuntu-rssreader-app:
assignee: nobody → David Planella (dpm)
Changed in ubuntu-weather-app:
assignee: nobody → David Planella (dpm)
Changed in gallery-app:
assignee: nobody → David Planella (dpm)
Changed in notes-app:
assignee: nobody → David Planella (dpm)

Collated the data to a spreadsheet where we can correct the text and then submit them all fixed en-masse.

https://docs.google.com/a/canonical.com/spreadsheets/d/1jJAcrZZL2cm5saEGsd61tdpdnCvN9MdoJyz24vdbR_c/edit?usp=sharing

Request access if you don't have it. Not a private document.

Changed in dropping-letters:
status: New → Triaged
Changed in sudoku-app:
status: New → Triaged
Changed in ubuntu-calculator-app:
status: New → Triaged
Changed in ubuntu-calendar-app:
status: New → Triaged
Changed in ubuntu-clock-app:
status: Confirmed → Triaged
Changed in ubuntu-filemanager-app:
status: New → Triaged
Changed in music-app:
status: Confirmed → Triaged
Changed in ubuntu-rssreader-app:
status: New → Triaged
Changed in ubuntu-weather-app:
status: New → Triaged
Mihir Soni (mihirsoni) on 2014-08-18
Changed in ubuntu-calendar-app:
importance: Undecided → Low
Changed in ubuntu-clock-app:
milestone: backlog → postrtm
David Planella (dpm) on 2014-10-08
Changed in ubuntu-filemanager-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
importance: Undecided → Low
Changed in dropping-letters:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
importance: Undecided → Low
Changed in friends-app (Ubuntu):
status: Confirmed → Won't Fix
Changed in sudoku-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
importance: Undecided → Low
Changed in ubuntu-calculator-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
importance: Undecided → Low
Changed in ubuntu-calendar-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
Changed in ubuntu-clock-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
Changed in music-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
Changed in ubuntu-rssreader-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
importance: Undecided → Low
Changed in ubuntu-weather-app:
assignee: David Planella (dpm) → Alan Pope ( ͡° ͜ʖ ͡°) (popey)
importance: Undecided → Low
Changed in ubuntu-calculator-app:
status: Triaged → Fix Released
affects: gallery-app → gallery-app (Ubuntu)
Changed in ubuntu-clock-app:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers