App cannot be started on clean Trusty desktop

Bug #1288885 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2014-03-06
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Dropping Letters
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Stock Ticker App
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Sudoku App
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu Calculator App
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu Clock App
High
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu File Manager App
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu Music App
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu Terminal App
Low
Alan Pope 🍺🐧🐱 πŸ¦„
notes-app
Undecided
Unassigned
notes-app (Ubuntu)
Undecided
Unassigned

Bug Description

On a clean Trusty desktop add the core apps ppa:-
sudo add-apt-repository ppa:ubuntu-touch-coreapps-drivers/daily
Install core apps from the ppa:-
sudo apt-get install music-app ubuntu-calculator-app ubuntu-clock-app
Attempt to start those apps:-

$ ubuntu-clock-app
$ ubuntu-calculator-app
$ music-app

Note they all fail to start with the same error:-

qmlscene: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/qmlscene': No such file or directory

Related branches

Interestingly weather, calendar and reminders are the three that are unaffected.

Pat McGowan (pat-mcgowan) wrote :

I notice that weather has a export QT_SELECT=qt5 prior to calling qmlscene, whereas music-app does not.
#!/bin/bash
export QT_SELECT=qt5
qmlscene /usr/share/ubuntu-weather-app/ubuntu-weather-app.qml
pat@pat-samsung:~$ more /usr/bin/music-app
#!/bin/bash
qmlscene /usr/share/music-app/music-app.qml
They both work properly on my system, but mine is not quite a clean install, and perhaps installing the SDK effects this.
Other compiled apps like reminders not invoked with qmlscene will work as well

Ok, setting QT_SELECT=qt5 with all of the apps and it works, so I'll create a merge request for them all.

Actually that's not going to fix the problem. The desktop file doesn't call the script to start the app. If we change /usr/bin/music-app we'll fix it for the people running music app from that script, but not from the dash or any other icon.

qt5-default wasn't installed on my clean trusty VM. Installing it "fixed" the issue.

Timo Jyrinki (timo-jyrinki) wrote :

It's complex, so trying to explain the situation is:
- We've QT_SELECT=qt5 set globally on the device, that's why everything works there without setting anything
- 'qt5-default' depends on development files, so it can't be used by default
- qmlscene is considered 'development binary' by upstream and 'not recommended for production', and while there has been talk that we need a simple replacement for it (since what it does is relatively simple too), those plans haven't went forward AFAIK
- The reason you see 'qt4' mentioned is because that's nowadays the fallback option when there is no configuration selected, which helps eg. KDE to remain functioning similar to before

So this is the same issue as what was on device, happening on desktop. Luckily, the qtchooser offers many ways of setting the Qt version - configuration, env var, program parameter.

You should try:
'qmlscene -qt5 /usr/share/music-app/music-app.qml' for the desktop file?

The other poorer solutions include:
- Call '/usr/lib/*/qt5/bin/qmlscene' - if expansion works, that'll also works
- A more exact version of above, call '/usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/qt5/bin/qmlscene'
- Set QT_SELECT=qt5 before launching

Bonus:
- Upstream has provided a new 'qml' binary supposed to be more suitable for those uses people have used 'qmlscene' for, so you may want to experiment with 'qml -qt5 /usr/share/music-app/music-app.qml' (after apt-get install qml). It's still worth investigating at some point, since there could be eg. startup time improvement.

Ok, confirmed that adding "-qt5" to the qmlscene command line allows the apps to run on the desktop without having to install any additional packages. Thanks Timo.

Ara Pulido (ara) on 2014-03-07
tags: added: desktop-touch
Nekhelesh Ramananthan (nik90) wrote :

So what is the solution to this? Do we recommend adding -qt5 to the qmlscene command in the .desktop file of all the core apps?

Yes Nekhelesh

Changed in ubuntu-clock-app:
importance: Undecided → High
assignee: nobody → Alan Pope γ‹› (popey)
milestone: none → 1.8
status: New → In Progress
Changed in dropping-letters:
status: New → In Progress
Changed in sudoku-app:
status: New → In Progress
Changed in ubuntu-calculator-app:
status: New → In Progress
Changed in ubuntu-filemanager-app:
status: New → In Progress
Changed in music-app:
status: New → In Progress
Changed in ubuntu-terminal-app:
status: New → In Progress
Changed in dropping-letters:
assignee: nobody → Alan Pope γ‹› (popey)
Changed in sudoku-app:
assignee: nobody → Alan Pope γ‹› (popey)
Changed in ubuntu-calculator-app:
assignee: nobody → Alan Pope γ‹› (popey)
Changed in ubuntu-filemanager-app:
assignee: nobody → Alan Pope γ‹› (popey)
Changed in music-app:
assignee: nobody → Alan Pope γ‹› (popey)
Changed in ubuntu-terminal-app:
assignee: nobody → Alan Pope γ‹› (popey)

Fix committed into lp:ubuntu-clock-app at revision 370, scheduled for release in ubuntu-clock-app, milestone 1.8

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed

Fix committed into lp:sudoku-app at revision 166, scheduled for release in sudoku-app, milestone Unknown

Changed in sudoku-app:
status: In Progress → Fix Committed

Fix committed into lp:ubuntu-calculator-app at revision 230, scheduled for release in ubuntu-calculator-app, milestone 1.6

Changed in ubuntu-calculator-app:
status: In Progress → Fix Committed

Fix committed into lp:music-app at revision 374, scheduled for release in music-app, milestone 1.0

Changed in music-app:
status: In Progress → Fix Committed
Changed in music-app:
status: Fix Committed → Fix Released

Fix committed into lp:ubuntu-filemanager-app at revision 148, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Changed in ubuntu-filemanager-app:
status: In Progress → Fix Committed
Olli Ries (ories) wrote :

stock ticker has the same issue, not listed as affected, will add

Olli Ries (ories) wrote :

notes-app suffers from the same issue, adding -qt5 to the .desktop file exec entry works for the Unity8 / preview session

Changed in stock-ticker-mobile-app:
assignee: nobody → Alan Pope γ‹› (popey)

Fix committed into lp:ubuntu-terminal-app at revision 47, scheduled for release in ubuntu-terminal-app, milestone alpha-1

Changed in ubuntu-terminal-app:
status: In Progress → Fix Committed

Fix committed into lp:stock-ticker-mobile-app at revision 72, scheduled for release in stock-ticker-mobile-app, milestone Unknown

Changed in stock-ticker-mobile-app:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notes-app - 1.4+14.04.20140415-0ubuntu1

---------------
notes-app (1.4+14.04.20140415-0ubuntu1) trusty; urgency=low

  [ Bill Filler ]
  * add -qt5 to fix desktop launching (LP: #1288885)
 -- Ubuntu daily release <email address hidden> Tue, 15 Apr 2014 16:43:16 +0000

Changed in notes-app (Ubuntu):
status: New → Fix Released

Fix committed into lp:dropping-letters at revision 46, scheduled for release in dropping-letters, milestone Unknown

Changed in dropping-letters:
status: In Progress → Fix Committed
Changed in ubuntu-calculator-app:
status: Fix Committed → Fix Released
Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
milestone: 1.8 → none
status: Fix Committed → Fix Released
Changed in dropping-letters:
status: Fix Committed → Fix Released
Changed in ubuntu-terminal-app:
importance: Undecided → Low
Changed in ubuntu-terminal-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers