When deploying an environment containing only a Heat generated package, an extra empty stack is created in Heat

Bug #1473129 reported by Michal Gershenzon on 2015-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Murano
Medium
Stan Lagun
Kilo
Undecided
Kirill Zaitsev

Bug Description

When an environment that contains only a Heat generated package is deployed, an extra empty stack is created in Heat.
That means there 2 stacks in total created by the environment - a stack for the heat template and an extra empty stack.

Yuki Nishiwaki (uckey-1067) wrote :

I encountered this phenomenon too. But I don't make out if this is bug.

Changed in murano:
milestone: none → liberty-2
status: New → Confirmed
importance: Undecided → Medium

Fix proposed to branch: master
Review: https://review.openstack.org/207642

Changed in murano:
assignee: nobody → Stan Lagun (slagun)
status: Confirmed → In Progress
tags: added: kilo-backport-potential
tags: added: engine

Reviewed: https://review.openstack.org/207642
Committed: https://git.openstack.org/cgit/openstack/murano/commit/?id=fc586b949d489343de9894ec92d21990f65a1e32
Submitter: Jenkins
Branch: master

commit fc586b949d489343de9894ec92d21990f65a1e32
Author: Stan Lagun <email address hidden>
Date: Fri Jul 31 00:50:34 2015 +0300

    Removes early creation of Heat stack

    Murano environment deployment started with empty stack
    creation so that it can be done prior to keystone token expiration
    for Heat to establish trusts based on user's token.
    When environment does nothing with the stack (for example
    all environment applications are HOT based and deploy into their
    own stacks) empty stack remains. Because most applications
    start their deployment with instance/other resources deployment
    stack will be created early anyway. So this strategy is redundant.

    Change-Id: Id8ec1df2c83f540b272ef70bd054f70de9da7715
    Closes-Bug: #1473129

Changed in murano:
status: In Progress → Fix Committed
summary: - When deploying an environment containnig only a Heat generated package,
+ When deploying an environment containing only a Heat generated package,
an extra empty stack is created in Heat
Changed in murano:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/211155
Committed: https://git.openstack.org/cgit/openstack/murano/commit/?id=35496249d19f4b3f086e14dca964edf43fe9356d
Submitter: Jenkins
Branch: stable/kilo

commit 35496249d19f4b3f086e14dca964edf43fe9356d
Author: Stan Lagun <email address hidden>
Date: Fri Jul 31 00:50:34 2015 +0300

    Removes early creation of Heat stack

    Murano environment deployment started with empty stack
    creation so that it can be done prior to keystone token expiration
    for Heat to establish trusts based on user's token.
    When environment does nothing with the stack (for example
    all environment applications are HOT based and deploy into their
    own stacks) empty stack remains. Because most applications
    start their deployment with instance/other resources deployment
    stack will be created early anyway. So this strategy is redundant.

    Change-Id: Id8ec1df2c83f540b272ef70bd054f70de9da7715
    Closes-Bug: #1473129
    (cherry picked from commit fc586b949d489343de9894ec92d21990f65a1e32)

Changed in murano:
milestone: liberty-2 → 1.0.0
Changed in murano:
milestone: 1.0.0 → 1.0.1

This issue was fixed in the openstack/murano 2015.1.1 release.

This issue was fixed in the openstack/murano 2015.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers