Murano-pkg-check fails to validate version 2.4 ui yaml file

Bug #1722548 reported by Ellen Batbouta on 2017-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Murano
Medium
zhurong

Bug Description

When I tried to validate a Murano package that uses a version 2.4 ui yaml file, here are the errors that I got:

 murano-pkg-check com.oracle.database.OracleDbRAC.zip
UI/OracleDatabaseUi.yaml:3:1: W010 Unknown keyword "Parameters"
UI/OracleDatabaseUi.yaml:12:1: W010 Unknown keyword "ParametersSource"
W082 Incorrect version of UI file "2.4"
UI/OracleDatabaseUi.yaml:209:17: W100 "securitygroup" is not known type. Probably a typo
W120 Unknown "OracleDb.png" in the package
W120 Unknown "License.txt" in the package
W121 Missing "LICENSE" in the package

Ellen Batbouta (ellen-batbouta) wrote :

One of the fixes will be to the file: openstack/murano-pkg-check/blob/master/muranopkgcheck/validators/ui.py

since it has hard-coded values for the UI_VERSION and does not include the version 2.4.

zhurong (zhu-rong) on 2017-11-22
Changed in murano:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → zhurong (zhu-rong)

Fix proposed to branch: master
Review: https://review.openstack.org/522142

Changed in murano:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers