Colon in the string literal leads to a syntax error

Bug #1489824 reported by Alexey Khivin on 2015-08-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Murano
Medium
Stan Lagun

Bug Description

Usually I expect that string literals will not break program execution. And I believe it is true for most of the programming languages that any character in the string literal must not lead to syntax error (except of escape sequences)

In the MuranoPL row with a colon (':') like this
      - $log.debug('debug: {0}', param)
leads to syntax error
but if we remove colon like this
      - $log.debug('debug {0}', param)
it become syntactically correct

I believe that such kind of behaviour should be fixed or should be explained in the MuranoPL documentation at least

My script with the colon at the last row which breaks the Syntax
http://paste.openstack.org/show/430743/

tags: added: engine muranopl
Changed in murano:
status: New → Confirmed
description: updated
Alexey Khivin (akhivin) wrote :

As I understand, comment a whole line should work for YAML but it does not work for MuranoPL
- "$log.debug('debug: {0}', param)"

Changed in murano:
milestone: none → liberty-rc1
assignee: nobody → Stan Lagun (slagun)
importance: Undecided → Critical
Stan Lagun (slagun) wrote :

This cannot be fixed without writing our own parser of MuranoPL classes that would be not strictly YAML based. I'm not sure this can be solved even by custom YAML parser because the bug is likely to be in YAML format itself.

Possible workaround:

1)

- $message: 'debug: {0}'
- $log.debug($message, param)

2)
- !yaql "$log.debug( 'debug: {0}', param)"

Changed in murano:
status: Confirmed → Won't Fix
Changed in murano:
status: Won't Fix → Confirmed
importance: Critical → High
Changed in murano:
milestone: liberty-rc1 → next
tags: added: release-notes
Changed in murano:
milestone: next → mitaka-1
Stan Lagun (slagun) on 2015-11-24
Changed in murano:
importance: High → Medium
Changed in murano:
milestone: mitaka-1 → mitaka-2
Changed in murano:
milestone: mitaka-2 → mitaka-3
Changed in murano:
milestone: mitaka-3 → mitaka-rc1
Changed in murano:
milestone: mitaka-rc1 → next
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers