[engine] output queue name for agent

Bug #1321476 reported by Steve McLellan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Murano
Fix Released
Medium
Stan Lagun

Bug Description

Murano engine defines the agent output queue name (for the listener) in muranoapi/engine/system/agent_listener.py:

    self._results_queue = str('-execution-results-%s' % name.lower())

This can (easily) result in name conflicts between users (or even for the same user in some circumstances). There is a more general authentication problem with the agent queues that will be addressed in a blueprint, but i suggest for now using the environment object id in the same way as when the instance agent queues are set up.

Changed in murano:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano (master)

Fix proposed to branch: master
Review: https://review.openstack.org/105117

Changed in murano:
assignee: nobody → Stan Lagun (slagun)
status: Confirmed → In Progress
Revision history for this message
Stan Lagun (slagun) wrote :

Environment ID cannot be used because it can be any string (for example UUID with dashes) and not every string can be Heat stack name (for example it cannot contain dashes)

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano (master)

Reviewed: https://review.openstack.org/105117
Committed: https://git.openstack.org/cgit/stackforge/murano/commit/?id=f3d0901fbc3d403f1556a0d1b25133e690800d9c
Submitter: Jenkins
Branch: master

commit f3d0901fbc3d403f1556a0d1b25133e690800d9c
Author: Stan Lagun <email address hidden>
Date: Mon Jul 7 15:00:28 2014 +0400

    Use random name for Heat stack name instead of environment's name

    Change-Id: I44de2083aa2d50e6cd3b3b79b204facedaf2b7df
    Closes-Bug: #1321476

Changed in murano:
status: In Progress → Fix Committed
Changed in murano:
milestone: none → juno-2
ruhe (ruhe)
Changed in murano:
status: Fix Committed → Fix Released
Changed in murano:
milestone: juno-2 → 2014.2
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers