[Tomcat] Test testDeploy1 in TomcatTest.yaml fails

Bug #1621018 reported by Valerii Kovalchuk on 2016-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
murano-apps
Low
Valerii Kovalchuk

Bug Description

After changes in the way of running deploy script (deleting template and using runCommand) test case testDeploy1 in TomcatTest.yaml fails with the error:

MuranoPlException: [testtools.matchers._impl.MismatchError]: !=:
reference = u'Deploy Tomcat'
actual = u'''\
Execute #!/bin/bash
# Licensed under the Apache License, Version 2.0 (the "License"); you may
# not use this file except in compliance with the License. You may obtain
# a copy of the License at
#
# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
# License for the specific language governing permissions and limitations
# under the License.

sudo apt-get update
sudo apt-get -y -q install tomcat7
sudo iptables -I INPUT 1 -p tcp -m tcp --dport 8080 -j ACCEPT -m comment --comment "by murano, Tomcat"

The reason is now template.Name is equal to the whole command by default

description: updated
Changed in murano-apps:
importance: Undecided → Low
assignee: nobody → Valerii Kovalchuk (vakovalchuk)
milestone: none → newton-1
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (master)

Fix proposed to branch: master
Review: https://review.openstack.org/366684

Changed in murano-apps:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (master)

Reviewed: https://review.openstack.org/366684
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=5e6b41ffeb0f443c40afdf67dbc96cd09914c3dc
Submitter: Jenkins
Branch: master

commit 5e6b41ffeb0f443c40afdf67dbc96cd09914c3dc
Author: Valerii Kovalchuk <email address hidden>
Date: Wed Sep 7 14:18:04 2016 +0300

    [Tomcat] Add help text to the deploy command

    This will fix the test testDeploy1 which requires template name to
    be equal to 'Deploy Tomcat'

    Change-Id: I030d754ac828b9481234f5833afc0187e9bea930
    Closes-bug: #1621018

Changed in murano-apps:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers