Service naming convention created by Murano app is not clear

Bug #1613651 reported by Ayrat KHAYRETDINOV on 2016-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
murano-apps
Wishlist
Nikolay Makhotkin

Bug Description

Overview:
Kubernetes uses services abstraction in order to expose app to the outside world. When you create a container app for K8s in Murano, it will automatically create a svc if you click “visible from outside” radio button.
We noticed that inside of K8s all services created by murano has following naming convention: “svc-random”.
Reference: https://github.com/openstack/murano-apps/blob/master/Docker/Kubernetes/KubernetesCluster/package/Classes/KubernetesCluster.yaml#L223
This makes very hard to understand which services belong to which application when you do verification with “kubectl get services” command.
We suggest that services name convention will change to “applicationName-random”.
Same should be for Deployments if those will be introduced to Murano Apps.

Actual behavior:
Services for app has created by Murano K8s App is “svc-random”

Proposed behavior:
Services for app has created by Murano K8s App is “applicationName-random”
Or
Services for app has created by Murano K8s App should be called “applicationName” but

Attached logs:
ubuntu@murano-sjevlirvfp6t34i-kube-1-jah3qodpxsq2:~/go/src/github.com/askcarter/workshop-in-a-box/bundles/kubernetes-101/kubernetes$ kubectl get services
NAME CLUSTER-IP EXTERNAL-IP PORT(S) AGE
svc-aeggkirvjf3va4j 11.1.81.239 <none> 80/TCP 1d
svc-fuoknirx98k2f4o 11.1.248.106 <none> 1029/TCP 1h
svc-hsifairx9857z4n 11.1.207.192 <none> 1028/TCP 1h
svc-qjdprirx93fhh4l 11.1.53.140 <none> 1026/TCP 1h
svc-qxfelirx91q304k 11.1.96.49 <none> 1025/TCP 1h
svc-vhggjirx97o6x4m 11.1.186.77 <none> 1027/TCP 1h

description: updated
tags: added: k8s
Changed in murano-apps:
milestone: none → newton-3
importance: Undecided → Wishlist
status: New → Confirmed
Changed in murano-apps:
assignee: nobody → Nikolay Makhotkin (nmakhotkin)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (master)

Fix proposed to branch: master
Review: https://review.openstack.org/357656

Changed in murano-apps:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (master)

Reviewed: https://review.openstack.org/357656
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=2fe1ddc8e3c8a9f2d07c1f6bde25156f39776b62
Submitter: Jenkins
Branch: master

commit 2fe1ddc8e3c8a9f2d07c1f6bde25156f39776b62
Author: Nikolay Mahotkin <email address hidden>
Date: Fri Aug 19 10:47:59 2016 +0300

    [K8s] Fixing service naming

     * Due to the service name length limitation
       it needs to be cut to 24 characters.

    Closes-Bug: #1613651

    Change-Id: Id2d68346034c0697f3fb41a090201e8736f8deec

Changed in murano-apps:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (stable/mitaka)

Fix proposed to branch: stable/mitaka
Review: https://review.openstack.org/361135

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (stable/mitaka)

Reviewed: https://review.openstack.org/361135
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=6277ddf2047aa272e693ccb0dd49de2ed550e63a
Submitter: Jenkins
Branch: stable/mitaka

commit 6277ddf2047aa272e693ccb0dd49de2ed550e63a
Author: Nikolay Mahotkin <email address hidden>
Date: Fri Aug 19 10:47:59 2016 +0300

    [K8s] Fixing service naming

     * Due to the service name length limitation
       it needs to be cut to 24 characters.

    Closes-Bug: #1613651

    Change-Id: Id2d68346034c0697f3fb41a090201e8736f8deec
    (cherry picked from commit 2fe1ddc8e3c8a9f2d07c1f6bde25156f39776b62)

tags: added: in-stable-mitaka
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers