Gateway incorrect behavior when deploying app with same name.

Bug #1613631 reported by Ayrat KHAYRETDINOV on 2016-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
murano-apps
Medium
Nikolay Makhotkin

Bug Description

Overview

We noticed a minor issue in case you have a K8s Cluster (both Ubuntu and Deb based) setup with 1 Gateway Node, 1 Master and 1 Node. If you trying to create an App e.g. Http and deploy it. Gateway will provide a single endpoint so that you can access this App from outside in the form of https://FIP_A:port_number_A which is expected behavior. If you going to create another Http App with the same name on a new Pod it will create two Endpoints in the form of https://FIP_1:port_number_A, https://FIP_1:port_number_B. We think that expected behavior should be 1 endpoint as https://FIP_1:port_number_B.
Probable root cause is that Gateway filters by the name of the App, and since it has the same name it prints 2 endpoints. In case you create an app with different name it will create 1 endpoint per each app.

Actual behavior
GW creates N number of endpoints if you have N number of App with same name.
Expected behavior
GW creates 1 endpoint per each App.

Revision history for this message
Ayrat KHAYRETDINOV (ayrat-khayretdinov) wrote :
tags: added: k8s
Changed in murano-apps:
assignee: nobody → Nikolay Makhotkin (nmakhotkin)
Changed in murano-apps:
assignee: Nikolay Makhotkin (nmakhotkin) → nobody
status: New → Confirmed
assignee: nobody → Nikolay Makhotkin (nmakhotkin)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (master)

Fix proposed to branch: master
Review: https://review.openstack.org/357823

Changed in murano-apps:
status: Confirmed → In Progress
Changed in murano-apps:
importance: Undecided → Medium
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (master)

Reviewed: https://review.openstack.org/357823
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=d2c3f45f5fc96594aa7c8770faf9650e9cb151ae
Submitter: Jenkins
Branch: master

commit d2c3f45f5fc96594aa7c8770faf9650e9cb151ae
Author: Nikolay Mahotkin <email address hidden>
Date: Fri Aug 19 13:32:20 2016 +0300

    [k8s] Restrict getEndpoints to search only in current pod

     * If we have a k8s cluster installed and
       then deploy 2 apps, each on separate pod,
       then in logs we will see 2 endpoints for
       2nd app. Then we will see 3 endpoints for
       next pod/app deployment. The reason is searching
       endpoints was done by whole k8s cluster but it
       should rather be only by current pod.
       Now it is fixed.

    Closes-Bug: #1613631

    Change-Id: I730016dcd55a922ac6c9ee20f9de500f7831f9c3

Changed in murano-apps:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (stable/mitaka)

Fix proposed to branch: stable/mitaka
Review: https://review.openstack.org/358552

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (stable/liberty)

Fix proposed to branch: stable/liberty
Review: https://review.openstack.org/358553

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to murano-apps (stable/kilo)

Fix proposed to branch: stable/kilo
Review: https://review.openstack.org/358554

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (stable/mitaka)

Reviewed: https://review.openstack.org/358552
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=35ae10184e5962048855e771fd03dca4fd26bb99
Submitter: Jenkins
Branch: stable/mitaka

commit 35ae10184e5962048855e771fd03dca4fd26bb99
Author: Nikolay Mahotkin <email address hidden>
Date: Fri Aug 19 13:32:20 2016 +0300

    [k8s] Restrict getEndpoints to search only in current pod

     * If we have a k8s cluster installed and
       then deploy 2 apps, each on separate pod,
       then in logs we will see 2 endpoints for
       2nd app. Then we will see 3 endpoints for
       next pod/app deployment. The reason is searching
       endpoints was done by whole k8s cluster but it
       should rather be only by current pod.
       Now it is fixed.

    Closes-Bug: #1613631

    Change-Id: I730016dcd55a922ac6c9ee20f9de500f7831f9c3

tags: added: in-stable-mitaka
tags: added: in-stable-liberty
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (stable/liberty)

Reviewed: https://review.openstack.org/358553
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=19e763e5899c6c4147567d2456588c6541537011
Submitter: Jenkins
Branch: stable/liberty

commit 19e763e5899c6c4147567d2456588c6541537011
Author: Nikolay Mahotkin <email address hidden>
Date: Fri Aug 19 13:32:20 2016 +0300

    [k8s] Restrict getEndpoints to search only in current pod

     * If we have a k8s cluster installed and
       then deploy 2 apps, each on separate pod,
       then in logs we will see 2 endpoints for
       2nd app. Then we will see 3 endpoints for
       next pod/app deployment. The reason is searching
       endpoints was done by whole k8s cluster but it
       should rather be only by current pod.
       Now it is fixed.

    Closes-Bug: #1613631

    Change-Id: I730016dcd55a922ac6c9ee20f9de500f7831f9c3

tags: added: in-stable-kilo
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to murano-apps (stable/kilo)

Reviewed: https://review.openstack.org/358554
Committed: https://git.openstack.org/cgit/openstack/murano-apps/commit/?id=c8e52c3689361d92f9a24bbb8e0e6cc146f6364b
Submitter: Jenkins
Branch: stable/kilo

commit c8e52c3689361d92f9a24bbb8e0e6cc146f6364b
Author: Nikolay Mahotkin <email address hidden>
Date: Fri Aug 19 13:32:20 2016 +0300

    [k8s] Restrict getEndpoints to search only in current pod

     * If we have a k8s cluster installed and
       then deploy 2 apps, each on separate pod,
       then in logs we will see 2 endpoints for
       2nd app. Then we will see 3 endpoints for
       next pod/app deployment. The reason is searching
       endpoints was done by whole k8s cluster but it
       should rather be only by current pod.
       Now it is fixed.

    Closes-Bug: #1613631

    Change-Id: I730016dcd55a922ac6c9ee20f9de500f7831f9c3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers