Mundus Home Folder Cleaner

Mundus not working on Debian Sid

Reported by Ustilago on 2012-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mundus
Undecided
Unassigned

Bug Description

Hi,

I installed mundus from mundus_2.2.0-1_all.deb package on my Debian Sid, but I can't launch it, it complains about bytecode :

$ /usr/bin/mundus
ERROR: #2: Cannot load class 'Main': Bytecode too recent. Please upgrade Gambas.

Here are the gambas libraries installed on my system :

$ dpkg -l |grep gambas
ii gambas2-gb-compress 2.21.0-2 amd64 The Gambas compression component
ii gambas2-gb-compress-bzlib2 2.21.0-2 amd64 The Gambas bzlib2 component
ii gambas2-gb-compress-zlib 2.21.0-2 amd64 The Gambas zlib compression component
ii gambas2-gb-db 2.21.0-2 amd64 Gambas database access common libraries
ii gambas2-gb-db-postgresql 2.21.0-2 amd64 The PostgreSQL driver for the Gambas database component
ii gambas2-gb-form 2.21.0-2 all A gambas native form component
ii gambas2-gb-gtk 2.21.0-2 amd64 The Gambas gtk component
ii gambas2-gb-gui 2.21.0-2 amd64 The graphical toolkit selector component
ii gambas2-gb-pdf 2.21.0-2 amd64 The Gambas pdf component
ii gambas2-gb-qt 2.21.0-2 amd64 The Gambas Qt GUI component
ii gambas2-gb-qt-ext 2.21.0-2 amd64 The Gambas extended Qt GUI component
ii gambas2-gb-qt-kde 2.21.0-2 amd64 The Gambas KDE component
ii gambas2-gb-qt-kde-html 2.21.0-2 amd64 The Gambas KHTML component
ii gambas2-gb-settings 2.21.0-2 all Gambas utilities class
ii gambas2-gb-xml 2.21.0-2 amd64 Gambas XML component
ii gambas2-runtime 2.21.0-2 amd64 The Gambas runtime
ii gambas3-gb-crypt 3.1.1-2+b2 amd64 Gambas crypt encription component
ii gambas3-gb-desktop 3.1.1-2+b2 amd64 Gambas Portland project compatibility component
ii gambas3-gb-form 3.1.1-2 all Gambas native form component
ii gambas3-gb-gtk 3.1.1-2+b2 amd64 Gambas gtk component
ii gambas3-gb-gui 3.1.1-2+b2 amd64 Gambas graphical toolkit selector component
ii gambas3-gb-image 3.1.1-2+b2 amd64 Gambas image effects component
ii gambas3-gb-net 3.1.1-2+b2 amd64 Gambas networking component
ii gambas3-gb-net-curl 3.1.1-2+b2 amd64 Gambas advanced networking component
ii gambas3-gb-qt4 3.1.1-2+b2 amd64 Gambas Qt GUI component
ii gambas3-gb-settings 3.1.1-2 all Gambas utilities class
ii gambas3-runtime 3.1.1-2+b2 amd64 Gambas runtime interpreter

If I uninstall all gambas2 librairies, I still have the error.

Regards,

Sebastien

sebikul (sebikul) wrote :

Mundus strictly depends on gambas3 >= 3.3.0. The gambas2 packages are not needed at all. The gambas3 packages you are using are from version 3.1.1, which won't work. Besides being outdated because they are not maintained at all, they are wrongly packaged, but might work.

You have two options, you can either compile the newer gambas3 packages yourself (long and tedious process), or download the Mundus source archive and compile a gambas binary for your installed version.

For the later, download the source archive, extract, execute make, and then sudo make install (be sure to uninstall the Mundus .deb first)

I'm really sorry about this, but Gambas3 availability on Debian is scarce. We are in the process of creating a repository, but it takes a lot of time.

sebikul (sebikul) on 2012-12-05
Changed in mundus:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers