Mugshot has a hard dependency on AccountsService

Bug #1311938 reported by Sean Davis
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mugshot
Fix Released
High
Unassigned
mugshot (Debian)
Fix Released
Unknown

Bug Description

Mugshot seems to depend on AccountsService. This functionality should be optional.

corsac@scapa: mugshot
Traceback (most recent call last):
  File "/usr/bin/mugshot", line 35, in <module>
    mugshot.main()
  File "/usr/lib/python3/dist-packages/mugshot/__init__.py", line 45, in main
    window = MugshotWindow.MugshotWindow()
  File "/usr/lib/python3/dist-packages/mugshot_lib/Window.py", line 50, in __new__
    new_object.finish_initializing(builder)
  File "/usr/lib/python3/dist-packages/mugshot/MugshotWindow.py", line 217, in finish_initializing
    self.init_user_details()
  File "/usr/lib/python3/dist-packages/mugshot/MugshotWindow.py", line 225, in init_user_details
    image = self.accounts_service_get_user_image()
  File "/usr/lib/python3/dist-packages/mugshot/MugshotWindow.py", line 442, in accounts_service_get_user_image
    None)
gi._glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
----

Looking at the stacktrace, it seems to require AccountService, which is
not installed here (I don't want it), but since the package doesn't
Depends on it (nor Recommends it), I assume there's a bug somewhere.

Related branches

Sean Davis (bluesabre)
Changed in mugshot:
status: New → Confirmed
description: updated
Changed in mugshot:
importance: Undecided → High
Changed in mugshot (Debian):
status: Unknown → New
Sean Davis (bluesabre)
Changed in mugshot:
status: Confirmed → Fix Committed
Changed in mugshot (Debian):
status: New → Fix Released
Sean Davis (bluesabre)
Changed in mugshot:
milestone: none → 0.2.4
Sean Davis (bluesabre)
Changed in mugshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.