mugshot is unable to store profile picture

Bug #1298665 reported by Daniel Kessel on 2014-03-27
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mugshot
High
Unassigned
mugshot (Ubuntu)
High
Unassigned

Bug Description

I recorded a profile picture using the webcam. Mugshot seems to be unable to store the profile picture at "~/.face".

When running "mugshot -vv", selecting the recorded webcam image causes apport to pop up.

Users cannot record their own profile picture using the application and their webcam.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: mugshot 0.2.2-1
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CurrentDesktop: XFCE
Date: Thu Mar 27 23:36:26 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-03-27 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Beta i386 (20140326)
PackageArchitecture: all
SourcePackage: mugshot
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel Kessel (dkessel) wrote :
Daniel Kessel (dkessel) wrote :

Log file is here:

http://paste.ubuntu.com/7165417/

I think the relevant part is:
DEBUG:mugshot: set_user_image() 'Setting user profile image to /tmp/tmp7w013lj0'
DEBUG:mugshot: on_apply_button_clicked() 'Applying changes...'
DEBUG:mugshot: get_chfn_details_updated() 'Checking if chfn details have been modified.'
DEBUG:mugshot: get_chfn_details_updated() 'chfn details have NOT been modified.'
DEBUG:mugshot: get_libreoffice_details_updated() 'LibreOffice is not installed or has not been opened. Not updating.'
DEBUG:mugshot: save_image() 'Photo updated, saving changes.'
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/mugshot/MugshotWindow.py", line 315, in on_apply_button_clicked
    self.save_image()
  File "/usr/lib/python3/dist-packages/mugshot/MugshotWindow.py", line 382, in save_image
    self.accounts_service_set_user_image(face)
  File "/usr/lib/python3/dist-packages/mugshot/MugshotWindow.py", line 409, in accounts_service_set_user_image
    None)
gi._glib.GError: GDBus.Error:org.freedesktop.Accounts.Error.Failed: file '/home/daniel/.face' is too large to be used as an icon

AccountsService complains that the file size of the photo exceeds the artificial limit (1MB).

http://cgit.freedesktop.org/accountsservice/tree/src/user.c#n1411

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mugshot (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) wrote :

This has been fixed in trunk.

Changed in mugshot:
status: New → Fix Committed
importance: Undecided → High
Sean Davis (bluesabre) wrote :

Fixed in mugshot 0.2.3

Changed in mugshot:
status: Fix Committed → Fix Released

It renders essential functionality of the package (or a dependent one) broken.

Changed in mugshot (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mugshot - 0.2.3-1

---------------
mugshot (0.2.3-1) unstable; urgency=medium

  * New upstream release. LP: #1302906
    - fix: mugshot is unable to store profile picture (LP: #1298665)

 -- Jackson Doak <email address hidden> Sat, 05 Apr 2014 12:41:01 +1100

Changed in mugshot (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers